WordPress.org

Ready to get started?Download WordPress

Forums

Background Manager
[resolved] Background per page don't work (9 posts)

  1. erspoelstra
    Member
    Posted 1 year ago #

    I installed everything as instructed, but the background per page don't work. I get the same background on every page, although I set the background on the page to a different image set.

    When I look in the source of that page, I see that the wrong current_background is selected:

    /* <![CDATA[ */
    var myatu_bgm = {"current_background":{"id":409, "url":"http:\/\/xxxxxxx\/wp-content\/uploads\/2012\/06\/25870990-groot.jpg","alt":"","desc":"", "caption":"25870990-groot","link":"","thumb":"http:\/\/xxxxx\/wp-content\/uploads\/2012\/06\/25870990-groot-150x150.jpg","bg_link":"","transition":"crossfade", "transition_speed":0},"change_freq":"0","active_gallery":"408","is_fullsize":"true","is_preview":"false", "initial_ease_in":"false","info_tab_thumb":"true","bg_click_new_window":"false","bg_track_clicks":"false", "bg_track_clicks_category":"Background Manager","fs_center":"true"};
    /* ]]> */

    The active gallery is 408 but should be 410 (according to the custom field on the page (myatu_bgm_active_gallery).

    Can you please help me with this issue?

    http://wordpress.org/extend/plugins/background-manager/

  2. erspoelstra
    Member
    Posted 1 year ago #

    Oh, and by the way, the overlay is working per page (I get different overlays, but with the same background everywhere)

  3. circuitor
    Member
    Posted 1 year ago #

    We are having the same issue since updating to BM 1.1 and WP 3.4 "Green" this morning.

    Update:
    We tried reverting to the older plugin (BM 1.0.25) but this does not work either because then no background shows up at all. Apparently something has changed in the database. Reverting not recommended.
    ~C

  4. innoventu
    Member
    Posted 1 year ago #

    Exactly the same issue here.

    Waiting for a workaround or solution, its holding up my project at the moment.

    Thanks in advance.

    http://wordpress.org/extend/plugins/background-manager/

  5. myatu
    Member
    Plugin Author

    Posted 1 year ago #

    Hi!

    Yes, this is a bug that managed to make its way past the last tests and I'm uploading a fix as I'm writing this (version 1.1.1). My apologies!

  6. erspoelstra
    Member
    Posted 1 year ago #

    Thank you for the quick fix, I downloaded the fix and everything seems to be working fine!

    If its working for the others, this topic can be marked as 'resolved'.

  7. innoventu
    Member
    Posted 1 year ago #

    Thanks for the quick fix, everything is working fine again here too!

  8. circuitor
    Member
    Posted 1 year ago #

    Fantastic! Thanks for the fast fix.
    All is working well now. :)

  9. myatu
    Member
    Plugin Author

    Posted 1 year ago #

    Glad to hear it's fixed. Sorry about that!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.