WordPress.org

Ready to get started?Download WordPress

Forums

Background Manager
[resolved] Background manager not working in 1and1 (9 posts)

  1. Bloodofeve
    Member
    Posted 2 years ago #

    Hi Myatu,
    I'm using 1and1 hosting, and have hit an issue.
    I have added the AddType x-mapp-php6 .php to my .htaccess file
    as below:-

    # BEGIN WordPress
    AddType x-mapp-php6 .php
    
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    But I am still getting the following error
    "The plugin "Background Manager" requires PHP version 5.3.0 or better, but version 5.2.17 was detected.
    Because of this error, the plugin was automatically deactivated to prevent it from causing further problems with your WordPress site.
    Error source: /homepages/38/d168328470/htdocs/.rydecarnival2012/wp-content/plugins/background-manager/background-manager.php"

    I have deleted the original .htaccess file and uploaded the new file to no avail.

    I have set up a check file which is
    http://www.rydecarnival.com/myserver.php
    and it seems that the system is only allowing PHP5.2 to work.
    Any suggestions?

    http://wordpress.org/extend/plugins/background-manager/

  2. myatu
    Member
    Plugin Author

    Posted 2 years ago #

    Hi, instead of AddType, try AddHandler, like so:

    AddHandler x-mapp-php6 .php
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    I'll correct this in the FAQ as well.

    Also note that anything between the # BEGIN WordPress and matching end may be changed by WordPress (thus overwrite your AddHandler addition).

  3. Bloodofeve
    Member
    Posted 2 years ago #

    Dear Myatu,
    thank you ever so much!This has cured the issue and the Backgrounds now work perfectly.
    I can't recommend your plugin enough it is fantastic.
    Kind regards
    Claire

  4. myatu
    Member
    Plugin Author

    Posted 2 years ago #

    I'm glad to hear that, and thanks for the kudos :)

  5. nutrivelo
    Member
    Posted 1 year ago #

    Hi Myatu, I also having the same problem. But I am still new to wordpress and donno what to do in order to solve the problem. I have no idea what is the .htaccess file and don't know how to upload a new .htaccess file to replace the original one.

    Could you possible help me out in this? I really do love your background manager after watched the demo of it.

    Thank you.

  6. myatu
    Member
    Plugin Author

    Posted 1 year ago #

    Hello nutrivelo,

    In most cases, WordPress should already have created a .htaccess file and you would have to edit that.

    Exactly what you edit depends on your web host - and keep in mind, some web hosts don't use .htaccess files, so this method may not work in all cases.

    Accessing the file is often done through an FTP client, of which plenty free ones can be found through Google. Your web host should have given you instructions, or at the very least a username/password and URL to use for the FTP client.

  7. leopardman
    Member
    Posted 1 year ago #

    Hi, same problem here...
    I copied the code above, but that crashed mine.

    Any advice...?
    This is the existing relevant part of .htaccess...

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    </IfModule>
    
    # END WordPress
  8. leopardman
    Member
    Posted 1 year ago #

    By the way, my provider is webhost4life, who seems to have no clue what I'm talking about...

  9. myatu
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Sorry to hear you're having trouble with this. Many web hosting providers have their own way of enabling PHP 5.3, provided they support it in the first place (and most good ones do).

    In the case of the original poster, this was 1and1, and they provide details on how to enable PHP 5.3 here: http://faq.1and1.com/scripting_languages_supported/htaccess/7.html

    So you would have to ask webhost4life if they support PHP 5.3 (or better), and if they do, if there's a way to enable it for your website or perhaps migrate your website to another server (that supports PHP 5.3).

    I can understand some of the frustration surrounding the PHP 5.3 requirement, however, it's been around for 3+ years now and offers better performance as well as security enhancements. That alone should outweigh the downsides of upgrading.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic