WordPress.org

Ready to get started?Download WordPress

Forums

Awesome Google Adsense
Causing 500 error (10 posts)

  1. TennaWho
    Member
    Posted 1 year ago #

    I got the white screen of death as of yesterday and could not log in to my admin page. I'm new to wordpress so this was confusing to me and it took until today to really figure it out. I disabled this plugin after finding the following in my error log:

    [08-Oct-2012 12:25:03] PHP Warning: fgets(): supplied argument is not a valid stream resource in /home3/tennawho/public_html/wp-content/plugins/awesome-google-adsense/awesome-google-adsense.php on line 244

    Love this plugin, hope this is fixed soon!

    http://wordpress.org/extend/plugins/awesome-google-adsense/

  2. Vantise
    Member
    Posted 1 year ago #

    How did you disable it???

  3. emueses
    Member
    Posted 1 year ago #

    To disable it, all you have to do is FTP to the website and delete the folder under /wp-content/plugin/

    BTW, I'm having the same problem as TennaWho, so i guess that makes three.

  4. TennaWho
    Member
    Posted 1 year ago #

    I went into my host file server and created a "plugins_old" folder that I moved it to for now until the script is fixed. I could've deleted it, but I didn't want to lose the settings I already have.

  5. emueses
    Member
    Posted 1 year ago #

    The problem seems to be with the verify Adult Content URL (http://awsmteam.com/verify_adult_content.php) which seems to be down.

    By quickly commenting out the function on line 243 in the awesome-google-adsense.php, you get the functionality back; like so:

    /*     <<<<<- Add This
    function verify_adult_content() {
    	$allow = ini_get('allow_url_fopen');if($allow != 1){ini_set("allow_url_fopen", 1);}$allow = ini_get('allow_url_fopen');if($allow == 0){return false;}$_data = array('site'=>get_option('siteurl'), 'plugin'=>'awesome_google_ads');$data = array();while(list($n,$v) = each($_data)){$data[] = "$n=$v";}$data = implode('&', $data);$url = parse_url('http://awsmteam.com/verify_adult_content.php');$host = $url['host'];$path = $url['path'];$port = 80;$data_length = strlen($data);$header  = "POST $path HTTP/1.0\r\n";$header .= "Host: $host\r\n";$header .= "User-Agent: DoCoMo/1.0/P503i\r\n";$header .= "Content-type: application/x-www-form-urlencoded\r\n";$header .= "Content-length: $data_length\r\n";$header .= "\r\n";$fp = fsockopen($host,$port,$err_num,$err_msg,120);fputs($fp, $header . $data);while(trim(fgets($fp,4096)) != '');while(!feof($fp)){$response .= fgets($fp,4096);}fclose($fp);
    	if ($response == 'OK'){
    		return true;
    	}
    	else{
    		return false;
    	}
    }
    */  <<<--- Add This

    You will need to also comment out the function call on line 259:

    /*     <<<<<- Add This
    	verify_adult_content();
    */	  <<<<<--- Add this
  6. emueses
    Member
    Posted 1 year ago #

    TennWho, by deleting the plugin you don't loose the settings as those are kept in the database.

  7. TennaWho
    Member
    Posted 1 year ago #

    Thanks emueses! As I said, I'm still new to WP so I didn't realize they would be saved. I really appreciate the help!

  8. emueses
    Member
    Posted 1 year ago #

    The same thing happened 11 months ago and they blame it on DNS. You can see the threat here

  9. emueses
    Member
    Posted 1 year ago #

    I don't know about you, but after commenting that part of the code, my website is now really, really fast! (admin pages, individual post, etc.)

  10. HappyBird
    Member
    Posted 1 year ago #

    I also have a problem with Awesome Google Adsense plugin. When I deactivated it and deleted it, the configuration of my site was still not back to normal. There are one or two large square empty block in my post and pages. I have also deleted the file in Myphp from my BlueHost host page, but the post and page still not back to normal. So what I can do next to restore my site? Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.