WordPress.org

Ready to get started?Download WordPress

Forums

Awebsome! Online Registered Users Widget
[resolved] Not showing admin as being online (12 posts)

  1. brasofilo
    Member
    Posted 2 years ago #

    hola Raul,

    i'm running WordPress 3.2.1 and the widget is not showing a green icon for me, although i'm connected...

    and if you're planning to update the plugin, I'd suggest adding a Dashboard widget option, so as to have the same functionality in the backend

    thanks,
    Rodolfo

    http://wordpress.org/extend/plugins/awebsome-online-registered-users-widget/

  2. Raul Illana
    Member
    Plugin Author

    Posted 2 years ago #

    Yo brasofilo!

    Thanks for the feedback, so much appreciated. I was also thinking in add an option to show gravatars too. :)

    BTW, I've not enough time right now to update the plugins, but surely I will in the next months.

    I need to update and fix the actual 3 plugins I've released (some revamps needed to include APIs), and release some more updated.

    If you have any other suggestions, I'll be watching.

    Best!
    R

  3. Raul Illana
    Member
    Plugin Author

    Posted 1 year ago #

    Updated!

    Enjoy. :)

  4. brasofilo
    Member
    Posted 1 year ago #

    che, gracias por el feedback y el Dashboard widget!
    :o[)

  5. mshumar
    Member
    Posted 1 year ago #

    great plugin! But I am having the same problem as the original poster. The widget is not showing the admin as online. FYI, I am using wordpress 3.1.4 (can't currently upgrade past this). Any insight why it's not working for admins?

    Thanks again for the cool plugin.

  6. brasofilo
    Member
    Posted 1 year ago #

    mshumar, sorry to hear you're locked in 3.1.4 :/

    it's a long shot, but try changing the add_action (at the very beginning of the plugin) to this:

    add_action('widgets_init', 'init_oruw_plugin');
    function init_oruw_plugin() {
        register_widget("Awebsome_ORUW");
    }

    Oh, yes, mostly important: what Awebsome version are you using?

  7. mshumar
    Member
    Posted 1 year ago #

    Brasofilo, thanks for the quick response! Unfortunately the long shot didn't seem to work. Admin is still showing as offline even after the change.

    Also, I am using version 2.0 of Awebsome.

    Not terrible if it doesn't show me (the admin) as online though, as I can see if the other members are online.

  8. brasofilo
    Member
    Posted 1 year ago #

    np :)

    It was a bad shot, as a matter of fact, the plugin wouldn't be working if create_function was the issue... It was the first I saw, but hence...
    (@Raul, if not mistaken that doesn't work in PHP 5.2)

    Took another look at the code but can't see nothing at first that could be doing this... Have you tested with another admin? And also being logged with both at the same time.

  9. mshumar
    Member
    Posted 1 year ago #

    I have not tested with another admin (currently I am the only one). I will be adding a few users soon, and a couple potentially as admins, so I'll keep you posted on how it works with them added. :)

  10. Raul Illana
    Member
    Plugin Author

    Posted 1 year ago #

    Hi fellas!

    @brasofilo create_function is PHP 4 >= 4.0.1, PHP 5 :D

    @mshumar please try adding a fake admin user to test this if you can. Also try deactivating plugins. I'm not having any issues in my dev site. :\

    I'll keep watching.

    Best!

  11. mshumar
    Member
    Posted 1 year ago #

    weird (but awesome), it's working now on my end. I added a user an an editor earlier today, and now when I log in (as admin) it is showing me as online! Not sure why its working now and wasn't before, but I'll take it!!!

    Thanks again fro the help guys! great plugin :)

  12. Raul Illana
    Member
    Plugin Author

    Posted 1 year ago #

    Cool!

    Enjoy. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic