WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: AWeber Registration Integration] Appears broken in WP 2.8.5 (2 posts)

  1. mbeneteau
    Member
    Posted 4 years ago #

    Getting PHP errors in WP 2.8.5. These can be solved by deleting the function check_opt_in and the register (... , "check_opt_in") around about line 275 -- it then works perfectly. Waiting for response from the author on this one.

    Also note that to get the required aweber parameters (Form ID and Unit), you need to paste the aweber javascript code-up into a browser window, which will reveal the form variables.

    http://wordpress.org/extend/plugins/aweber-registration-integration/

  2. GKauten
    Member
    Posted 4 years ago #

    Version 1.2.1 released last night fixes the issues seen in the check_opt_in() function which occur after upgrading to WordPress 2.8.5 and up. It also corrects an issue that was seen with the function used to prevent duplicate email addresses from being registered with the AWeber system.

    Regarding the form parameters required, the plugin upgrade also includes instructions for how to retrieve the variables required. From the AWeber control panel, when viewing your forms, clicking on the "Get HTML" link for the desired form results in a popup window. This window by default shows the code for the Javascript form, however there is also a link at the top of the popup titled "Raw HTML Version" which then reveals the parameters required by the plugin. This allows users to retrieve the parameters without having to sift through the Javascript resource.

Topic Closed

This topic has been closed to new replies.

About this Topic