WordPress.org

Ready to get started?Download WordPress

Forums

AWD Weight/Country Shipping for WooCommerce
[resolved] Shipping not Taxable (9 posts)

  1. budThornhill
    Member
    Posted 1 year ago #

    I'm using this with WooCommerce 1.6.5.2. I love the easy setup. i haven't had the issues the others have brought up, but I did notice that my taxes aren't being applied to shipping.

    I have the Tax Status set to Taxable. Yet when I manually calculate the taxes,the shipping is not taxed.

    Any ideas?

    Thanks,

    Bryan

    http://wordpress.org/extend/plugins/awd-weightcountry-shipping/

  2. PozHonks
    Member
    Posted 1 year ago #

    I confirm this bug. Tax is working with flat rate for example, but not with AWD.
    Please, Andy, fix this bug quickly.
    Thank you.

  3. Andy_P
    Member
    Plugin Author

    Posted 1 year ago #

    Thank you for your feedback guys, will have a look at this.

  4. cheryl2010
    Member
    Posted 1 year ago #

    Andy, I'm having the same problem. The plugin is not taxing the shipping cost. I know this is a freebie and shouldn't expect much at this point, but need to know if this bug will be resolved instantly as my client's site is going live next week. Otherwise, of course, I'll have to find another plugin that will work properly.

    Thank you ...

  5. Christopher Aceto
    Member
    Posted 1 year ago #

    I too can confirm that taxes are not being calculated although "Taxable" has been selected. This plugin would be great if we could get that functioning.

    gj.

    C

  6. nichart
    Member
    Posted 1 year ago #

    I have the same problem. Hope we can get a fix on this soon. Thank you.

  7. PozHonks
    Member
    Posted 1 year ago #

    I have found the bug. After few testings, it seems to work for me. Open the file shipping-awd.php, go to line 167 and replace:
    'calc_tax' => $taxable
    with
    'calc_tax' => 'per_order',

    By comparing the flate rate file (supplied by woocommerce) with awd, I found this difference.

    Hope this will help Andy for a better bug fix ?

  8. nichart
    Member
    Posted 1 year ago #

    Thanks @PozHonks, your solution worked for me :o)

  9. Andy_P
    Member
    Plugin Author

    Posted 1 year ago #

    Thank you PozHonks for fixing this, it is included in current update.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.