WordPress.org

Ready to get started?Download WordPress

Forums

Automatic WordPress Backup
Automatic WordPress Backup zip not found (8 posts)

  1. AutomatedRig
    Member
    Posted 3 years ago #

    I think that is my issue anyway, I have reviewed the requirements and everything seems to be good. The only red on my plugin settings page for this is the last item at the bottom of the page "zip not found". Any help would be appreciated. Thanks.

    http://wordpress.org/extend/plugins/automatic-wordpress-backup/

  2. arnaudin
    Member
    Posted 3 years ago #

    I am having this same problem. Is there any workaround? After a call to support it sounds like the host is not going to install zip for me.

  3. arnaudin
    Member
    Posted 3 years ago #

    Update: I found a more helpful support person who told me zip was actually already on the server. I updated the "automatic-wordpress-backup.php" file such that the shell_exec commands referenced the absolute path to zip which was "/usr/bin/zip" instead of simply "zip"

  4. cw17s0n
    Member
    Posted 3 years ago #

    @arnaudin I seem to have the same issue you had, I've been going through and replacing "zip" with "/usr/bin/zip" to no avail, any chance you could tell me which lines need to changed? Thanks

  5. arnaudin
    Member
    Posted 3 years ago #

    Line 712: $result = shell_exec('/usr/bin/zip -r ' . $file . ' ' . implode(' ', apply_filters('awb_backup_folders', $backups)) . ' -x *uploads/awb*');

    Line 723: $result = shell_exec('/usr/bin/zip -u ' . $file . ' awb-database-backup.sql');

    Line 749: $result = shell_exec('/usr/bin/zip -u ' . $file . ' manifest.txt');

  6. cw17s0n
    Member
    Posted 3 years ago #

    Thanks, I'll have to keep digging, I have the same thing you do, and my host said zip is installed and available at the path /usr/bin/zip. But the plugin still says zip not found.

  7. AutomatedRig
    Member
    Posted 3 years ago #

    Hey all, haven't been around for a bit. Just an update on my end > basically it just started working for me. When I clicked the manual update at the beginning it wouldn't take. I walked away from it for a day to think about it. Reloaded my secret key etc from s3 and let it go. The zip not found is still there but every backup is sent to my bucket so I'm happy. Sorry for not being able to shed any light. It's a great plugin but not even as much as a response from the developer after I submitted a request for support. I am not adverse to paying for the support (although I filled out the free support form) there wasn't even a confirmation email stating that he'd received the request. If it had bumped back to me and said for quicker service then I would have paid. I just have a problem with paying up front for something I am putting out there with out a confirmation that I'll receive any service.

  8. Hasitha Prabath
    Member
    Posted 2 years ago #

    Same here.
    I'm deactivate this plugin and installed BackWPup. It works perfectly.
    http://wordpress.org/extend/plugins/backwpup/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic