WordPress.org

Ready to get started?Download WordPress

Forums

Auto ThickBox Plus
[resolved] Border radius not visable on iframe (14 posts)

  1. hunnsdon
    Member
    Posted 2 years ago #

    I'm using the latest version of chrome browser.

    The iframe popup works but if I use rounded corner for the order the are hidden, the rest of the border is intact.

    It looks ok when i reduce the border radius to zero. What's going on there?

    http://wordpress.org/extend/plugins/auto-thickbox-plus/

  2. attosoft
    Member
    Plugin Author

    Posted 2 years ago #

    You are talking about top left and top right border radius of title bar?
    If so, I fixed the issue a while ago. Please try (reinstall) the latest version.

  3. hunnsdon
    Member
    Posted 2 years ago #

    Hello attosoft

    Thank for your reply.

    This is the version I have (v1.1) downloaded from here "wordpress.org" only a few days ago.

    I'm referring to top: left, right, bottom: left, right of the border when used as iframe by adding thickbox in css class of the advanced link settings setting of an image.

    The iframe opens and the contents are fine but the borders corners if selected as anything other than zero. i.e. rounded corners. are missing therefore not rounded. (border radius set to 12 in view settings). The rest of the border is visible.

    So what else might be wrong? Am I using this correctly to be able to click an image (imamge with link) to open a iframe popup with rounded corners?

  4. attosoft
    Member
    Plugin Author

    Posted 2 years ago #

    Hi hunnsdon,

    Does the iframe have the scroll bar?
    When an iframe has vertical scroll bar, the bottom right corner seems not be rounded.
    And when an iframe has horizontal scroll bar, the bottom left corner seems not be rounded.
    I think this is not a bug.

    Then the top left and top right corners are not rounded in the version a few days ago.
    Please reinstall (remove and install) the latest version that I fixed yesterday.

    If the iframe has no scroll bar and you use the latest version updated yesterday,
    there may be problems in this plugin or your blog.

  5. hunnsdon
    Member
    Posted 2 years ago #

    Hi attosoft

    It's probably easier if I show you. See the following - I'll send them to you in an email. One is with box shadow and one without. Notice the grey corners on the top (left & right - not correct look) and also the bottom looks like its being overlaid as you can just see the rounded corners underneath.

    Regards
    hunnsdon

  6. hunnsdon
    Member
    Posted 2 years ago #

    There appears to still be a problem with the bottom right border corner. Pictures sent by email for for opera and chrome.

    Regards
    hunnsdon

  7. hunnsdon
    Member
    Posted 2 years ago #

    Hello Sir

    Please can we discuss in here from now on. I don't think its helpful to have two discussions about these issues.

    Thank you for your email. Yes I have downloaded version 1.2 but now I get the following displayed on the homepage:-

    Warning: getimagesize() [function.getimagesize]: URL file-access is disabled in the server configuration in
    /FOLDERTREETOPLUGIN/wordpress/wp-content/plugins/auto-thickbox-plus/auto-thickbox.php on line 322

    Warning: getimagesize(http://www.mydomainname.xx/wp-content/plugins/auto-thickbox-plus/images/loadingAnimation.gif)function.getimagesize]:
    failed to open stream: no suitable wrapper couldbe found in
    /FOLDERTREETOPLUGIN/wordpress/wp-content/plugins/auto-thickbox-plus/auto-thickbox.php on line 322

    "FOLDERTREETOPLUGIN" - is replacement for actual document root
    "www.mydomainname.xx" - is a substitute for domain name

  8. attosoft
    Member
    Plugin Author

    Posted 2 years ago #

    As above messages say, URL file-access is disabled in your server configuration. That is allow_url_fopen = Off in php.ini on your server. (default is On)

    This issue is caused by changing loading image option under the condition of allow_url_fopen = Off.

    If www.mydomainname.xx is internal domain, please use default loading image until I fix the issue. But if it is external domain, you need to set allow_url_fopen = On.

  9. hunnsdon
    Member
    Posted 2 years ago #

    Hello and what?

    I have changed nothing other than update the plugin to version 1.2. I do not understand what you mean.

    Regards

    hunnsdon

  10. attosoft
    Member
    Plugin Author

    Posted 2 years ago #

    The issue is caused by the code using getimagesize() function. But the code exists from version 0.8, and I did not change it in version 1.2. So I guess your server setting has been changed without noticing by server administrator.

    Anyway, I intend to take a different approach and remove getimagesize() function call, so the issue will be solved soon.

  11. attosoft
    Member
    Plugin Author

    Posted 2 years ago #

    I intend to take a different approach and remove getimagesize() function call, so the issue will be solved soon.

    I released version 1.3 witch contains the improved code about "Loading" image option.

  12. hunnsdon
    Member
    Posted 2 years ago #

    Hello Sir

    Unfortunately still having problems.

    Gallery images are fine. Single images are not functioning correctly.

    Single images open but are overlaid with a countdown timer.

    See pictures sent via email

  13. attosoft
    Member
    Plugin Author

    Posted 2 years ago #

    Dear hunnsdon,

    I'm sorry for your inconvenience but the problems are not reproduced in my blog and test blog.
    I saw the pictures sent from you. It seems to be modified in thickbox.js/css by you.
    The problems including round corners issue in Chrome are occurred only in your blog.
    There may be any problems with your blog and modification, or not?

    It's too hard for me to solve the problems without looking your blog (HTML, CSS and JavaScript).

    See also "Auto ThickBox Plus does not work" in FAQ.

  14. attosoft
    Member
    Plugin Author

    Posted 1 year ago #

    All the problems have been resolved by exchanging e-mails.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic