WordPress.org

Ready to get started?Download WordPress

Forums

Auto Excerpt everywhere
Problem: Only works on blog home page for me. (3 posts)

  1. Dominor Novus
    Member
    Posted 1 year ago #

    Unfortunately, this plugin does not affect my search, archive and category archive pages.

    I've had to additionally install another similar plugin to achieve uniform post excerpts across all standard blog pages:

    http://wordpress.org/extend/plugins/advanced-excerpt/

    I'm using the Thematic theme framework. I'm unsure if a conflict is at hand or the plugin itself is discrepant.

    "Auto Excerpt everywhere" is a neat, uncomplicated plugin. It would be great to figure out the root of this issue.

    http://wordpress.org/extend/plugins/auto-excerpt-everywhere/

  2. J0SiE
    Member
    Plugin Author

    Posted 1 year ago #

    Can you provide a link to your blog?
    It must be something in your theme...

  3. Dominor Novus
    Member
    Posted 1 year ago #

    Hi J0SiE,

    I ended up using two custom functions to achieve uniform excerpts with the Thematic theme framework:

    //http://themeshaper.com/forums/topic/excerpts-on-home-page#post-10621

    function childtheme_content($content) {
    if ( is_home () ) {
    $content= 'excerpt';}
    return $content;
    }
    add_filter('thematic_content', 'childtheme_content');

    //http://themeshaper.com/forums/topic/read-more-link-in-manual-excerpt

    function all_excerpts_get_more_link($post_excerpt) {

    return $post_excerpt . ' ID) . '">' . 'Read more' . '';
    }
    add_filter('wp_trim_excerpt', 'all_excerpts_get_more_link');

    I've set up another example on a testing environment that recreates the problem I described.

    Working on standard blog home page:
    http://www.dominornovus.com/jquery-test-environment/blog/

    Not working in archive:
    http://www.dominornovus.com/jquery-test-environment/2012/10/

    Not working in category archive:
    http://www.dominornovus.com/jquery-test-environment/category/uncategorized/

    Not working in search archive:
    http://www.dominornovus.com/jquery-test-environment/?s=lorem+ipsum&searchsubmit=Search

    Perhaps the above two functions might shine light on the why your plugin and the Thematic theme framework are conflicting.

    You can find the Thematic theme framework in the WordPress Theme Directory:

    http://wordpress.org/extend/themes/thematic

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags