WordPress.org

Ready to get started?Download WordPress

Forums

Author Spotlight (Widget)
[resolved] Don't want author display on home page (4 posts)

  1. tenoclockwine
    Member
    Posted 1 year ago #

    Hi, the author spotlight works fine on all my post, but i don't want it appear on my pages. It doesn''t appear on blog page, however does appears on my 'home' page. Is there anyway to get rid of this?

    http://wordpress.org/extend/plugins/author-profile/

  2. Debashish
    Member
    Plugin Author

    Posted 1 year ago #

    The feature to display the widget on "Pages" was long overdue. On my test blogs the Widget doesn't show up on Home page and works fine on all pages (as it should).

    Is your home page the default WordPress home or have you set it to any static page (please check at "Settings > Reading" and reply).

    For now you may edit the plugin's author-profile.php file and replace line 106 and see if it works for you:

    Change the line:
    if((is_single() || is_page()) && $authordata->ID){

    to
    if((is_single() || is_page()) && !is_home() && $authordata->ID){

    Let me know if it works for you.

  3. Debashish
    Member
    Plugin Author

    Posted 1 year ago #

    If your home page is a static page, you can use the following line instead of the one I mentioned above (one containing is_home() call):
    if((is_single() || is_page()) && !is_front_page() && $authordata->ID){

  4. tenoclockwine
    Member
    Posted 1 year ago #

    Cool!!!! Thank you so much! it worked!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic