WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Author avatars] Please add feedback here (89 posts)

  1. Paul Bearne
    Member
    Posted 5 years ago #

    Hi all

    Use these forums to get support and give us feedback

    Paul and Ben

  2. bryan868
    Member
    Posted 5 years ago #

    Great plugin, thanks! I put in userid "1" so it won't show the admin, but it shows it anyway. Is this a bug?

  3. Ben
    Member
    Posted 5 years ago #

    Try putting "admin" in that field... At the moment it only compares the values with the user "login names" because we thought that that would be nicer to use for the enduser... I think we're going to change that to accept user ids as well so that you can put either.

    Thanks for the feedback :)

  4. Ben
    Member
    Posted 5 years ago #

    As of version 0.2 it's possible to put both "user login" and "user ID" into the field for hidden users. So both "1" and "admin" should hide the admin user now...

  5. bryan868
    Member
    Posted 5 years ago #

    Using 2.7-final, this plugin breaks my "tag" field and the image uploader on the "Write" page in the admin.

    Just FYI.

  6. Ben
    Member
    Posted 5 years ago #

    Thanks for reporting! I've just released a new version which should fix that bug... :-)

  7. Joe Lange
    Member
    Posted 5 years ago #

    Hi guys-

    Great plugin. I am glad I found it.

    The list of authors are currently centered on the sidebar...I am trying to align the picture to the left and have the text just to the right of the picture. The complete list would be aligned left, consistent with the rest of the widgets on my blog. Is this possible?

    http://www.langetwins.com/blog

    It's the last widget on the page. Thanks!

  8. Paul Bearne
    Member
    Posted 5 years ago #

    Hi Joe

    We have made it so you can overload the default widget styles in your theme CSS

    Try adding this CSS code to the style.css inorder to left align etc. (not test but should point you in the right direction)

    li.multiwidget_author_avatars .author-list .user {
    text-align:left;
    }
    li.multiwidget_author_avatars .author-list .user span.name {
    display:inline;
    Padding-left:5px;
    }

    It looks like you will be able to increase the image size as well

    Paul

  9. Joe Lange
    Member
    Posted 5 years ago #

    Thanks!

  10. kfailla
    Member
    Posted 5 years ago #

    This may seem like a funny question: But where does one upload their author photo? I want my blog to have something similar to Joe's. However, I want the authors side-by-side in a row of 2.

  11. kfailla
    Member
    Posted 5 years ago #

    I get it! They have to first create a gravatar. Okay second question. I want to display the authors side-by-side. Is that possible?

  12. Ben
    Member
    Posted 5 years ago #

    Are you using the widget or the shortcode?

    Either way the avatars are actually "floated left" by default which means that they should automatically appear next to each other as long as there's enough space... So if you're using the widget in a sidebar you might have to reduce the size of the avatar so that they fit into the sidebar..!?

  13. Ben
    Member
    Posted 5 years ago #

    Corection to myself: they're not "floated left" but actually "inline blocks"... which in this case essentially has the same effect ;-)

  14. apostaganha2
    Member
    Posted 5 years ago #

  15. Bodhipaksa
    Member
    Posted 5 years ago #

    Hi,

    I activated the plugin, but on my widgets page I'm getting the following error message:

    Fatal error: Undefined class name 'self' in /htdocs/www/wp-content/plugins/author-avatars/lib/FormHelper.class.php on line 197

    Any idea what's going on?

  16. Paul Bearne
    Member
    Posted 5 years ago #

    I we haven't seen this before

    which version of WP are you using?

    Paul

  17. Bodhipaksa
    Member
    Posted 5 years ago #

    I'm using 2.7.1.

  18. Paul Bearne
    Member
    Posted 5 years ago #

    Ok

    I will check this out on monday and get back to you

    Paul

  19. Bodhipaksa
    Member
    Posted 5 years ago #

    Many thanks. Your plugin seems the perfect solution for my problem with having 45 authors (and growing). An array of avatars would be much more compact in the sidebar than a long list of names.

  20. Bodhipaksa
    Member
    Posted 5 years ago #

    By the way, when I activate the plugin my sidebar doesn't even show up on the widget page. When I deactivate the plugin my sidebar reappears on the widget page.

  21. Ben
    Member
    Posted 5 years ago #

    Oh, sorry about that error... the "self" keyword which I use in that class is not available in PHP version 4 (which I missed because we only tested on PHP 5).

    I've fixed this in the trunk... could you download it and test it on your system for me, please?

    You can download the whole dev version from here: http://downloads.wordpress.org/plugin/author-avatars.zip (you might have to wait a little while because the zip only gets updated every few hours I think); or you can just replace your version of /author-avatars/lib/FormHelper.class.php with the new trunk version here.

    I am not sure about the second thing about your whole sidebar dissappearing... can you please check if the fix above solves this problem? otherwise I'm going to need a few more details... ;-)

    On a sidenote: PHP4 is not officially supported anymore since January 2008 so I strongly recommend thinking about upgrading your system to PHP5... Most webhosts I know have already done the upgrade or provide easy ways of switching across... ;-)

  22. cuneytdd
    Member
    Posted 5 years ago #

    thanks............

  23. cuneytdd
    Member
    Posted 5 years ago #

    neon

  24. Bodhipaksa
    Member
    Posted 5 years ago #

    Thanks. Testing it now...

    And it works perfectly. Thanks, Benedikt!

    The issue with the sidebar not showing on the widgets page was that instead of seeing "You are using 1 widget in the 'Main Sidebar' sidebar" I was getting nothing at all. But that's sorted now.

    I'll look into the PHP 5 issue. I thought I was using PHP 5, but I was getting confused with MySQL 5!

  25. Bodhipaksa
    Member
    Posted 5 years ago #

    I couldn't see anything in the documentation that said how to upload an avatar for authors. Two authors are showing gravatars -- is that the only way to do it? Getting 45 authors to sign up for gravatars would be a headache, so I'm hoping there's another solution.

  26. Paul Bearne
    Member
    Posted 5 years ago #

    We don't support the adding of avatars we just call the wordpress avatar code which in turn calls out to web (gravatars etc. see the full list in the admin pannel > settings > discussion ) so all your authors will need to upload an image to one of the services.

    Maybe some links to the services will help ;-}

    Paul

  27. Ben
    Member
    Posted 5 years ago #

    Haecceity, thanks for testing. I'm going to release that fix as a bugfix version later today or tomorrow...

    As Paul said we don't support adding custom pictures to the blog but I think there are some other plugins around that allow you to do this. As long as they use the "get_avatar" function they should work fine with our plugin.

    According to its documentation the User Photo plugin is one of them.. apparently it provides an option to "Override Avatar with User Photo"... I haven't tested it but it sounds like it should work :-)

  28. Bodhipaksa
    Member
    Posted 5 years ago #

    Thanks - you're so helpful. I actually had the "Add Local Avatar" plugin open in my browser and was going to ask whether it was compatible with yours. I'll give it, or the User Photo plugin, a try.

  29. Ben
    Member
    Posted 5 years ago #

    My pleasure.. let me know how it works out.

  30. Bodhipaksa
    Member
    Posted 5 years ago #

    It worked out very well, thanks. You can see the results at http://www.wildmind.org/category/blogs

    I plan to put the text list in some kind of hidden div so it will slide out if necessary.

    I noticed a couple of wee things. One was that I had trouble with the styling and when I looked at the output I saw

    img src='/images/avatars/akuppa.jpg' class='avatar avatar-30 avatar-default' height='30' width='30'

    (single quotes rather than double).

Topic Closed

This topic has been closed to new replies.

About this Topic