WordPress.org

Ready to get started?Download WordPress

Forums

Audit Trail
Exclude Users Does Not Work (5 posts)

  1. binaryeric
    Member
    Posted 4 years ago #

    When adding any users to the exclude list, there is no impact. I have added 4 users to be ignored and they all appear in the audit trail along with all actions.

    http://wordpress.org/extend/plugins/audit-trail/

  2. catseyegroup
    Member
    Posted 3 years ago #

    Yep, I'm finding the same thing happening...

  3. Jeff Sterup
    Member
    Posted 3 years ago #

    Yep. Really disappointing. I have a user that automatically updates thousands of posts every day through a cron job. I dont want this user to be tracked or it will fill the database quickly.

  4. Jeff Sterup
    Member
    Posted 3 years ago #

    Was able to hack the plugin into working.

    Added this code to line 166 in models/audit.php to fix.

    get_currentuserinfo();
    $ignored_users = explode(",", get_option('audit_ignore'));
    if (in_array($user_ID, $ignored_users)) {
    	return;
    }
  5. Sith Lord Goz
    Member
    Posted 3 years ago #

    This is definitely a bug in the plugin - but I noticed from http://wordpress.org/support/topic/plugin-audit-trail-caution?replies=6 that a fix seems to be just terminating the "ignore users" string with a comma.

    I entered "1,13," and saved the options - seems to now exclude activity from users 1 and 13.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic