WordPress.org

Ready to get started?Download WordPress

Forums

Audiobar
Frame not appearing + Unexpected characters generated (10 posts)

  1. KiloTango
    Member
    Posted 2 years ago #

    Just tried to install this, and even with all other plugins turned off, I get a

    "The plugin generated 157 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin."

    No bar is displayed but clicking a play button loads up a new tab with audiobar's default styling.

    It's a real shame, this seems like such a cool plugin.

    http://wordpress.org/extend/plugins/audiobar/

  2. KiloTango
    Member
    Posted 2 years ago #

    Oh, and it also spits out this in the post content:

    You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line 7

  3. soundgrail
    Member
    Posted 2 years ago #

    I am having the exact same problem.

    I have had the plugin installed for a few weeks now and all of a sudden this happened as soon as I uploaded a few large files.

    However, I'm getting:

    You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line 7
    Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in public_html/wp-content/plugins/audiobar/lib/getid3/extension.cache.mysql.php on line 141#

    This is line 141 of said file:

    if (mysql_num_rows($this->cursor) > 0) {
            // Hit
            list($result) = mysql_fetch_array($this->cursor);
    				return unserialize(base64_decode($result));
    			}
    		}
    		// Miss
    		$analysis = parent::analyze($filename);
    
    		// Save result

    Hope this helps someone come up with a solution to this problem.

  4. carlocapocasa
    Member
    Plugin Author

    Posted 2 years ago #

    Hi there!

    Thanks for this report!

    MySQL 5.4 apparently dropped a long-deprecated feature I didn't know about.

    Please update to Audiobar 1.0.3, de-activate, and re-activate again, and it should work. This update also fixes a glitch with SEO content.

    Let me know if there's anything else I can help you with.

    Thanks for using Audiobar!

    Carlo

  5. KiloTango
    Member
    Posted 2 years ago #

    The SQL errors have gone, but it's still not loading the bar. I get a js error of

    top.audiobar is undefined
    in firebug, clicking one of the buttons just loads the bar in a new tab.

    I've been using a custom theme but even when I swap it out for Twenty Eleven, it's not generating the frames.

  6. carlocapocasa
    Member
    Plugin Author

    Posted 2 years ago #

    Sounds like the iframe wrapper is not being loaded.

    The first thing to try is switch to Twenty Eleven, delete your browser cache, and re-load. If you have any cache plugins installed, de-activate them first.

    Carlo

  7. KiloTango
    Member
    Posted 2 years ago #

    I've tried that, it's still not loading the iFrame, and still gives me the 'top.audiobar is undefined' js error. Also all of my links are now redirecting to the home page.

    This is on a mac running lion, in Firefox and Chrome. I wouldn't think it would make any difference but for what it's worth it's being tested in a local environment, using MAMP.

  8. carlocapocasa
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for the Info!

    Mamp is good... other servers like NGINX or IIS can have subtle differences in the way they process GET and POST variables. As a matter a fact I tried to migrate an Audobar site to NGINX once but had the same problem as you are having right now.

    Any other plugins installed than Audiobar?

    What is the local URL you are using? (e.g. http://127.0.0.1/my/awesome/site)

    Are you certain that the wordpress site url is pointing to that URL? (check admin panel configuration)

    Carlo

  9. KiloTango
    Member
    Posted 2 years ago #

    The local URL I'm using is http://localhost:8888/blair (I had been running it on my general test area which is http://localhost:8888/wordpress but decided to try a fresh install to see if that was the issue) Both the urls in the settings are set to that.

    No other plugins. It's really odd. (And frustrating, this plug-in is pretty much EXACTLY what I'm after for this client, if only it worked!)

  10. carlocapocasa
    Member
    Plugin Author

    Posted 2 years ago #

    Hm, it's possible that Audiobar doesn't support ports that are not 80. I'll see if I can check that out.

    Carlo

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags