WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Audio Player] Version 2.0 beta released (531 posts)

  1. Vader_666
    Member
    Posted 6 years ago #

    Hello,
    I have a little problem : in the admin panel, the configuration page of Audio Player is blank !
    I use WordPress 2.5.1 with the french translation and the Audio Player 2.0 beta 1.

    The plugin works (i can add music in my blog), but i can't configure the player... Is someone have the same problem ?

    Thanks for your plugin and for your help :)

  2. my-sweet-jane
    Member
    Posted 6 years ago #

    Hi, I seem to be the only one having this problem. I am using firefox if that is any help. Plugin installs and activates perfectly. Problem is that I can't change the colour of the audio player. Although the colour picker etc displays ever time I choose a colour the hex code will show up but not the colour and there is no change in the demo of the player below.
    What I do is pick a colour and icon and click save changes.

    Any ideas?

    Jane

  3. BlaenkDenum
    Member
    Posted 6 years ago #

    Is it just me or is does it show a little border/outline around the player every time you click on it? I don't think it's part of audio player I think it's being done by my browser FF3, the previous audio player didn't have this though. Is there any way to get rid of it?

    To answer My own question:

    I did see the link border around the player. This will be fixed in the next release (beta 2 coming soon).

    Sorry didn't read that, looking forward to the next version! :)

  4. doryphores
    Member
    Posted 6 years ago #

    @Vader_666:

    Very strange indeed. Can you check that you installed the plugin in the correct folder? The files should be in wp-plugins/audio-player.

    Could you also post a link to your blog so I can have a look?

    Martin

  5. doryphores
    Member
    Posted 6 years ago #

    @my-sweet-jane:

    Can you check that you installed the plugin in the correct folder? The files should be in wp-plugins/audio-player.

    Does this happen on a live WP blog? Can you post a link so I can have a look?

    Martin

  6. iblastoff
    Member
    Posted 6 years ago #

    Just wanted to say thanks for the audio player! I'm actually running Textpattern and managed to get your latest beta working with a simple plugin on this site here http://sickpill.com. (none of the fancy admin stuff like the color picker though, but most settings seem simple enough to configure via swobject params anyway). love the addition of volume control!

  7. Vader_666
    Member
    Posted 6 years ago #

    @doryphores

    Are you sure of the folder ? It seems that the default plugin folder is wp-content/plugins/... And when i create the wp-plugins folder and put inside the audio player files, the plugin don't appear at all on the admin panel.

    My blog is http://blog.vader.fr. You can see a pic of the admin panel here after i click on the "Audio Player" link.

  8. my-sweet-jane
    Member
    Posted 6 years ago #

    Hi there, I've double checked that I installed in the right folder and have. You can seek the player on my demo site http://sales.wpqueen.com

    Thanks

    Jane

  9. TheGeek101
    Member
    Posted 6 years ago #

    Just to start by saying, I've been a user of this plugin for sometime now. I like the new look & feel of the 2.0 but I've run into one problem:

    When I click play, the file starts playing, but if I pause it, then go back to finish listening, It doesn't play. But If I refresh the page, it will play the file again.

    http://lascivious.creativeburst.org

  10. doryphores
    Member
    Posted 6 years ago #

    @TheGeek101:

    Thanks for reporting this. I have uploaded a fix. Download and reinstall the plugin from http://wpaudioplayer.com/download.htm

    Martin

  11. doryphores
    Member
    Posted 6 years ago #

    @Vader_666:

    Could you try this for me:

    First, make sure you install the latest version available on my website (http://www.wpaudioplayer.com/download.htm).

    Open audio-player.php and replace line 474 with:

    include(dirname(__FILE__) . "/php/options-panel.php");

    Let me know if this fixes it.

    Martin

  12. Mark Barnes
    Member
    Posted 6 years ago #

    As you have changed the name of the function that calls AudioPlayer, can I suggest you add the following code:

    //Fix for AudioPlayer v1
    if (!function_exists('ap_insert_player_widgets')) {
    	function ap_insert_player_widgets($params) {
    		return insert_audio_player($params);
    	}
    }

    That will help people who called AudioPlayer from functions.php or from other plugins.

    Thanks.

  13. Vader_666
    Member
    Posted 6 years ago #

    @doryphores:
    The last version (beta 2) don't fix my problem...
    But the line 474 remplacement does ! :) include(dirname(__FILE__) . "/php/options-panel.php"); seems to be the solution ;)
    Thanks a lot ! :)

  14. doryphores
    Member
    Posted 6 years ago #

    @Vader:

    Excellent! I'll include the fix in the next release.

    Martin

  15. my-sweet-jane
    Member
    Posted 6 years ago #

    Hi there, I posted my link in the thread.

    Thanks
    Jane

  16. abdistract
    Member
    Posted 6 years ago #

    hi,

    i'm having problems on my blog too...the plugin is definitely in audio-player in the plugins folder where it should be, and i have the latest version of everythin: wp 2.5.1, Flash 9, the plugin 2.01beta, and java is enabled on my browser, but i get this error message in safari and ff where the flash player should be:

    Audio clip: Adobe Flash Player (version 6 or above) is required to play this audio clip. You also need to have JavaScript enabled in your browser.

    The clip is in an 'audio' folder on my server - which i verified in the audio-player settings.

    I also tried to add audio via the dashboard when i was writing the post - the 'add audio' button. I uploaded the audio file for the post, and clicked the 'audio-player' button, then 'insert into post'. But that didn't work either - the error message was messier, running un-formatted across the page.

    hope i to get it working,

    cheers,

    ab

  17. doryphores
    Member
    Posted 6 years ago #

    @Jane:

    Can you try downloading the latest code and reinstalling the plugin? I have uploaded a small change that might fix the color picker issue.

    Martin

  18. doryphores
    Member
    Posted 6 years ago #

    @abdistract:

    I just checked your site on Firefox and Safari (both on Windows and Mac) and the player works fine.

    The message should only show when you don't have Flash Player (8 or above) installed or JavaScript is disabled. Check that you have Flash installed properly.

    Martin

  19. abdistract
    Member
    Posted 6 years ago #

    Martin,
    i re-installed Flash and it's all good. big thanks for the great plugin and for taking time to help out.

  20. jackstin
    Member
    Posted 6 years ago #

    look at tavik.com please

    everything looks great in FF2 and in Safari

    but IE & wont play the file on the home page.

    any direction will be great....

  21. komski
    Member
    Posted 6 years ago #

    I just read in your blog about planning to make the downloading of the mp3 to stop when the player is paused. I would just suggest to just throw in a stop button? I occasionally pause the player to wait 'till the mp3 file is downloaded completely:) (connection sucks sometimes) And I know others are experiencing this also (I guess so).

    Thanks for the great player:D

  22. clarezoe
    Member
    Posted 6 years ago #

    I have the same problem as abdistract too. my blog

    I'm sure I installed it correctly. I've test it in FF3(both Linux and Windows), IE6, none of them worked. I can see the player in your site and other sites, so it's not the problem of my browser, I have no knowledge about PHP, could you help me to check what is wrong in my settings?

    I'm using Audio-player 2.0b plugin version in wp 2.5.1,
    the error is

    Audio clip: Adobe Flash Player (version 6 or above) is required to play this audio clip. You also need to have JavaScript enabled in your browser.

    I used the syntax [audio:http://my.site/music.mp3], all full url address.

    Hope to hear from you soon.

    Feifei

  23. clarezoe
    Member
    Posted 6 years ago #

    sorry, my bad. I found it I changed the fold name, it works fine now.
    Great plugin!

  24. iblastoff
    Member
    Posted 6 years ago #

    hey hey,

    firstly i'm using the new standalone version. in the standalone instructions it states that 'encode' is a valid option but i'm assuming this is only done with the 'full' wordpress plugin version? i'm guessing any urls being encoded are probably done via php.

  25. doryphores
    Member
    Posted 6 years ago #

    @iblastoff:

    You are right, you need to encode the urls server side with PHP (or any other server side language).

    As an aside, I see the encode feature as a bit of a gadget. Anyone with a bit of programming knowledge can decode the URLs. I included the feature because a lot of people requested it but it isn't a bullet proof solution.

    Martin

  26. doryphores
    Member
    Posted 6 years ago #

    @komski:

    Some clarification about the "stop download" feature: the download is only cancelled when the player closes as a result of another one being open. When you click the pause button, the download isn't cancelled. (I'd actually forgotten that I'd done it in this 'smart' way)

    I implemented this because quite a few people are embedding many players on one page. Many servers are configured to only allow 2 or 3 concurrent downloads so this could be a major issue for some.

    I don't really want to throw in another button. The design of the player is very restrictive in terms of UI space so another button would be a pain to implement.

    Martin

  27. simon04
    Member
    Posted 6 years ago #

    transparency isnt working for me?

  28. doryphores
    Member
    Posted 6 years ago #

    @simon04:

    can you give me a little more information? And possibly a link to an example?

    Martin

  29. skieran
    Member
    Posted 6 years ago #

    I keep getting "file not found" when I hit play on the player on the page I constructed.

    I've looked SEVERAL times using File Manager on cpanel.

    The file is there.

    What am I doing wrong?

    Thanks!

    Sahaun

  30. doryphores
    Member
    Posted 6 years ago #

    @skieran:

    'File not found' errors can happen for many reasons but it depends on how you are using the player.

    Can you post a link to an example page where this is happening? If you can, it would be very helpful if you could switch encoding off in the Audio Player advanced options so I can see the mp3 URL and find out what's wrong.

    Martin

Topic Closed

This topic has been closed to new replies.

About this Topic