WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Audio Player] Version 2.0 beta released (531 posts)

  1. doryphores
    Member
    Posted 5 years ago #

    OK. At long last I finally have a beta release of version 2.0 ready for you to try out. You can download it here: http://www.wpaudioplayer.com.

    Please post questions and feedback to this forum topic.

    Martin

  2. Knauqueue
    Member
    Posted 5 years ago #

    Hi Martin.
    Great audio player. Great new features. I've been using the version 1.2.3 for a few months, and I am very happy.

    I found a few major bugs in this version.

    1. It is not supported in Firefox Beta 3. I think you might want to correct that before the new browser is released.

    2. When it says "File Not Found", the player does not want to close back - in all browsers.

    3. When I press multiple audio files, all of the former files keep playing, instead of closing back (unlike version 1.2.3).

    I hope you can resolve these problems because on my blog I like to post multiple audio files at once.

    Thanks!

  3. doryphores
    Member
    Posted 5 years ago #

    @Knauqueue:

    Hi. Thanks for the feedback. I need to know a little more about the issues you mention.

    1: When you say it is not supported in Firefox Beta 3, what do you mean? Are you basing this on what I say on the installation page or did you actually try it in FF 3? As far as I know, it works in FF 3.

    2: Yeah, I know about this. I can't remember why I did this though :-) I'll look into it.

    3: This is quite strange because this should be the one feature that has improved. Have you got an example online? It would be very helpful if I could have a look. If you don't, can you give me more details: which browser you tried this in and which version of the Adobe Flash player you have installed.

    Again, thanks again for the feedback. I'll do my best to fix the issues.

    Martin

  4. craigsanatomy
    Member
    Posted 5 years ago #

    Hi Martin,
    I too must first compliment you on a great tool. For some reason, the player is showing up in FF (both Beta 3, and 2) but not in IE7 (PC) or Safari (Mac). I get this message:

    Audio clip: Adobe Flash Player (version 6 or above) is required to play this audio clip. You also need to have JavaScript enabled in your browser.

    I'm wondering if there is something I'm doing wrong? Is there a fix for this?

    Thanks,
    -Craig

  5. craigsanatomy
    Member
    Posted 5 years ago #

    As a side note, i looked at your site in IE7 and the player works fine. What could be different about mine? (It's WP 2.5.1 hosted on Dreamhost)

  6. doryphores
    Member
    Posted 5 years ago #

    @Craig:

    Can you post a link to a page where this is happening?

    Martin

  7. Knauqueue
    Member
    Posted 5 years ago #

    @doryphores:

    1. SOLVED - I've upgraded WordPress from 2.5.0 to 2.5.1 and the player started to work perfectly in Firefox 3. So basically it is important to have the latest version of the software. The only think that I've noticed is that the link-border appears around the player when I press "Play". But that's ok.

    2. Thanks!

    3. I have the latest flash version installed, and this bug appears in IE-7, OP-9, SF-3 and sometimes in FF-3. FF-2 works alright, that means that files close back properly. On my site there are about 20 files on one page.

    4. I've found another problem. In all browsers - when I press "play", the file (sometimes, not always) does not start to play, but when I press "refresh", everything goes back to normal. Maybe there are way too many files on one page, or I have way too many tabs open?

    Thnaks!

  8. m2calabr
    Member
    Posted 5 years ago #

    I would reiterate, cool payer, clean and simple.

    One question when I put the player on a black background there is a white "backdrop" that is visible. When "closed" you get a white bar to the left of the play button. Can that be made transparent or set the color?

    I have tried the options bg and pagepg (I tried to set both to 0x000000).

    Any suggestions?

  9. doryphores
    Member
    Posted 5 years ago #

    @m2calabr:

    2 questions before I can help you:

    Are you using the player as a WordPress plugin or standalone?

    Are you using version 2.0 beta or 1.2.3?

    Martin

  10. doryphores
    Member
    Posted 5 years ago #

    @Knauqueue:

    1: Glad it works for you but I just tested it on FF 3 rc2 and WP 2.5.0 and it worked fine. I am not aware of any issue with WP 2.5.0. I did see the link border around the player. This will be fixed in the next release (beta 2 coming soon).

    3 and 4: It is possible that many players on one page is a problem. It would be really helpful to see an example where this is happening. Can you post a link?

    Martin

  11. travis coats
    Member
    Posted 5 years ago #

    I am having trouble getting the player to work correctly. I installed the folder into the wordpress plug-ins and then moved the audio player.php file as instructed on your site, but I am getting (and this has expressed itself differently after trying different things) either multiple audioplayer plug-in instances in the plug-ins window of the back end editor or I am getting code errors when I try to access the plug-in settings(options).

    I had it working last night, but I had to duplicate the audioplayer.php file, one in the actual audio player folder and one in the plug in folder. Doing this made it function, but I still couldn't edit the appearance of the player. Any suggestions?

  12. flick
    Member
    Posted 5 years ago #

    (Just to say that I'm a big fan of the current version, so thank you for creating such a great plugin!)

  13. simon04
    Member
    Posted 5 years ago #

    are there any new runtime options for this version? like the color of the volume bar? cant seem to change that.. only the color of the speaker. thanks :)

  14. simon04
    Member
    Posted 5 years ago #

    looked at the php file. doesnt look like theres any new options. also righticon isnt working for me...

  15. simon04
    Member
    Posted 5 years ago #


  16. sargeants
    Member
    Posted 5 years ago #

    Hello - I've been working on creating a new site for my g/f and her music, and this new player would be great... if I could get it to work right.

    As testing I was using v1.2.3 and was able to get things to play, but now trying out v2.0 - getting an error.
    Audio clip: Adobe Flash Player (version 6 or above) is required to play this audio clip. You also need to have JavaScript enabled in your browser.

    I'm running WP2.5.1 on an apache2 server. My main computer is Ubuntu 8.04 with FF3B5, but have also tried on XPH w/FF2 and IE6

    here's the site - any ideas?
    http://laurarodie.ssarge.net/recital-music/

    should also mention that your site works well...
    Thanks - ssarge

  17. flick
    Member
    Posted 5 years ago #

    (sorry to gatecrash this thread: @sargeants, perhaps you might consider adding a few more pixels to the left and right margin of the main content? :)

  18. doryphores
    Member
    Posted 5 years ago #

    @sargeants:

    You uploaded the plugin to a folder called audio-player-2beta1. The folder should be called audio-player. Rename it and it should work OK.

    Martin

  19. doryphores
    Member
    Posted 5 years ago #

    @Travis:

    You shouldn't have to move any file. Simply download the archive and upload everything to your plugins folder. The audio-player.php file should be directly under the audio-player folder.

    Like this: /wp-content/plugins/audio-player/audio-player.php

    And make sure you don't have multiple audio-player.php files in there.

    Martin

  20. doryphores
    Member
    Posted 5 years ago #

    @simon04:

    I will be adding the full list of runtime options to the site soon.

    Martin

  21. sargeants
    Member
    Posted 5 years ago #

    Wow - I knew it was gonna be something simple like that...
    was wondering why the admin area wasn't looking like it was in the screenshots..

    - also added a few pixels to the margin that I think you were talking about Mosey

    Thanks!!!

    Check soon and listen to some Classical Saxophone!!

  22. craigsanatomy
    Member
    Posted 5 years ago #

    Hi Martin,
    Here is the site: http://blog.5alarmmusic.com/

    Do you have the same problem? (works in FF, but not in IE7 or Safari?)

    Any ideas?

    Thanks,
    -Craig

    PS I've been reading these other threads, and the player seems to be installed correctly, with the correctly named folder, etc.

  23. m2calabr
    Member
    Posted 5 years ago #

    I am using beta 2 in standalone mode. A reminder so you don't have look for my previous message. I am trying to set the background color since I am displaying it on a back background page. Currently past the play button is white.

    Thanks for your help.

  24. doryphores
    Member
    Posted 5 years ago #

    @m2calabr:

    First, make sure you have the latest files. The option you need to set is pagebg and you don't need the '0x' in front anymore so set it to '000000'.

    I haven't written up how to use Audio Player on non WordPress sites yet so I'm not sure how you are using it. The option must passed in as a FlashVar. You can use the audio-player.js file supplied in the zip file and work out how to use it (look at how it is setup in the What's New page).

    Martin

  25. doryphores
    Member
    Posted 5 years ago #

    @craigsanatomy:

    I looked at your blog and it looks like some BR tags are being included inside the script tags that control the players. This doesn't seem to bother FF but IE and Safari don't like it. I'm not sure why these tags are being inserted. Maybe you have a plugin doing some extra formatting?

    I will make a small change to try to counter this and include it in the next beta release. Keep an eye on this thread for the announcement.

    Martin

  26. thehumansarecoming
    Member
    Posted 5 years ago #

    i think i might of spotted a bug (or might just be using the pluging incorrectly)

    if i try and specify the track names it seems to work, but only plays the last track.

    [audio:BWARE03A.mp3|titles=Symptomless Coma|artists=Donny,
    BWARE03B.mp3|titles=Markus|artists=BSoul,
    BWARE03C.mp3|titles=Fuct|artists=T.Z.A.,
    BWARE03D.mp3|titles=Cybernetics VIP|artists=Current Value]

    any ideas?

  27. thehumansarecoming
    Member
    Posted 5 years ago #

    i think i've found another issue. i figured a simple work around for my problem would just be to tag the mp3 files with the correct information.

    So i deleted them from the server but they seems to be cached in the player, 3 for the 4 tunes still play, only one comes up as file not found.

  28. doryphores
    Member
    Posted 5 years ago #

    @thehumansarecoming:

    The correct syntax is:

    [audio:BWARE03A.mp3,BWARE03B.mp3,BWARE03C.mp3,BWARE03D.mp3|titles=Symptomless Coma,Markus,Fuct,Cybernetics VIP|artists=Donny,BSoul,T.Z.A.,Current Value]

    Martin

  29. craigsanatomy
    Member
    Posted 5 years ago #

    Thanks Martin,
    Yes with that many small images we had a terrible time with line hard line breaks. The WSIWYG editor is doing a terrible job of adding or removing them, perhaps that's affecting the player?

    Is there anything I can do for now?

    Thanks for your help. I look forward to the next release.

    -Craig

  30. doryphores
    Member
    Posted 5 years ago #

    @craigsanatomy:

    You could try this if you feel comfortable editing the php file:

    Open audio-player.php

    Replace line 460 to 464 with the following:

    $playerCode .= '<script type="text/javascript">';
    $playerCode .= 'AudioPlayer.embed("' . $playerElementID . '", ' . $this->php2js($playerOptions) . ');';
    $playerCode .= '</script>';

    Basically, you are removing the line breaks (\n) and the comment tags.

    Let me know if it fixes it.

    Martin

Topic Closed

This topic has been closed to new replies.

About this Topic