WordPress.org

Ready to get started?Download WordPress

Forums

Audio Player
Using as a standalone player (2 posts)

  1. asylumet
    Member
    Posted 3 years ago #

    I am trying to use this player as a standalone player with the object tag to embed it in a page. I prefer to not use javascript for such a thing and the embed tag breaks page validation for XHTML Strict.

    I am trying to play multiple tracks with the player in a comma delimited list as suggested in the documentation.

    The tracks play but the display says "File not found" also the titles and artist are never shown nor ID3 info from the SoundFile if excluding
    artists and titles options.

    The display time never increments and likewise if setting remaining=yes it does not decrement.

    Pressing the pause button also does not always stop playback.

    Below is the code I am using. If anyone has any ideas how to fix any of this it would be greatly appreciated.

    <object type="application/x-shockwave-flash" data="http://domain.tld/mp3-player/swf/player.swf" id="audioplayer1" height="20" width="290">
      <param name="movie" value="http://domain.tld/mp3-player/swf/player.swf">
      <param name="FlashVars" value="playerID=1&autostart=yes&soundFile=http://domain.tld/play/song1.mp3,http://domain.tld/play/song2.mp3&titles=Song One,Song Two&artists=Artist A,Artist B">
      <param name="quality" value="high">
      <param name="menu" value="false">
      <param name="wmode" value="transparent">
    </object>
  2. asylumet
    Member
    Posted 3 years ago #

    I am beginning to think it may be a wise choice to find a new player. I just had a thought that maybe the reason it says file not found is that I am using a script to track downloads as noticed in the URL I use were the filename is preceded by play/. I had the idea to maybe copy one file into the directory that the html file that the player is embeded into is housed in. Sure enough the File not found goes away. It now just says Connecting... forever but still plays. I then click next and then previous and would you look at that, the artist and title show up but the song doesn't play. The counter still just stays at 0:00.

    Is there even any support for this player or a place to report bugs/request features or anything or is this just a forum for people to speculate?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic