WordPress.org

Ready to get started?Download WordPress

Forums

Audio Player
Problem with WP 3.01, 2010 theme (6 posts)

  1. jhipps
    Member
    Posted 3 years ago #

    Hi --

    We're having some problems with the Audio Player plug-in following an upgrade to WP 3.01 and a move to the new default theme, 2010.

    I've followed all the suggestions on the Troubleshooting page, including uninstalling and reinstalling Flash and making sure that wp_header() and wp_footer() are in the appropriate locations. Rather than seeing an audio player, however, all we're getting is a blank space.

    Here's a sample page from our site:

    http://www.centerlinesoccer.com/?p=1598

    Does anyone have any suggestions? This is perplexing to me.

    Thanks!

    Jay

  2. wellebee
    Member
    Posted 3 years ago #

    Don't know how much this helps, but blank space where your player is supposed to be contains this html:

    <p class="audioplayer_container">
    <span id="audioplayer_1" style="display: block; padding: 5px; border: 1px solid rgb(221, 221, 221); background: none repeat scroll 0% 0% rgb(248, 248, 248);">Audio clip: Adobe Flash Player (version 9 or above) is required to play this audio clip. Download the latest version <a title="Download Adobe Flash Player" href="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash&promoid=BIOW">here</a>. You also need to have JavaScript enabled in your browser.</span>
    </p>

    It looks like WP isn't finding the Flash player.

  3. jhipps
    Member
    Posted 3 years ago #

    I had seen that in the code but thought the message about the Flash player would only be shown to viewers who did not have the Flash plugin installed. Is that not the case? I thought the Flash plugin was installed on the client side, not the server side.

  4. Reuben Gunday
    Member
    Posted 3 years ago #

    It does not show up audio player because the required javascript file is throwing errors(file name: 1pixelout_audio-player.js). Try upgrading the plugin or delete it and install it again.

  5. jhipps
    Member
    Posted 3 years ago #

    Thanks, Reuben! That was it — the 1pixelout script is part of the PodPress plugin and it's either corrupted or was somehow interfering with Audio Player.

  6. ntm
    Member
    Posted 3 years ago #

    @jhipps: You are probably right. centerlinesoccer.com/wp-content/plugins/podpress/players/1pixelout_audio-player.js is not reachable. That seems to be the reason why there are JS errors when you open this post in your browser.
    Please, try to find out whether this file exists in this folder or not.
    (Maybe update to podPress 8.8.6.3.)
    Or did you removed this file actively?

    The player in this post are now the players of the WP Audio Player. Did you switched the players since your first post here?

    I have tested to run the WP Audio Player and podPress at the same time. I would say it is possible without problems. The swfobjects and the container elements are having different names. But if there is a problem with podPress then I would like to solve it.

    Regards,
    Tim

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic