WordPress.org

Ready to get started?Download WordPress

Forums

Audio Player
[resolved] Not working in firefox 8.0.1 on win7 x64 (26 posts)

  1. robnalexpress
    Member
    Posted 2 years ago #

    I cannot get audio player to work in firefox 8.0.1 on my Windows 7 64 bit machine. Not just on my site, but on any site using the plugin.

    Works fine on my windows xp machines.

    Anyone else having this issue? Any suggestions?

    http://wordpress.org/extend/plugins/audio-player/

  2. robnalexpress
    Member
    Posted 2 years ago #

    Anyone else having this issue? If you are running:

    Windows 7 64-bit
    Firefox 8.0.1
    Shockwave Flash 11.1.102.55

    Please let me know if the audio players on this page work for you.

    Rob

  3. ClaytonJames
    Member
    Posted 2 years ago #

    Audio player plugin on your site is working fine for me.

    - Win 7, 64 bit, FF 8.0.1, Shockwave Flash 11.1.102.55. It also appears to be functioning properly in IE9. I'm afraid I can't duplicate the issue.

  4. robnalexpress
    Member
    Posted 2 years ago #

    @ClaytonJames- Thanks! It's driving me crazy. When I hover over the play arrow, instead of turning solid white (as it should) it flickers back and forth between black and white, and when I click it, nothing happens.

  5. ClaytonJames
    Member
    Posted 2 years ago #

    Working well on my end. Have you tried uninstalling the flash plugin, dumping your browser cache(s) and then reinstalling the plugin? Sounds whacky, I know, but stranger things have happened. I have had several flash plugin crashes in FF8 with this version of flash on my 64 bit laptop, but I can't recall having any issues on any of the 32 bit machines.

  6. robnalexpress
    Member
    Posted 2 years ago #

    Yep. Completely uninstalled flash using the adobe uninstaller, rebooted, deleted everything in C:\Windows\system32\Macromed\Flash and C:\Windows\syswow64\Macromed\Flash, ran the 64-bit installer for firefox, and still no joy. Checked all my FF settings seem OK. Like you, no problem on my 32 bit XP laptop running same FF and Flash versions (except for 32-bit).

  7. ClaytonJames
    Member
    Posted 2 years ago #

    ran the 64-bit installer for firefox

    Ahhh... we might have a fundamental difference here. I'm running Firefox out of the x86 Program Files directory, which indicates a 32 bit instance of FF, I believe. - Yep', sure enough. My task manager shows firefox running as firefox.exe *32.

    I apologize for the confusion. You seem to be running FF in 64 bit, while I am running it in 32 bit on a 64 bit OS. I can also confirm that my IE9 instance is running in 32 bit mode. Sorry about that, I never gave it a thought!

  8. robnalexpress
    Member
    Posted 2 years ago #

    Thanks Clayton- that's actually good to know, 'cause I was beginning to think there was some unique glitch on my machine. I've posted on the mozilla and adobe forums, but not getting any response so far.

  9. ClaytonJames
    Member
    Posted 2 years ago #

    I just opened your site in the 64 bit version of IE9, and the player still worked normally. No problems in IE9 64 bit version for me.

  10. robnalexpress
    Member
    Posted 2 years ago #

    Firefox 8.0.1 is the only browser on the 64-bit machine with the problem. IE9, chrome, safari, all work.

    If you have time, and can try FF 64 bit, I'd be interested to know if it works for you.

    Thanks, Rob

  11. ClaytonJames
    Member
    Posted 2 years ago #

    I just installed FF 64 bit from the nightly builds, (testing) seems to be working perfectly on your site.

    http://nightly.mozilla.org/

    [edit] Crap! Be careful if you try and then uninstall the nightly, it can remove your FF8 bookmarks and settings if you aren't paying attention. Going to do a quick backup/restore. Yikes! :-)

  12. robnalexpress
    Member
    Posted 2 years ago #

    That's my next step- to try a beta version. I'll do that later tonight or tomorrow and post back.

    I'd be interested to know if this stable version works for you.

    Thanks Clayton, for taking the time to help me troubleshoot this- much appreciated!

    Rob

  13. ClaytonJames
    Member
    Posted 2 years ago #

    Confirmed. My 64 bit version of firefox, with the stable flash plugin version you posted, is working fine for me on your site.

    I'm stumped. :-)

  14. robnalexpress
    Member
    Posted 2 years ago #

    But you're using a different firefox version. I'll try that tomorrow and let you know if it works. Thanks for trying to help me figure this out!

  15. robnalexpress
    Member
    Posted 2 years ago #

    Tried the nightly version with no luck.

    ran the 64-bit installer for firefox
    What I meant was the 64 bit flash installer. I'm running FF out of the x86 Program Files directory (32 bit) too. I wonder if I can install a 32 bit version of flash player?

  16. ClaytonJames
    Member
    Posted 2 years ago #

    ran the 64-bit installer for firefox

    Me too. I ran the 64 bit flash installer from the link you gave me, and it worked fine.

    I wonder if I can install a 32 bit version of flash player?

    I don't see why not.

    Something else that might be worth checking into; I remember having some issues with a flash video player quite a while back. I recall that the solution had something to do with removing a corrupted flashplayer/browser local profile from the user settings. I don't recall exactly. Definitely a stretch, but not beyond the realm of possibilities I suppose.

  17. robnalexpress
    Member
    Posted 2 years ago #

    Clayton- Really appreciate your help! I'll look into profiles. I've read that others have had flash issues related to profiles. I also wonder if the firefox flash plugin might somehow be conflicting with the IE flash player, which is a separate program.

  18. robnalexpress
    Member
    Posted 2 years ago #

    I may just have to give up on this and hope that a future flash or firefox update straightens it out. I've tried everything I can think of.

    I uninstalled all flash players (using adobe's uninstaller), I uninstalled firefox, I deleted deleted everything in C:\Windows\system32\Macromed\Flash and C:\Windows\syswow64\Macromed\Flash, I deleted all residual firefox and flash files in user folders, and reinstalled everything from scratch, and get the same result.

    I tried the 32 bit flash plugin, and get the same results.

  19. ClaytonJames
    Member
    Posted 2 years ago #

    I'm definitely stumped. I'm sorry we couldn't pin it down!

  20. robnalexpress
    Member
    Posted 2 years ago #

    I'm gonna try creating a new firefox profile.

  21. robnalexpress
    Member
    Posted 2 years ago #

    No luck with the new firefox profile- same behavior. Maybe someone on the Mozilla or Adobe boards will offer a solution, or maybe someone will stumple across this thread who had and solved the same issue.

  22. robnalexpress
    Member
    Posted 2 years ago #

    SOLVED IT. You will not fracking believe it! It was my windows display settings! Was set to large (150%). I switched it to medium (125%) and now the audio player works! Unbelievable, but isn't that the way it so often turns out- just something ridiculously stupid. Thanks ClaytonJames for helping me troubleshoot all the more likely causes. [Insert appropriate Expletive Here!]

  23. ClaytonJames
    Member
    Posted 2 years ago #

    Who in the heck would have ever that could be the cause? Just one of those odd-ball things! Glad you got it working. :-)

  24. robnalexpress
    Member
    Posted 2 years ago #

    @ClaytonJames-

    Let me know if you can duplicate it:

    > Go to Control Panel\All Control Panel Items\Display.
    > Set dpi to 150%
    > Save (log out - log back in)
    > Open this page in Firefox 8.0.1
    > Click on any audio player.
    > Let me know if it plays.

    If a few people confirm it, I'll submit as a bug at Mozilla.

    Rob

  25. ClaytonJames
    Member
    Posted 2 years ago #

    And... we have a winner!!

    I just now tried it on a win 7 32bit box, 22 in display at 1680x1050.

    I set the dpi at 150%, made the change, visited the page, and guess what?

    When I hover over the play arrow, instead of turning solid white (as it should) it flickers back and forth between black and white, and when I click it, nothing happens

    That is exactly what I now see. I don't think it's a 32 -vs- 64bit issue.

    Good find on that one!

  26. robnalexpress
    Member
    Posted 2 years ago #

    Thanks so much, ClaytonJames. It's good to know I'm not totally losing my mind. At one point in this diagnostic process, it appeared that the problem was unique to my machine- which drove me nuts, since I'm borderline OCD about maintaining my computers.

    Once I get a couple more confirmations from users on the Mozilla thread, I'll post a bug report. After all, one shouldn't have to adjust screen settings every time one wants to play a clip, and old guys like me can't deal with the 125% setting on a high rez monitor without going blind.

    You've been an awesome partner in this process. I guess we'd better close this out, since it's not really an audio player issue- and I think we turned it into the longest thread under this tag :)

    Rob

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic