WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Audio Player] Not working in all themes (33 posts)

  1. landun
    Member
    Posted 4 years ago #

    I get the "Adobe Flash Player (version 9 or above) is required..." message in my main theme with Audio Player 2.0.1. It worked fine with the 1.x version.
    With WordPress Classic and WordPress Default themes it works fine.
    I've called wp_footer() in the footer.
    The XHTML and CSS validates without errors.

  2. doryphores
    Member
    Posted 4 years ago #

    @landun

    Can you post a link so I can have a look?

  3. moishelichtfuss
    Member
    Posted 4 years ago #

    Exact same problem here:

    http://lastheroofthewesternworld.com

    Error message is as follows:
    Audio clip: Adobe Flash Player (version 9 or above) is required to play this audio clip. Download the latest version here. You also need to have JavaScript enabled in your browser.

    Flash was updated, JavaScript is on.

  4. doryphores
    Member
    Posted 4 years ago #

    @moishelichtfuss

    You need to include a call to wp_footer() in your theme's footer. See more info here: http://wpaudioplayer.com/support/troubleshooting

    Martin

  5. moishelichtfuss
    Member
    Posted 4 years ago #

    thanks. it's done.

  6. RabNehpets
    Member
    Posted 4 years ago #

    I'm experiencing the same problem.

    My personal site (http://stephenbarkley.com) works perfectly with WordPress 2.9.1 & Audio Player 2.0.1, but my church site (http://wspc.ca) gives me the "Adobe Flash Player (version 9 or above) is required..." error.

    I've added the <?php wp_footer(); ?> just before the closing body tag in my footer.php file, but it didn't change anything.

    The site's http://wspc.ca. Any ideas out there? I'm pulling what's left of my hair out :)

  7. doryphores
    Member
    Posted 4 years ago #

    @RabNehpets

    Looks like you don't have the wp_head() call in your header.php file. These tags are very important as they are used by plugin developers to insert stuff into the HEAD section of the page or in the footer of the page. Without these calls, the plugin cannot do its job.

    Insert this in header.php just before the closing </head> tag.

    <?php wp_head(); ?>

    Martin

  8. landun
    Member
    Posted 4 years ago #

    Thank you! doryphores for the hero-of-the-day-award!

    My theme was also missing wp_head(), or rather it was commented out. Right now I have no idea why.

  9. jeremyt323
    Member
    Posted 4 years ago #

    I'm having the same issue with my site. Both header and footer calls are in. Java up to date. Javascript on. Any ideas?

    http://www.thepointcommunity.net/truth/sermons/

  10. RabNehpets
    Member
    Posted 4 years ago #

    Martin,

    Thanks so much for your help. The problem's solved.

    I'm considering moving to a premium theme like Thesis to avoid these coding mistakes in the future.

    Steve.

  11. abiedermann
    Member
    Posted 4 years ago #

    I believe I've got the same coding issue. The theme we are using is a bit buggy and I've made a lot of changes to the coding myself. Could you help me figure out what I'm missing?? Thanks.

    http://letsgetserious.net

    Alex

  12. doryphores
    Member
    Posted 4 years ago #

    @abiedermann

    Same thing, you need to add the wp_footer() call to your theme footer. Explained here:

    http://wpaudioplayer.com/support/troubleshooting

    Martin

  13. abiedermann
    Member
    Posted 4 years ago #

    Thanks Martin. It appears I'd added that call to the theme footer, but in whatever tinkering I'd done before I had taken get_footer out of the other template files. Thanks again.

  14. jeremyt323
    Member
    Posted 4 years ago #

    Topic not resolved for me. Both calls are in place. Can you take a look at my site Martin? Thanks very much!

    http://www.thepointcommunity.net/truth/sermons/

  15. doryphores
    Member
    Posted 4 years ago #

    @jeremyt323

    Yes I know. I checked your site and can't find what the problem is. You have 2 empty script tags in the footer. I'm guessing that one of them should be for Audio Player but is somehow empty. If you can, maybe you could try disabling your other plugins to see if this is caused by a conflict.

    Martin

  16. shambhavi
    Member
    Posted 4 years ago #

    Hi there, Martin

    Since upgrading to 2.9.1 from 1.8.4, the audio buttons look like this:

    http://jayakula.org/resources/music/

    Is the long white extension a new feature or a glitch? I liked the neat, small buttons. Can I get those back?

    Thanks!

  17. shambhavi
    Member
    Posted 4 years ago #

    P.S. Sorry - forgot to say am using v. 2.0.1 of audio player.

  18. shambhavi
    Member
    Posted 4 years ago #

    I "fixed" this by unchecking "transparent" for background and entering the hex code for the background color of my pages. The transparent setting worked fine before, but apparently not with my current set up. Using Firefox as usual, too. Thanks for a great little plug in!

  19. doryphores
    Member
    Posted 4 years ago #

    @shambhavi

    You're right. For some reason, the transparent option didn't work on your site. I'm having a look now to see if it is a bug.

    Martin

  20. doryphores
    Member
    Posted 4 years ago #

    @shambhavi

    I found the issue: There was a bug with the way the transparent background setting was migrated from the old version. I have fixed it now and the next update will fix it for all. Thanks again for spotting this one :=)

    Martin

  21. shambhavi
    Member
    Posted 4 years ago #

    No worries. It's always nice to be actually useful. Thanks again.

  22. jeremyt323
    Member
    Posted 4 years ago #

    Martin,

    I've messaged back-and-forth with the developer of the "sermon browser" plugin, which seems the most likely candidate to be causing my conflict above (there is another guy on his site having the same issue). He took a look at things and came back with the reply in this thread at his site:

    http://www.4-14.org.uk/forum/sermon-browser-support/audio-clip-adobe-flash-player-version-9-or-above-is-required-to-play-this-audio-clip

    Is there any way you could take a look at what he says and perhaps offer any suggestions? Thanks so much for all your help. I really appreciate it!!

    -Jeremy

  23. doryphores
    Member
    Posted 4 years ago #

    @jeremyt323

    I don't get it. I did notice that the code in the footer was missing but I have no idea why it's not showing up. I installed sermon browser on a test site here and everything works fine. The players display as they should. I also had a look through the code of the sermon browser plugin and I can't find anything out of order.

    I'm running out of ideas.

    Have you tried disabling your other plugins one by one to see if there is a conflict?

    Martin

  24. jeremyt323
    Member
    Posted 4 years ago #

    Martin,

    I went through and disabled each plugin one by one, with no luck. Now, I've rolled back to 1.2.3, and there's no icon displaying at all. I've just taken over this site, and the guy that designed it is much more knowledgeable than I am. I'm mainly just adding the content and hoped to leave design to him. He's unavailable at the moment, however.

    Can you re-look at my site just once more and see if you can decipher anything since the 1.2.3 rollback?

    Sorry for the trouble. Thanks so much for your help.

    -Jeremy

  25. codename_delta
    Member
    Posted 4 years ago #

    Martin,

    I too am having the exact issue as Jeremy and am also using Sermon Browser on the site. I have tried everything suggested here including deactivating all the plugins. I too notice that the code in the footer is missing.

    Also I have tried going back to version 1.2.3 and have the same issue as Jeremy in which nothing shows up in the list.

    If you would like to check it out, http://www.mbbchurch.org/messages

    Thanks for the help in advance!

    Dustin

  26. Ben Miller
    Member
    Posted 4 years ago #

    jeremyt323 & codename_delta, for 1.2.3, in the WordPress control panel, if you go to Settings, Audio player, do you see a player toward the bottom of the page looping through a 10 second silent test file? If you don't see this player, then you don't have the plugin installed correctly; the problem might be that the files were uploaded to the wrong location. See this post for more details.

  27. codename_delta
    Member
    Posted 4 years ago #

    Thanks bhengh,

    That resolved the 1.2.3 issue, but still having issues with 2.0.2.

    I have upgraded back to 2.0.2 so the Martin can look at it.

    Dustin

  28. Ben Miller
    Member
    Posted 4 years ago #

    Martin, could you post version 2.0 beta 6 somewhere so that these guys could test it and see if it works on their Sermon Browser sites?

  29. doryphores
    Member
    Posted 4 years ago #

    I have uploaded 2.0b6 to the WordPress plugin repository. You can download it from here:

    http://wordpress.org/extend/plugins/audio-player/download/

    Let me know if it works

    Martin

  30. codename_delta
    Member
    Posted 4 years ago #

    Martin,

    I downloaded 2.0b6, the assets were not included, but not sure if they have been updated since then. I used the assets from v2.0 and everything works as it did before. I have tried 2.0 itself as well and and it results in the same thing as 2.0.1 and 2.0.2.

    I'll stick with the beta for now. Again thanks for the help guys!

    Dustin

Topic Closed

This topic has been closed to new replies.

About this Topic