WordPress.org

Ready to get started?Download WordPress

Forums

Audio Player
Loading full post with AJAX, player doesn't show (5 posts)

  1. JonasVorwerk
    Member
    Posted 3 years ago #

    Hello

    We love the audio player on our music blog. But recently we changed our blog to show just excerpts and onclick the full post is being loaded and displayed. But now the players fails to load.

    The post which is loaded doesn't have a wp-header and wp-footer (it's still in the same page), so:
    - The main audio player script is loaded in the header.
    - The audio file settings are placed in the footer, so I changed the plug-in to add these settings at loop_end.

    But still no audio player. Anybody got some suggestions?

    This is the site I'm talking about: http://www.lowriderscollective.com

  2. choibc
    Member
    Posted 3 years ago #

    I got similar problem. I don't know why.
    I guess something wrong in php source since listing posts show audio-player flash mostly, but not 100%

  3. Michael
    Member
    Posted 3 years ago #

    I am also having the same issue. When I view a page on its own, the audio player shows up great, however when I load that same page into another page via AJAX, the player does not appear.

    Any suggestions on a work around?

    Thanks!

  4. JonasVorwerk
    Member
    Posted 3 years ago #

    still no solution..

  5. Michael
    Member
    Posted 3 years ago #

    I was playing around with this yesterday some more, and I figured one way around it.

    I grabbed the standalone version, and embedded it into the page I wanted to load via AJAX and it works. It ain't all that graceful, but it does get the job done.

    Maybe that will help?

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic