WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Assignment Desk] Assignment desk in multi-site = white screen on sites (2 posts)

  1. jonathan.morgan
    Member
    Posted 3 years ago #

    On a fresh install of WordPress 3.03 with multi-site turned on and no other plugins installed, network activating Assignment Desk causes all sites except the main one (and admins within those sites) to have blank screens.

    We are running Ubuntu 10.04.1, PHP version 5.2.14. We are up to date on ubuntu updates and on WordPress updates (there haven't been any yet since we installed today).

    Simply activiating the plugin (not network activating it) doesn't break sites, and it seems to work just fine in the main blog for the site. As soon as you "network activate" it, however, it breaks all sub-sites (still works in main site...).

    When I turn error reporting on in index.php and load one of the child sites pages, I get:

    Fatal error: Call to undefined function wp_get_current_user() in /var/www/spartan-online-newsroom/wp-includes/capabilities.php on line 1059

    This is inside a call to function "current_user_can( $capability )".

    If there is more I can do to help debug this, please let me know.

    Thanks,

    Jonathan Morgan

  2. Daniel Bachhuber
    Hand Built
    Posted 3 years ago #

    I was able to reproduce the issue but not immediately diagnose what was causing the problem. Because it's only appearing on network activate, I'm going to log it as a non-blocking issue we'll try to resolve for 1.0.

    Thanks for the detailed bug report and diagnosis!

Topic Closed

This topic has been closed to new replies.

About this Topic