WordPress.org

Ready to get started?Download WordPress

Forums

AskApache Google 404
[resolved] Cannot redeclare set_current_screen() (13 posts)

  1. Juffs
    Member
    Posted 3 years ago #

    After updating the plugin to version 4.8.2 I get the following error message.

    "Fatal error: Cannot redeclare set_current_screen() (previously declared in /wp-content/plugins/askapache-google-404/askapache-google-404.php:63) in /wp-admin/includes/template.php on line 3952"

    After manually removing the plugin and trying a new re-install I get the same error.

    Please could you look into this. Thanks for a great plugin.

  2. gorky5
    Member
    Posted 3 years ago #

    I found the same thing. My site was visible to the public but the error was locking me out of the admin area. I rolled back to the prior version and it seems to be OK again.

    Disappointing that a new release was issued without it being properly tested.

  3. desean
    Member
    Posted 3 years ago #

    i have the same issue. rolling back to 4.8.0 now

  4. Henrys44
    Member
    Posted 3 years ago #

    How do you roll back to 4.8.0? Thanks!

  5. tervan
    Member
    Posted 3 years ago #

    I would like the answer to this too I cannot log into my admin area now???

  6. Henrys44
    Member
    Posted 3 years ago #

    Tervan,
    Here is the link to download the previous versions.
    http://wordpress.org/extend/plugins/askapache-google-404/download/

    Just follow the installation instructions on the Plugin Homepage from there.

  7. askapache
    Member
    Plugin Contributor

    Posted 3 years ago #

    Wow big mistake on my part, sorry about that! Got a little anxious to get the update out there..

    I just released a fix 4.8.2.1 that fixes that and a jquery.cookies issue.

    BTW, please keep sending me any ideas for improvements, I implemented a ton of suggestions with this release and want any ideas for improvement you can think of. This plugin is a set-it and forget it deal because it's used on so many sites, so it has to be 1-click and it works. The 404 Google Tracking Code with asynchronous javascript? My favorite.

    Again, sorry for that coding error.. it's really not cool that it caused php errors to show up, a potential security problem for sure..

  8. Juffs
    Member
    Posted 3 years ago #

    Thanks for getting this sorted so quickly. Much appreciated.

  9. tervan
    Member
    Posted 3 years ago #

    Sorry about being a pain but I am still not able to log in to my admin area to upload the 4.8.2.1 fix. Any suggestions?

  10. askapache
    Member
    Plugin Contributor

    Posted 3 years ago #

    I have no idea what is wrong tervan.. I am debugging it as much as I know how and it's clean.

    Please give me any errors, a screenshot, as much as you can..

  11. tervan
    Member
    Posted 3 years ago #

    Below is what I get when trying to log into my admin area

    Fatal error: Cannot redeclare set_current_screen() (previously declared in /home/tervan/public_html/wp-content/plugins/askapache-google-404/askapache-google-404.php:63) in /home/tervan/public_html/wp-admin/includes/template.php on line 3948 is the message I'm getting

    I went into cpanel to upload the 4.8.2.1 fix to /wp-content/plugins/ but to no avail

    I am a novice at blogging so, it is probably something easy

    Thanks for getting back to me

  12. Juffs
    Member
    Posted 3 years ago #

    Tervan do you have FTP acccess to your domain? If you do (and know how to access it), one way to get past the problem you are facing is to manually delete the askapache-google-404 folder from your plugins directory via FTP.

    This will allow you to access your admin/back-end again and then you can install version 4.8.2.1 and get things running again.

    That is what I did and I haven't had any problems (even my settings seem to have been saved somehow - maybe they are stored in the WP database? Not sure). Please be warned however that doing this may result in loss of your previous settings/customizations for the askapache-google-404 plugin.

    The other guys will probably be able to provide you with a more "delicate" way of disabling the plugin, but removing the old version of the plugin entirely worked for me so I'm sure it will be fine for you. Since there have been quite a few updates to this new version of the plugin you would probably have to go through most of the settings again anyway just to check, so if you do lose them in the process of sorting out this problem it's not really gonna be an issue.

    Anyway - good luck. Hope you can get it sorted out without any unnecessary hassle.

  13. Gwyneth Llewelyn
    Member
    Posted 3 years ago #

    Wow, thanks for the quick update! I upgraded it, got the same error, but deleting the plugin and installing 4.8.2.2 worked flawlessly for me. Many thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic