WordPress.org

Ready to get started?Download WordPress

Forums

ArtistDataPress
[resolved] Warning curl_setopt() displayed instead of content (26 posts)

  1. jmkajdan
    Member
    Posted 2 years ago #

    Hi from Paris FR !
    I'm using WordPress 3.3.1. and after installing ArtistDataPress v0.35 and trying to display data's in a widget OR a Page, this message is displayed instead of content :
    "Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /wp-content/plugins/artistdatapress/artistdatapress.php on line 308
    There seems to be a problem with your feed URL.MORE SHOWS"
    Any solution ?
    I don't know much about coding...

    Thanks for your reply :)
    jm
    http://www.kajdan.com
    Edit Reply

    http://wordpress.org/extend/plugins/artistdatapress/

  2. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    Hey JM,

    Looks like that has to do with a setting on your server. If you're able to edit your PHP config, try turing off safe mode. If not, let me know, and I'll see what I can do.

    Slushman

  3. jmkajdan
    Member
    Posted 2 years ago #

    Hi Slushman,

    Thanks for your reply.
    Not really able to do it but ready to try with a tuto step by step.

    Thanks again,
    jm

  4. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Jm,

    I'm not sure how to go about that (it would be different for each person's hosting setup, but I just uploaded the 0.36 update, which includes a function that may be a work-around for you. Give it a shot and let me know if it works for you.

    Slushman

  5. jmkajdan
    Member
    Posted 2 years ago #

    Hi Slushman,

    I downloaded and installed the update but unfortunately, it still doesn't work :
    "Fatal error: Call to undefined function curl_redir_exec() in /wp-content/plugins/artistdatapress/artistdatapress.php on line 350"

    Thanks for helping,
    jm

  6. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    Doh! I called the function incorrectly. Download the plugin again in about fifteen minutes or so, I fixed the call so it should work now.

  7. jmkajdan
    Member
    Posted 2 years ago #

    Hi again,

    A new message :
    Fatal error: Call to undefined function curl_redir_exec() in /wp-content/plugins/artistdatapress/artistdatapress.php on line 471

    Hope it can help you :)
    tx
    jm

  8. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    Arg! Ok, got that one, try it again. :)

  9. jmkajdan
    Member
    Posted 2 years ago #

    Same thing ;)
    "Fatal error: Call to undefined function curl_redir_exec() in /wp-content/plugins/artistdatapress/artistdatapress.php on line 471"
    jm

  10. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    And you've downloaded the latest one, I made a small change and added it to the curent download. If it's still doing it, then I'm afraid you'll need to find a tutorial about turning off PHP safe mode or talk to your web host about it. Not sure how much more I can do from this end.

  11. alexbergermusic
    Member
    Posted 2 years ago #

    Hi Slushman,

    I love this plugin and it's been working fine since I installed it almost a year ago.

    Now I just started getting the following:

    'There seems to be a problem with your feed URL.'

    This is my XML feed:
    http://feeds.artistdata.com/xml.shows/artist/AR-IES80CH08022S2O8/xml/future

    I'm using version 0.36 and WordPress 3.3.1.

    Any ideas?

    Many thanks,

    Alex

  12. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Alex,

    Sorry about. I'll be issuing an update later today. Someone else already let me know about the issue and I've been working on the solution.

    Slushman

  13. alexbergermusic
    Member
    Posted 2 years ago #

    That's great news - about to announce a bunch of tour dates!

    All the best,

    Alex

  14. alexbergermusic
    Member
    Posted 2 years ago #

    I see you've been working on this...any idea when the 0.37 update will be available?

  15. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    It's available now. :)

  16. jmkajdan
    Member
    Posted 2 years ago #

    Hi Slushman
    Thanks for the update but unfortunately, it's still not working with my WP configuration.

    Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /wp-content/plugins/artistdatapress/artistdatapress.php on line 352
    ArtistDataPress
    There seems to be a problem with your feed URL.

    Thanks,
    jm

  17. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    Hey JM,

    Unfortunately, that's a server config issue. I've tried to figure out a way around this, but PHP safe mode has to be turned off in order to get the XML feed from ArtistData. If you can turn safe mode off yourself, I'd recommend it. Everything I've read says turning safe mode isn't a major security risk, but I've heard that some hosts (like GoDaddy) have it turned on to protect their servers. I can try to find another way around the issue, but the way it works right now is the safest and most secure way out there that I've found.

    Slushman

  18. starrockdan
    Member
    Posted 1 year ago #

    I am having issues with the widget. I have followd the instructions and have my feed entered in correctly but I just see "Please enter a feed in the options page" instead of my shows. Under settings layouts i can see an example of my shows so I know the feed is working.

  19. slushman
    Member
    Plugin Author

    Posted 1 year ago #

    Hey starrockdan,
    Since you're not having the exact same issue, can you start a new post? It's best to keep issues separated on the forums so people can find answers later. :)
    Slushman

  20. alexbergermusic
    Member
    Posted 1 year ago #

    Hi Slushman,

    I can't access the settings from my dashboard for ArtistData.

    I get this message: Your PHP settings are incompatible with ArtistDataPress. The PHP setting, open_basedir is currently . Please change the setting on your server to empty.

    I've updated to the latest version of WordPress (3.4.2)

    Any ideas? The main issue is that currently the date is not showing on my shows.

    Many thanks,

    Alex

  21. slushman
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Alex,

    I added that check in there to make sure people's server settings were correct so they could run ADP, since I've had lots of complaints about it not working correctly. Unfortunately, this message means you'll need to change the open_basedir setting so you can run ADP without issues. You'll probably want to contact your web host to have them do it so its secure too.

    On my server, open_basedir has no value, it looks like yours has ".", which is a special settings, according to the documentation.

    http://php.net/manual/en/ini.core.php

    Sorry for the trouble, hopefully the server setting change will fix the dates issue too.
    Slushman

  22. slushman
    Member
    Plugin Author

    Posted 1 year ago #

    Hey guys,
    0.5 switches from using cURL (and PHP) to get your XML feed to using a built-in WordPress function. This should resolve all the issues with the server settings. Check it out and let me know!
    Slushman

  23. starrockdan
    Member
    Posted 1 year ago #

    When I try and activate the plugin I get this error now.

    Parse error: syntax error, unexpected T_SL in /home/content/72/6270772/html/bonesWP/wp-content/plugins/artistdatapress/inc/adp_widget.php on line 58

  24. slushman
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Dan,
    Try the new 0.51 update. There was some weird line in the widget code, its out now.
    Slushman

  25. starrockdan
    Member
    Posted 1 year ago #

    That is the error I get with the 0.51 update.

  26. slushman
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Dan,
    For some reason, there was a conflict with my files when I tried to update it earlier and there was a bunch of gibberish added to the files, which is what that error refers to. I've cleaned all the mess out (I double checked them all on my development site) and they should be clean now. The latest version is 0.52. Let me know if you're still getting that error.
    Slushman.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic