WordPress.org

Ready to get started?Download WordPress

Forums

ArtistDataPress
[resolved] Shortcode on page displays no gigs (29 posts)

  1. djalbertfreeman
    Member
    Posted 2 years ago #

    I'm developing a new website for Wilful Missing and was delighted to find this plugin for ArtistData gigs. Although I've got the widget working, and that looks great, I can't get the shortcode to display any gigs. The shortcode displays the 'more shows' link, but nothing above it. Here is where you can see this problem:

    Test gigs page, with [artistdatapress] shortcode (not working):
    http://www.digitalimperative.org/wilfmiss/gigs-via-artistdata-plug-in/

    Homepage with ArtistDataPress widget (working, in the left column):
    http://www.digitalimperative.org/wilfmiss/

    This is the XML feed I'm using:
    http://feeds.artistdata.com/xml.shows/artist/AR-49B2297EE328FB6A/xml/future

    I don't 'think' I'm doing anything wrong, so is this a bug that can be fixed?

    http://wordpress.org/extend/plugins/artistdatapress/

  2. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    Hey DJ,
    Sorry about the error, but thanks for pointing it out! I've been hacking away at tonight and found the problems. I've uploaded version .341, which should fix the problem you're seeing (and I fixed another one I noticed while I was working on this one).
    Thanks, great looking site, by the way!
    Slushman

  3. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    Scratch that, try version .35, better validation included and the problems you described are fixed.

  4. djalbertfreeman
    Member
    Posted 2 years ago #

    Thanks for looking into this slushman. It's now working on the test site, but not on the live site.

    On the test site, the homepage widget still looks excellent, and the shortcode on the gigs page also now works:

    http://www.digitalimperative.org/wilfmiss/gigs-via-artistdata-plug-in/

    However, on our live site, I'm experiencing a rather worrying problem. In both the widget, and on the gigs page I see the following error:

    Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /[sitepath*]/wp-content/plugins/artistdatapress/artistdatapress.php on line 308
    There seems to be a problem with your feed URL.

    *In the above, there was a URL to our full site path, but rather than taking the risk of displaying the folder structure for the entire world to see on this forum, I've replaced it with [sitepath]

    I'm not familiar enough with the error message structure to be able to determine precisely what the problem is, but it looks to be as though it might be a server setting issue. It's only affecting this plugin though. Any suggestions as to why this might be happening with your plugin, and what the solution might be?

    I'm glad you like the site by the way, I've been working on it for a while with a friend, Ben McKenna of Totaal who must take a lot of the credit. :-)

    Thanks,
    Alb

  5. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Alb,

    Sorry I never got back with you on this. Yes, it is a setting on your server. If you're able to edit the PHP config, turn off safe mode. If you're not able to do that, let me know and I'll see what I can work up. It looks like there's another person with this issue too.

    Slushman

  6. Stephen Quirk
    Member
    Posted 2 years ago #

    I'm running .36 and having the same problem. I can't leave it running because the site is in production.

  7. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    Hey sdquirk,

    if you're talking about the CURLOPT_FOLLOWLOCATION issue, that's a setting that will need to be changed on your server. If you can change it, turn off PHP safe mode. If you can't make that change yourself, I'd contact your web host or server admin and ask them to turn it off. Unfortunately, that's the only solution I've seen so far.

    Slushman

  8. Stephen Quirk
    Member
    Posted 2 years ago #

    I'm on a shared Godaddy server, so I don't know that this is a solution for me. It's strange, it was working very will and just stopped recently. Thanks.

  9. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    hey sdquirk,

    I just uploaded 0.371, try it out and let me know if it's still giving you issues. If it's still the PHP safe mode, I really would try talking to GoDaddy. They may have a server they could move you to that has safe mode turned off. I'm betting they do just to be cautious, but its really not needed. That, or I'd find another web host. I can recommend a few, if you're interested. :)

    Slushman

  10. bluefishbrothers
    Member
    Posted 2 years ago #

    Hi Slushman,

    Great plugin! We use it on our band's website and love it.

    It has worked for many months but then suddenly it stopped working. It displays 'There seems to be a problem with your feed URL.'. I tried everything, but I can't get it to run.

    I also checked about PhP safe mode, but it's already turned off at our server.

    Can you help me? We are at http://www.bluefishbrothers.nl and the artistdata profile is at http://artistdata.sonicbids.com/bluefish/shows/

    Yours,
    Geert

  11. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Geert,

    Which version are you using? I just updated to 0.372 the other day to resolve this exact issue. If you're not already using that version, update and try it again. If you are using the latest version, let me know.

    Slushman

  12. bluefishbrothers
    Member
    Posted 2 years ago #

    Hi Slushman,

    I'm up to date at 0.372. WordPress is up to date as well.

    I hope you can find out what's going wrong.

    Geert

  13. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Geert,

    Can you give me the XML feed URL from your ArtistData Tools page? Thanks,

    Slushman

  14. bluefishbrothers
    Member
    Posted 2 years ago #

    Hi Slushman,

    The XML feed for Future shows is:

    http://feeds.artistdata.com/xml.shows/artist/AR-MDW7QAXD6UPB9CBU/xml/future

    Geert

  15. bluefishbrothers
    Member
    Posted 2 years ago #

    Weird, huh?

  16. firsttryfailed
    Member
    Posted 2 years ago #

    Hi Slushman,

    Love the plugin! I am trying to use it on my site, the widget worked great but the shortcode version only showed me a few dates then cut off my footer somehow. Any suggestions?

    http://dev.dlocsworld.com/tour/
    xml feed - http://artistdata.sonicbids.com/kottonmouth-kings/shows/xml/future

    Any help would be greatly appreciated.
    Thanks man!
    -Chris

  17. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    @Geert - very. The XML feed works on my test site, so I'm not really sure what to tell you. Could you delete the plugin and reinstall it?

    @Chris - The first thing I noticed is the default.css isn't loading, so the layout looks a bit odd. I would try deleting the plugin and reinstalling it. The latest update 0.372 should have fixed the layout issue, which I'm guessing is related to the cut off footer issues as well.

  18. bluefishbrothers
    Member
    Posted 2 years ago #

    Hi Slushman,

    I deleted the plugin and reinstalled it. Still the same: "There seems to be a problem with your feed URL."

  19. tboston007
    Member
    Posted 2 years ago #

    Hi Slushman,
    I love the concept of this plug in but can't get it working properly

    Is there information somewhere on how to change the look?
    Thanks

    Here is the url
    http://calendar.toddboston.com/?page_id=2

    and I am getting this error

    Fatal error: Uncaught exception 'Exception' with message 'DateTimeZone::__construct() [datetimezone.--construct]: Unknown or bad timezone (System/Localtime)' in /home/content/t/b/o/tboston007/html/calendartb/wp-content/plugins/artistdatapress/inc/layout.php:117 Stack trace: #0 /home/content/t/b/o/tboston007/html/calendartb/wp-content/plugins/artistdatapress/inc/layout.php(117): DateTimeZone->__construct('System/Localtim...') #1 /home/content/t/b/o/tboston007/html/calendartb/wp-content/plugins/artistdatapress/inc/layout.php(43): Layout->default_layout() #2 /home/content/t/b/o/tboston007/html/calendartb/wp-content/plugins/artistdatapress/artistdatapress.php(446): Layout->get_layout(NULL) #3 [internal function]: ArtistDataPress_Plugin->shortcode('', '', 'artistdatapress') #4 /home/content/t/b/o/tboston007/html/calendartb/wp-includes/shortcodes.php(235): call_user_func(Array, '', '', 'artistdatapress') #5 [internal function]: do_shortcode_tag(Array) #6 /home/content/t/b/o/tboston007/html in /home/content/t/b/o/tboston007/html/calendartb/wp-content/plugins/artistdatapress/inc/layout.php on line 117

  20. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    Hey bluefishbrothers,

    Can you make a php info page and shoot me the URL? Feel free to email me rather than post the URL here. I'm thinking there's got to be a difference between your PHP config and mine because your feed works fine on my development site.

  21. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    Hey tboston007,

    I'm seeing two separate issues here. First, you're missing the CSS file that makes your shows page layout correctly. I believe if you delete the plugin and reinstall it, it will fix that.

    The second issue is the DateTimeZone issue, which someone else reported too. Can I get the URL for your shows feed? I'll need that to help narrow down the problem.

  22. tboston007
    Member
    Posted 2 years ago #

    Thanks for the reply!
    I just deleted the plug in and re-installed and entered back on the page
    http://calendar.toddboston.com/?page_id=2

    Here is the xml for show feed
    http://feeds.artistdata.com/xml.shows/artist/AR-0VQB0H07MWDNW26U/xml/future

    Here is an url for just the shows page on artist data
    http://artistdata.sonicbids.com/todd-boston/shows/

    Thanks!

  23. bluefishbrothers
    Member
    Posted 2 years ago #

    Hi Slushman,

    I cannot find your email address. Can you give it to me?

    Thanks!

  24. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    Sure thing, I guess it's not posted on my site after all! :)

    chris at slushman dot com

  25. tboston007
    Member
    Posted 2 years ago #

    Hey Slushman, any response to my last post?
    Thanks

  26. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Todd,

    Sorry, I've been trying to work out the fatal exception error issue. The reason the shows on your page are al lout of whack is because for some reason, the default.css, which contains the actual layout for that page, is not loading. Can you check the plugin folder on your server and make sure the file is there? It should be in:

    wp-content/plugins/artistdatapress/css/default.css

  27. djalbertfreeman
    Member
    Posted 2 years ago #

    Hello Slushman. I'm back. :-)
    I've finally managed to get somewhere with the PHP safe mode issue, so that error is no longer showing. However, I'm still not seeing my gigs.

    The following code from our server says that safe mode was already off:

    [PHP]
    short_open_tag = off
    asp_tags = Off
    precision    =  14
    y2k_compliance = Off
    output_buffering = on
    allow_call_time_pass_reference = On
    cgi.force_redirect = On
    cgi.fix_pathinfo=1
    
    safe_mode = Off
    safe_mode_exec_dir =/nonexec/
    
    disable_functions =

    The hosting company's advice was:

    If you install mod_ruid, this gets rid of 99% of safe_mode errors.

    I installed mod_ruid, and that did indeed eradicate the safe mode error. However, I see no gigs. Both the shortcode on our gigs page, and the widget I tried on the home page, just show the "powered by ArtistData" logo.

    Here is the page the shortcode is on:
    http://wilfulmissing.co.uk/gigs-artistdatapress/

    Here is our XML feed:
    http://feeds.artistdata.com/xml.shows/artist/AR-49B2297EE328FB6A/xml/future

    I've tried various permutations of settings in the plugin, but it still shows blank.

    Sorry this is a long reply, but hopefully all the info above will help you identify the issue. Can you help?

    Thanks.

  28. slushman
    Member
    Plugin Author

    Posted 2 years ago #

    Hey DJ,

    Can you email me? I'd like to get more info from you, but you won't want to post it on here. chris at slushman dot com. If I get a solution, I'll post it here for everyone else who comes across this thread, or I'll post an update to the plugin with the fix.

    Thanks
    Slushman

  29. slushman
    Member
    Plugin Author

    Posted 1 year ago #

    Hey DJ (and everyone else),
    The 0.5 update should resolve this issue by using a built-in WordPress function rather than cURL and PHP. Check it out and let me know.
    Slushman

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic