WordPress.org

Ready to get started?Download WordPress

Forums

Arconix Portfolio
[resolved] Invalid Argument Supplied - Error on Portfolio page (8 posts)

  1. lorielue
    Member
    Posted 1 year ago #

    I just downloaded this plugin and I'm so excited because I've been looking for months for something like this, just a simple portfolio, and I haven't been able to find one. This looks like exactly what I want, except I am getting an error on my Portfolio page:

    Warning: Invalid argument supplied for foreach() in /home/motif/public_html/wp-content/plugins/arconix-portfolio/includes/class-portfolio.php on line 367

    I simply installed the plugin, created a portfolio page, and added the short code. Then I added a sample test portfolio item.

    Here is my Portfolio page, showing the error on it: http://www.sitemotif.com/portfolio/

    http://wordpress.org/extend/plugins/arconix-portfolio/

  2. John Gardner
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Lorielue,

    I apologize for the problem you're having with my plugin. I'm in the process of developing a fix and will release it ASAP.

  3. John Gardner
    Member
    Plugin Author

    Posted 1 year ago #

    I just released the update to the plugin that resolves this issue. Thanks for your patience.

  4. lorielue
    Member
    Posted 1 year ago #

    Fantastic, thank you very much for looking into this. I will download the update now!

  5. lorielue
    Member
    Posted 1 year ago #

    Well, it looks like my theme (Origin by DevPress) has FancyBox included by default. This lightbox code is stopping your feature image link from working. Since that's the only way to link into the portfolio item and the link is being overwritten by the lightbox, there is no way to open a portfolio item.

    I tried adding a couple classes to your code (nolightbox and nofancybox)in class-portfolio.php line 398 based on other support forums, but no luck :(

    I also tried the function disable_fancybox() but that didn't work either. (my guess is that either "portfolio" isn't being recognized as a page at the time it calls?)

    I know there has to be a way to override the fancybox, because on my index page the feature images are correctly working as links. Just not sure how to make that happen in the Portfolio page. I even tried the class "featured" on the link, as is being used in my index page. But it doesn't help.

    I'll keep searching, but feel free to let me know if you have any ideas. Thanks again for all your help

  6. John Gardner
    Member
    Plugin Author

    Posted 1 year ago #

    I went to the site you provided in your initial question and clicked on a portfolio item. I got what I consider to be normal "lightbox" behavior -- the image flew out in a lightbox. Are you trying to link to the portfolio item page and not to the image?

  7. lorielue
    Member
    Posted 1 year ago #

    Yes, My understanding is that the image opening the portfolio page is the intended functionality, especially since the title doesn't link. It seems there is no other way to open each portfolio detail page. Your code appears to be setup to turn the image into the link for the resulting page, however the fancybox lightbox in my theme seems to be over writing the link causing it to open a lightbox instead of the related portfolio page.

  8. John Gardner
    Member
    Plugin Author

    Posted 1 year ago #

    Linking to a detail page (instead of the image) is possible.

    Your shortcode would need to have link="page" added to it, resulting in something like this (assuming no other parameters are passed): [portfolio link="page"]

    There's a potential for a little more work when linking to pages. You can read this blog post to learn more about what those modifications might be:

    http://arconixpc.com/2012/linking-portfolio-items-to-pages

    Let me know if I can help you further.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic