WordPress.org

Ready to get started?Download WordPress

Forums

Arconix Flexslider
[resolved] [Plugin: Arconix FlexSlider] Autoplay on and off? (3 posts)

  1. GerritKuilder
    Member
    Posted 2 years ago #

    Would it be an option to be able to turn autoplay on or off?

    http://wordpress.org/extend/plugins/arconix-flexslider/

  2. John Gardner
    Member
    Plugin Author

    Posted 2 years ago #

    I apologize for getting back to you so late. I didn't realize until now that I didn't subscribe to the support feed. There isn't currently an option to turn autoplay on and off, but it's something I'll look to add

  3. John Gardner
    Member
    Plugin Author

    Posted 2 years ago #

    GerritKuilder,

    I'm such a fool. While there is no shortcode option to do that, autoplay can be turned off by changing the javascript that initializes the slider script.

    The easiest way to do so is to navigate to the js folder inside my plugin directory -- wp-content/plugins/arconix-flexslider/js/ -- and copy the flexslider.js file to the root of your theme folder and re-name it to arconix-flexslider.js (All of that is to make sure you don't lose the change we're going to make when I update the plugin in the future).

    Inside arconix-flexslider.js, you'll see the following:

    jQuery(window).load(function() {
        jQuery('.flexslider').flexslider( {
    	pauseOnHover: true,
            controlsContainer: ".flex-container"
        } );
    } );

    add slideshow: false, right below the pauseOnHover line and that should take care of it.

    Your new code should look like this:

    jQuery(window).load(function() {
        jQuery('.flexslider').flexslider( {
    	pauseOnHover: true,
            slideshow: false,
            controlsContainer: ".flex-container"
        } );
    } );

    Let me know if you run into any other issues.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic