WordPress.org

Ready to get started?Download WordPress

Forums

Approval Workflow
No Notification (12 posts)

  1. Sean
    Member
    Posted 2 years ago #

    I'm not getting workflow submission notifications. I have the approval set to administrator and had a user submit a revision but two things happened:

    Initially, he updated his page and the change went live without my knowledge, but it wasn't visible in the edit page. Fixed that by checking the box for submit to workflow which removed the change from the live site.

    So, the user made the change again, this time checking the box to submit to workflow before updating. I'm not getting any notification and I'm the admin.

    I initially tested out this plugin before deploying it and was working correctly.

    http://wordpress.org/extend/plugins/approval-workflow/

  2. ericjuden
    Member
    Plugin Author

    Posted 2 years ago #

    Hi, there is a new version available. Please update and let me know if this helps.

    Eric

  3. Sean
    Member
    Posted 2 years ago #

    Thanks, Eric. I will let you know if I encounter a similar issue.

  4. Sean
    Member
    Posted 2 years ago #

    I tested a submission and got the following error:

    Warning: array_pop() [function.array-pop]: The argument should be an array in /home/[xxxxx]/public_html/wp-content/plugins/approval-workflow/approval-workflow.php on line 248

    Warning: Cannot modify header information - headers already sent by (output started at /home/[xxxx]/public_html/wp-content/plugins/approval-workflow/approval-workflow.php:248) in /home/[xxxx]/public_html/wp-includes/pluggable.php on line 881

  5. ericjuden
    Member
    Plugin Author

    Posted 2 years ago #

    Whoops, I had a variable named wrong. I just pushed up the changes. Watch for 1.3.1.

    Eric

  6. Sean
    Member
    Posted 2 years ago #

    I updated to 1.3.1 and submitted another change by my test user but have not received the admin notification.
    I do not get the array or modify header warnings though.
    Additionally, all changes are still being published to the live page (whether the checkbox is selected or not.)

    My test user is allowed to edit pages & edit published pages but cannot publish new pages. If I remove either of these options my user cannot even access the pages admin menu.

  7. ericjuden
    Member
    Plugin Author

    Posted 2 years ago #

    You will want them to have all edit_ permisions, just not publish_ permissions. I can verify that email notifications are working in my setup. Is it possible they are going to spam? I have tried this on 2 different setups now and both send email just fine.

    Eric

  8. Sean
    Member
    Posted 2 years ago #

    I'll have to do some more research into why I'm not getting the notifications...
    They don't appear to be going to spam. I do receive notifications from some users but not all (even though they share the same role).
    Here's a screenshot of the user role I've modified.
    http://i46.tinypic.com/fe2ves.png

  9. ericjuden
    Member
    Plugin Author

    Posted 2 years ago #

    You may want to give them edit_private_ permissions as well. I guess it depends on your setup.

    Eric

  10. wstevenson
    Member
    Posted 1 year ago #

    Where you guys able to solve the notification issue? I have made myself a Contributor and my CCO a Author but he is not receiving email notifications. Any thoughts?

    Thank you!
    WS

  11. ericjuden
    Member
    Plugin Author

    Posted 1 year ago #

    Hi wstevenson,

    Did you go into the plugin settings and change the role set to receive the notifications? By default it is Administrator.

    Eric

  12. wstevenson
    Member
    Posted 1 year ago #

    Hi Eric, yes, I have tried doing that and they are still not receiving the emails. Any other thoughts?
    Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic