WordPress.org

Ready to get started?Download WordPress

Forums

Plugin API HTTP Error (42 posts)

  1. JeffreyHoschak
    Member
    Posted 5 years ago #

    I am trying to install plugins from the dashboard, but when I try to search or use the featured or popular button, I get the following error:
    An Unexpected HTTP Error occurred during the API request.

    How do I resolve this issue?

  2. skywolfyx1
    Member
    Posted 5 years ago #

    i have the same problem, anybody help us

  3. skywolfyx1
    Member
    Posted 5 years ago #

    i have the same problem, anybody help us

  4. wikinerd
    Member
    Posted 5 years ago #

    same here.

  5. Creap
    Member
    Posted 5 years ago #

    +1

  6. Anthony Acosta
    Member
    Posted 4 years ago #

    "An Unexpected HTTP Error occured during the API request"

    Very annoying, don't have a clue how to troubleshoot this one.

  7. sybold
    Member
    Posted 4 years ago #

    same problem, and i can't fix it on my own. please anybody?

  8. jasonrhodes
    Member
    Posted 4 years ago #

    All I can tell, at this point, is that this is typically a proxy error. I have my site situated so that it bypasses the main proxy server, so I can avoid caching while the site is in development.

    Because of that, I think, I am getting the exact error you all are talking about in several places throughout the admin section.

  9. jimmiwin
    Member
    Posted 4 years ago #

    So anyone finally resolve this?

  10. paavels
    Member
    Posted 4 years ago #

    I did.

    Short answer: Probably server DNS settings aren't properly configured

    Long answer:

    wp-includes/http.php file has lines:

    $response = array( 'headers' => array(), 'body' => '', 'response' => array('code' => false, 'message' => false), 'cookies' => array() );
    		foreach ( (array) $transports as $transport ) {
    			$response = $transport->request($url, $r);

    Add line after to see the error:

    print_r($response);
  11. efree_unix
    Member
    Posted 4 years ago #

    The cause of error is too long in the process of requesting the API plugin in the wordpress server so that the operation timed out. By default, wordpress give 5 seconds time limit to request a plugin. If within 5 seconds does not get a replay, then the process will be stopped and displayed an error "An Unexpected HTTP error occurred during the API request."

    Open wp_include/http.php file on line 223

    'timeout' => apply_filters( 'http_request_timeout', 5),

    change the script above into

    'timeout' => apply_filters( 'http_request_timeout', 30),

    If you understand about Indonesian language, You can visit my new blog here. Here is the complete explanation.

  12. cornettes
    Member
    Posted 4 years ago #

    Thanks efree_unix, I honestly didn't think that would work because I have dozens of sites with the exact same configuration and only a few were giving this error, but i made the change you suggested and it worked.

  13. hartwigrobert
    Member
    Posted 4 years ago #

    THANKS!! The timeout change to 30 worked like a charm.
    I had the same error when searching for a new plugin.

    "An Unexpected HTTP Error occured during the API request"

  14. davidgeisbush
    Member
    Posted 4 years ago #

    I've got this same error message and have tried changing the timeout to 30 seconds with no joy. This began when I tried to activate 5-6 plugins at once and completely blocks my use of the admin dashboard.

    PS. I'm running wordpress 2.8.4 on linux (off a QNAP server) with no outside access so it shouldn't be a DNS issue.

  15. stengah
    Member
    Posted 4 years ago #

    The timeout limit fix did not work for me either.

    As this in my case is on a completely new install of WP (no added plugs) I suspected this error to occur to be caused by lack of WordPress API key under the Akismet plugin settings.

    However, trying that did not help either – neither has incrementiung the limit (as per fix above) to 45 secs).

    Help would be appreciated

    /Mads

  16. h4x3d
    Member
    Posted 4 years ago #

    same problem.

  17. Robomaster
    Member
    Posted 4 years ago #

    Same problem - I did a little digging and found the problem. There's some command called fsockopen that is usually disabled on free hosts: I'm using freehostia and they apparently disabled it. This means that wordpress doesn't have access to html freely and can't look up the plugin directory, theme directory, or automatic update directory. It stinks... Anybody know a free host with reasonable storage and bandwidth that has fsockopen enabled?

  18. Food Blogger
    Member
    Posted 4 years ago #

    Extending the time to timeout worked for me! Thanks efree!

  19. delphig
    Member
    Posted 4 years ago #

    WP_Error Object ( [errors] => Array ( [http_request_failed] => Array ( [0] => Empty reply from server ) ) [error_data] => Array ( ) )

    After setting the debug as per paavels comment this is what I get..
    Anyone with ideas.. Still getting the API timeout

  20. rogeriomello
    Member
    Posted 4 years ago #

    efree_unix, thanks for the tip of timeout. It solved not just this problem, as also another one I was having with attachments.
    (don't ask me how, but it was magically solved after I changed the http.php)

  21. Obstinate
    Blocked
    Posted 4 years ago #

    I wish it solved mine. About an hour ago I started getting this message for the first time ever. I've not installed any plugins for over a week. I only have about 10. Now I can't access my dashboard at all. It has been giving me the API message for almost an hour now. I'm stuck. :(

    *UPDATE*

    Sexybookmarks was the culprit. I've just uninstalled it via FTP and hey presto! :)

  22. scharfenberg
    Member
    Posted 4 years ago #

    I had the same problem on several sites with WP. I also disabled Sexybookmarks by FTP and it solved the problem.

    Hope there will be a fix for this as Sexybookmarks is a very popular plugin.

  23. Paradisewriter
    Member
    Posted 4 years ago #

    Obsinate,

    I am getting the same error and also have Sexybookmarks installed. I am in FTP right now and am wondering if I just delete it to uninstall? If not, please share the steps you followed to uninstall it.

    Thank you and Happy Thanksgiving!

  24. Obstinate
    Blocked
    Posted 4 years ago #

    Hey, Paradisewriter

    Yep, that's literally all I done via FTP. I found the SexyBookmarks folder, clicked delete (again, all through FTP) - then I went back to my dashboard and clicked 'Try again' and it worked. Everything was back to normal. It was a 2 second job that had me pulling my hair out for an hour!

    Good luck. :)

  25. Paradisewriter
    Member
    Posted 4 years ago #

    Obstinate,

    Worked like a charm! I too was pulling my hair out for the last hour or so, thank you so much for taking the time out of your Thanksgiving day to respond.

    A Big Mahalo (thank you)!

  26. bojanglin
    Member
    Posted 4 years ago #

    Thanks for the tip Obstinate. I had the same exact issue today and it never happened to me before. I just deleted Sexybookmarks from my FTP account and everything is now fine!

    Happy Thanksgiving everyone!!

  27. alliant
    Member
    Posted 4 years ago #

    Same issue here in ATL on 3 WP sites JUST TODAY ONLY, called GoDaddy no help. Did the 30 time thing, no change. No sexybook marks. Why today when I have time to work on sites? Thanks, Michael

  28. eight7teen
    Member
    Posted 4 years ago #

    Bravo to everyone who made the mass assumption that SexyBookmarks was to blame... In all actuality, it's a WordPress issue.

    SexyBookmarks makes use of the WordPress API, and therefore yes, disabling the plugin will "fix" your problem... However, there are countless others of you who do not have, nor have ever had SexyBookmarks installed who have run into the same issue. Coincidence?

    Before everyone points the shameless finger of blame in the wrong direction, why not ask WP to either FIX it's API, or maybe just post up some damn documentation so that plugin developers aren't using "guesswork" in terms of accessing it?

    Don't believe me? Check this out: http://api.wordpress.org/

  29. ijango
    Member
    Posted 4 years ago #

    I have multiple Wp sites up and running, hosted through GoDaddy. Just started two new ones this evening. I'm getting the same error not only on my news sites without any plugins ( Except askimet )but also my old ones. I cannot upload themes or plugins. The WP RSS feeds on the dashboard are also not populating due to the same error. HTTP error & Timed out & cannot connect to host. Any suggestions?????

    GoDaddy says it's all good on there end. WP must be having a problem.

    Thanks,

    J

  30. wpjordan
    Member
    Posted 4 years ago #

    Hi All -- I am having this problem without SexyBookmarks (or any other plugin) installed.

    Has been about 12 hours since this started.

    New installation, new site. No plugins other than defaults. Only default theme installed. Changed the WP-Includes/http.php from default 5, to 45, with no change.

    Any suggestions or ideas?

    Thanks,
    Jordan

Topic Closed

This topic has been closed to new replies.

About this Topic