WordPress.org

Ready to get started?Download WordPress

Forums

Anyfeed Slideshow
[resolved] Newbie help with slideshow (64 posts)

  1. nnlee
    Member
    Posted 3 years ago #

    I'm trying to test plugin Anyfeed Slideshow, but I'm kind of new at all this and it's not working. For example, if I wanted to add the feed for images from NASA at http://www.nasa.gov/rss/image_of_the_day.rss, what would I put in the feed URL field of the widget? That URL?

    http://wordpress.org/extend/plugins/anyfeed-slideshow/

  2. Soleil Golden
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Nnlee,

    This would appear to be a bug caused by NASA only having one image in that feed (which makes it quite difficult display a slide show!). I will resolve this issue in the next release by including a check for how many images are in a feed.

    I should be able to have this release out by the end of the day today.

    Thanks for the feedback!

  3. nnlee
    Member
    Posted 3 years ago #

    Thanks! I appreciate it. But was I correct in adding that URL?

  4. Soleil Golden
    Member
    Plugin Author

    Posted 3 years ago #

    My pleasure! And yes you were. :)

  5. ohippyday
    Member
    Posted 3 years ago #

    Hi there! I am also trying to test the Anyfeed plugin using the feed to my Picasa album. I'm getting an error message in the sidebar saying "Failed to write XML". Could this be caused by the URL I'm using? Thanks!!

  6. Soleil Golden
    Member
    Plugin Author

    Posted 3 years ago #

    nnlee,

    I just checked in a new version, 1.0.1, which I have tested and found to be working with single image RSS feeds (specifically tested with the NASA feed you listed above). It should post to the site in the next 15 minutes, at which time you should be able to upgrade the plug-in from your WordPress install. Please let me know here if it gives you have any more trouble!

    Hi ohippyday,

    This could be caused by limitations at your hosting provider, but I'd like to see if it's something I can work around. Could you please open a new topic here with your issue? If you have time, I'd love to work with you on figuring out the cause of that problem so I can see about fixing it.

    Thanks!

  7. blucodelap
    Member
    Posted 3 years ago #

    Hi Soleil
    In my site I see this error:

    "Warning: tempnam() [function.tempnam]: open_basedir restriction in effect. File(/var/tmp) is not within the allowed path(s): (/usr/local/psa/home/vhosts/blucode.com/httpdocs:/usr/local/psa/home/vhosts/blucode.com/httpdocs/tmp) in /usr/local/psa/home/vhosts/blucode.com/httpdocs/wp-content/plugins/anyfeed-slideshow/anyfeed_slideshow.php on line 114
    Failed to open temp file."
    page site is > http://blucode.com/?page_id=518
    and link to my feed > feed://vimeo.com/blucodelap/subscriptions/videos/rss
    can you help me?
    thank you very much
    Maurizio

  8. blucodelap
    Member
    Posted 3 years ago #

    …oops! all permission (777) are set on my server…

  9. Soleil Golden
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Maurizio,

    Please check the other thread here: http://wordpress.org/support/topic/plugin-anyfeed-slideshow-trying-to-use-slide-show-plugin-with-picasa-feed?replies=3

    I believe these problems are related. Thank you for your detailed report, I will be releasing a new version today that addresses this issue. :)

  10. blucodelap
    Member
    Posted 3 years ago #

    …thanks Soleil.
    I wait for you new version.

  11. Soleil Golden
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Maurizio,

    The new version has been released- let me know if it gives you any trouble.

    Thanks!

  12. blucodelap
    Member
    Posted 3 years ago #

    sorry Soleil,
    but i report this trouble:

    Warning: tempnam() [function.tempnam]: open_basedir restriction in effect. File(/var/tmp) is not within the allowed path(s): (/usr/local/psa/home/vhosts/blucode.com/httpdocs:/usr/local/psa/home/vhosts/blucode.com/httpdocs/tmp) in /usr/local/psa/home/vhosts/blucode.com/httpdocs/wp-content/plugins/anyfeed-slideshow/anyfeed_slideshow.php on line 123
    Failed to open temp file.

    can I do something?
    thanks
    Maurizio

  13. Soleil Golden
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Maurizio,

    Sorry for the trouble you're having! When you look at the widget's advanced options, are you able to check the checkbox at the bottom? What does the text next to it say?

    Thanks!

  14. blucodelap
    Member
    Posted 3 years ago #

    …Warning: is_writable() [function.is-writable]: open_basedir restriction in effect. File(/var/tmp) is not within the allowed path(s): (/usr/local/psa/home/vhosts/blucode.com/httpdocs:/usr/local/psa/home/vhosts/blucode.com/httpdocs/tmp) in /usr/local/psa/home/vhosts/blucode.com/httpdocs/wp-content/plugins/anyfeed-slideshow/anyfeed_slideshow.php on line 274
    disabled="disabled" /> Cache XML for 24 hours? This feature is not compatible with your Host's configuration.

  15. Soleil Golden
    Member
    Plugin Author

    Posted 3 years ago #

    Hi bluecodelap,

    I'm about to push out another update, but wanted to check in first. After visiting that settings page, are you still receiving errors? That issue should be caused by having the caching system enabled- I had it automatically disable caching if it couldn't write to that directory (I just forgot to make sure it didn't report errors to the screen).

    Thanks for your patience!

  16. blucodelap
    Member
    Posted 3 years ago #

    yes Soleil
    the error is still the same…
    maurizio

  17. Soleil Golden
    Member
    Plugin Author

    Posted 3 years ago #

    Maurizio,

    Was the checkbox at the bottom of the configuration page checked?

  18. blucodelap
    Member
    Posted 3 years ago #

    yes Soleil
    it is!

  19. Soleil Golden
    Member
    Plugin Author

    Posted 3 years ago #

    Therein lies the problem! Un-check that box and save, it should work! :)

  20. blucodelap
    Member
    Posted 3 years ago #

    …mmmm, I dont know why but trouble persists…

    Warning: tempnam() [function.tempnam]: open_basedir restriction in effect. File(/var/tmp) is not within the allowed path(s): (/usr/local/psa/home/vhosts/blucode.com/httpdocs:/usr/local/psa/home/vhosts/blucode.com/httpdocs/tmp) in /usr/local/psa/home/vhosts/blucode.com/httpdocs/wp-content/plugins/anyfeed-slideshow/anyfeed_slideshow.php on line 123
    Failed to open temp file.

    sorry, but I'm sure you will find solution!

  21. Soleil Golden
    Member
    Plugin Author

    Posted 3 years ago #

    Could you try deleting the plugin from within WordPress, and re-installing it? There is a function that runs when you remove it that should remove all of the settings from the database. That should correct the problem.

    Sorry for all the trouble!

  22. blucodelap
    Member
    Posted 3 years ago #

    …so I reinstalled plugin and close to the button (unchecked) in the bottom of the page I read:
    "Cache XML for 24 hours? This feature is not compatible with your Host's configuration."

    on my page in the site:
    "Warning: tempnam() [function.tempnam]: open_basedir restriction in effect. File(/var/tmp) is not within the allowed path(s): (/usr/local/psa/home/vhosts/blucode.com/httpdocs:/usr/local/psa/home/vhosts/blucode.com/httpdocs/tmp) in /usr/local/psa/home/vhosts/blucode.com/httpdocs/wp-content/plugins/anyfeed-slideshow/anyfeed_slideshow.php on line 128
    Failed to open temp file."

    maurizio

  23. Soleil Golden
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Maurizio,

    Thank you so much for your detailed replies; they really help.

    I missed something when making the changes for version 1.0.2, which may have caused this problem to continue. I just pushed a new code update, 1.0.4 which should resolve it.

    Please try it out, and let me know your results. Thanks for your patience and help!

  24. blucodelap
    Member
    Posted 3 years ago #

    Good Morning Soleil !

    and thanks for your efforts to resolve my problem and make a great contribution to the community…
    now, with your last version I no longer have those troubles but now on the site is flashing the word "loading" without it happens more…

    thanks
    maurizio

  25. Soleil Golden
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Maurizio,

    From what I'm seeing, this seems to happen only with large images in the slide show, and only on Webkit browers (Safari + Chrome). Does this scenario seem to match up with your experience?

    I'm working on another fix for this one as we speak.

  26. Soleil Golden
    Member
    Plugin Author

    Posted 3 years ago #

    I take that back! The issue was with feeds in which the image was within a <content:encoded> tag. I'll have a new version out shortly which should fix the last bug related to this issue.

    Thank you for your diligence in helping me troubleshoot this issue, Maurizio, I really appreciate it!

  27. Soleil Golden
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Maurizio,

    I just added version 1.0.5 to the system, which should fix your last bug. :)

    Thanks again for all your help!

  28. blucodelap
    Member
    Posted 3 years ago #

    Hi Soleil

    I deleted plugin and I installed new 1.0.5, set permission and I see only flashing "loading"…some idea?

    maurizio

  29. Soleil Golden
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Maurizio,

    I just noticed the cause of your problem. I'm so sorry I didn't catch it before!

    use http:// instead of feed://, and it should work (I just tested it myself on my dev install).

    Sorry for running you through hoops!

  30. blucodelap
    Member
    Posted 3 years ago #

    …I changed Feed URL from "feed://vimeo.com/blucodelap/subscriptions/videos/rss" in "http://vimeo.com/blucodelap/subscriptions/videos/rss" but nothing…

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic