WordPress.org

Ready to get started?Download WordPress

Forums

Annual Archive
[resolved] Change title language (12 posts)

  1. entodoays
    Member
    Posted 1 year ago #

    I like this extension but I have a site in French and would like that the page title shown is not "Yearly archives: 2011" but "Archives annuelles: 2011"
    How could I modify the titles?

    http://wordpress.org/extend/plugins/anual-archive/

  2. Baden
    Member
    Plugin Author

    Posted 1 year ago #

    Hello.
    Can you share a link to the page in question?
    Is French the default language of your WordPress installation in the wp-config.php file? I think 'Yearly Archives: 2011' is being generated by WP's language files.

    In the meantime, we will add the text domain and the ability to translate all elements of the plugin into any language you wish. More info to follow.

  3. entodoays
    Member
    Posted 1 year ago #

    In wp-config.php ther's a line : define('WPLANG', 'fr_FR');

    I cannot post a link to the page because it is still in development and I do not wish to publish any link for the time being.

    Thanks for your reply.

  4. Baden
    Member
    Plugin Author

    Posted 1 year ago #

    Are you using the sidebar or the shortcode?
    If Shortcode, please paste the exact shortcode, so we may test that it is translating properly.

    For now, please do this:

    1. update to version 1.2 (fresh out of the plugin oven)
    2. go to our community translation tool and translate the plugin into French
    3. when you are finished, export the .po and .mo files
    4. rename the files to anarch-fr_FR.po and anarch-fr_FR.mo
    5. upload these files to the plugin's languages sub-folder

    We will include all new translations in future releases.

    Good luck!

  5. entodoays
    Member
    Posted 1 year ago #

    In the community translation tool I couldn't find out how to start a new translation. There's only the German translation and didn't find any "Add new" link. Please give details.

  6. Baden
    Member
    Plugin Author

    Posted 1 year ago #

  7. entodoays
    Member
    Posted 1 year ago #

    I did what was recommended but there are some missing items to translate.

    I did a widget with an annual archive and when I click on one of the years I still get "Yearly archives: 2011"

    What's wrong?

  8. Baden
    Member
    Plugin Author

    Posted 1 year ago #

    Regarding the French translation of the plugin: Great Job! We have included the french translation in version 1.2.1 of the plugin available here: http://plugins.twinpictures.de/plugins/annual-archive/

    Wait, so where exactly is "Yearly archives: 2011" being displayed? Not in the widget, but on the archive page that 2011 links to? The archive page from your theme?! If so, then it's your theme that needs to be translated! Which theme are you using on your site? If your page will be offered only in french, this will be an easy fix...

  9. entodoays
    Member
    Posted 1 year ago #

    I used a sidebar widget setting it as annual. On the page I get a list of years, as expected. When I click on on of the years, I get a page with the archived items for that year but on top of that I get "Yearly archives: 2011".
    I'm using the twentyten template with some modifications.
    The site is all french.

  10. Baden
    Member
    Plugin Author

    Posted 1 year ago #

    We just did a test on our test server: http://spacedonkey.de/date/2012/
    If you set your browser to French, the site will display correctly in French.
    This is what we did to make it work:

    1. Download WordPress in French.
    2. Copy up the twentyten language files: fr_FR.po and fr_FR.mo located in the French WordPress folder under: wp-content > themes > twentyten > languages to your server using FTP

    That's it. As In your wp-config.php you have: define('WPLANG', 'fr_FR'); and you have fr_FR.po and fr_FR.mo files loaded for both WordPress and Twenty Ten, everything should be working!

  11. entodoays
    Member
    Posted 1 year ago #

    Perfect. I was missing the french translation files for the template. The original installation was in English and only later installed the French version, but I hadn't copied the template translation files.
    Thanks a million.

  12. Baden
    Member
    Plugin Author

    Posted 1 year ago #

    Alright! Glad we could help.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic