WordPress.org

Ready to get started?Download WordPress

Forums

Analytics360
Not showing in editor role? (17 posts)

  1. wp-boy
    Member
    Posted 3 years ago #

    Hi, I've got an Mu install and running this plugin, but
    when I go into a sub blog of the MU install using a
    non-super admin role, the Analytics360 fails to
    appear in the "dashboard" submenu.

    I bought the MenuEditorPro plugin to see if it
    would help out by changing the role levels this
    plugin is allow to be visible to.

    I drop the level down to role_0 and read and
    still won't show?

    Please help?!
    https://img.skitch.com/20110215-dm6yfgu3gqch9dcub2iabsj9uf.jpg

    Sincerely,
    JZ

  2. furioso
    Member
    Posted 3 years ago #

    Hi JZ,

    I'm having the same problem here. The Analytics360 submenu only shows up when I'm logged in as an admin. Did you find a solution to also give access to editors yet?

    Regards,
    Ben

  3. wp-boy
    Member
    Posted 3 years ago #

    Sorry no...

    I'm thinking of installing wordpress
    stats plugin so my users can see
    something.

    -JZ

  4. furioso
    Member
    Posted 3 years ago #

    A pity. I wrote an email to MailChimp yesterday but I'm not sure if they care about non-paying customers :)
    (I'll post the answer if I get one)

    Thanks for replying anyway. Guess another option would be to register a new Gmail account and let my editors access the statistics through google.com/analytics

    -Ben

  5. furioso
    Member
    Posted 3 years ago #

    "In regards to your query, there is currently not a way to allow users with editors rights access to the statistics without providing them your login credentials. Let us know if you have any further questions. This is a great idea. Your best bet would be to add this to our official wish list. Here's the URL: http://jungle.mailchimp.com/forum/categories/wish-lists/listForCategory

    Our developers and designers frequently check that forum when planning application upgrades."

  6. wp-boy
    Member
    Posted 3 years ago #

    Thanks for stepping on on this...

    -JZ

  7. mintydog
    Member
    Posted 3 years ago #

    I resolved this by changing all of the instances of "manage_options" to "moderate_comments" in analytics360.php and my Editor can now see the menu option and the data. Since that plugin is read-only it doesn't hurt anything that I've seen thus far.

  8. furioso
    Member
    Posted 3 years ago #

    Yippie, it works here too! :)
    Thanks a lot!

  9. wp-boy
    Member
    Posted 3 years ago #

    Thanks for the help!
    The power WP community solves another caper!

  10. wp-boy
    Member
    Posted 3 years ago #

    Hey guys I just made the changes to
    the permissions like described above,
    and it worked but...

    I get these weird question marks
    coming up.

    https://img.skitch.com/20110413-j7tqa8255u5k8e1efwrc9b9j58.jpg

    Help?

  11. idesignstudio
    Member
    Posted 3 years ago #

    It can be even more playful with the permissions as analytics360.php has pretty clear code. In the different functions you can unfluence which user level can see the Dashboard widget and/or Settings >> Analytics360 by using these levels:
    Roles and Capabilities.

    Like this, we easily gave Settings >> Analytics360 options rights only to admins and all subscribers can actually see Dashboard >> Analytics360.

    Cheers!

  12. Maggew Dot Com
    Member
    Posted 2 years ago #

    This was a perfect swift-fix...I appreciate the community share, big time!

    Before you replace all five instances with "moderate_comments" be sure to leave line 640 untouched. You will prevent editors from being able to "access settings" page which could be bad. You want to protect your other clients data.

    If only there was a way to display this on the dashboard now..one less click!

    p.s. - Mhmm...chinese chicken w/cashews is amazing.

  13. erikshosting
    Member
    Posted 2 years ago #

    Hey, I tried to follow the instructions here to do this, but I noticed that the function that builds the menus is now tieing the settings and read only page together into the same code. So, what I did, was change all instances of 'manage_options' to 'moderate_comments', but then I copied the function for the menu, and put it and the original behind an IF/ELSE statement and removed the creation of the settings page in the appropriate place, and voila. settings page for admin, analytics page for admin and editors!
    I wrote a tutorial, and copied my code onto my wordpress tutorial site

  14. brasofilo
    Member
    Posted 2 years ago #

    @erikshosting

    the code in your page is not easily readable... i did this pastebin, and modified a little bit the conditionals

    also, it's necessary to modify function a360_request_handler() - line #210, and change "manage_options" to "publish_posts" (the pastebin has full instructions)

    cheers

  15. Maggew Dot Com
    Member
    Posted 2 years ago #

    Thanks brasofilo for the tweak - I appreciate the love brotha man.

  16. brasofilo
    Member
    Posted 2 years ago #

    maggew, chinese chicken with cashews is so dam good that i learned to do it myself :o)

    salut, bro

  17. keirj
    Member
    Posted 2 years ago #

    @erikshosting

    Nice work yo. Saved me some bacon, my bacon that is... Mmmmm bacon....

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic