WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Amazon Reloaded for WordPress] Unusable (36 posts)

  1. doctoraa
    Member
    Posted 4 years ago #

    No matter what key words I enter, this plugin will not find anything on Amazon.

  2. nickohrn
    Member
    Posted 4 years ago #

    Could you be more descriptive of what does happen?

  3. davidolrik
    Member
    Posted 4 years ago #

    I have the same problem.

    I enter a search term e.g. 'snowcrash', the search indicator lights up for a couple of seconds, and then nothing happens.

    I'm using WordPress version 2.8.1-beta2

  4. morbidromantic
    Member
    Posted 4 years ago #

    Now it seems this is my problem. I was able to use it up until today. Now when I search, it doesn't turn up any results. It's a shame, too, because I used this plugin daily and there are no plugins I can find like it.

  5. onkelandy
    Member
    Posted 4 years ago #

    Same problem here.. Did amazon change anything?

  6. nickohrn
    Member
    Posted 4 years ago #

    Yes, Amazon changed something. Not sure when I'll have time to make the fix.

  7. digigirl
    Member
    Posted 4 years ago #

    Add me to this list - this is happening to me as well. Using 2.8.4

  8. Diplominformatiker
    Member
    Posted 4 years ago #

    Nick, please go ahead and fix the problem, I miss the plugin a lot.

  9. uergsel
    Member
    Posted 4 years ago #

    Full ACK, your plugin makes books and music blogging much more easier. Thank you for your great plugin and hopefülly there will be an update soon.

  10. gudlyf
    Member
    Posted 4 years ago #

    I've made a temporary fix for anyone impatient like me:

    http://www.cliqueclack.com/code/2009/08/20/a-fix-for-amazon-reloaded-for-wordpress-and-amazons-new-api/

    Requires you get your own Amazon AWS keys.

  11. WebG2
    Member
    Posted 4 years ago #

    Thank you, gudlyf, for making that edit. The plugin works again.

    Now, if only someone would know how to...

    (a) update either the insertImageLink or insertAmazonLink functions so that the extra piece of HTML that Amazon suggests we use will appear after the tag that's being inserted.

    <img style="border:none !important; margin:0px !important;" src="http://www.assoc-amazon.com/e/ir?t=YOURCODEHERE&l=as2&o=1&a=PRODUCTASINHERE" border="0" alt="" width="1" height="1" />

    (b) Add the product name to the ALT tag for the image.

    Then things would be swell.

  12. nickohrn
    Member
    Posted 4 years ago #

    Hey everyone, I've updated the plugin. You should have it working again out of the box :)

  13. paul_williams@btinternet.com
    Member
    Posted 4 years ago #

    Great that you are working on this plug-in, it's been the best for the job.
    However version 5, asks for my Amazon details again - that's fine - but then provides seperate image and product links. Should it do that?

    The image doesnt link to Amazon and the 'link' goes to amazon.com despite the setting for UK.

    Anyone else getting this?

  14. onkelandy
    Member
    Posted 4 years ago #

    I love the new version but well.. the locale stuff doesn't work. It always searches on amazon.com - but just change the ".com" in line 465 an it works fine!

  15. paul_williams@btinternet.com
    Member
    Posted 4 years ago #

    I tried editing the plug-in as above (replacing com with co.uk) but not finding a line 465, edited the line (233 in my file):

    $url = 'http://ecs.amazonaws.com/onca/xml?';

    Thanks for this onkelandy.

    I'm still disappointed that the is no longer an amazon link.

    Any work around for that?

  16. onkelandy
    Member
    Posted 4 years ago #

    I just figured some weird problem: the created links aren't working because the tag is "ws" and not my Associate ID. I've checked my credentials and everything turned out to be fine there..

  17. nickohrn
    Member
    Posted 4 years ago #

    Fixed the bug with locale recognition and associates tags. Any others, feel free to post.

  18. onkelandy
    Member
    Posted 4 years ago #

    Worx perfectly! Thanks alot.

  19. paul_williams@btinternet.com
    Member
    Posted 4 years ago #

    Nice work!

    Thanks

  20. mikejs78
    Member
    Posted 4 years ago #

    Do these fixes automatically work with links that were created in old posts before the update?

  21. nickohrn
    Member
    Posted 4 years ago #

    Any links created with the plugin are direct HTML that should work forever.

  22. GinnyRED57
    Member
    Posted 4 years ago #

    Works great with WP 2.8.5, but some of the "send link to editor" buttons are floating in an unexpected way above some of the text. I have a screenshot at this post if that's any help. I'm using Firefox and WP 2.8.5.

    Otherwise, stellar plugin! I've been looking for an Amazon plugin for a while, since the one I was using was left in the dust by a long-ago upgrade.

    Any chance you could add an Author link, perhaps as a checkbox option?

  23. nickohrn
    Member
    Posted 4 years ago #

    I think you meant to post this link: http://www.blogula-rasa.com/2009/10/30/books-the-man-with-the-golden-torc/. Anyways, I'll take a look at it and see what's going on.

  24. nickohrn
    Member
    Posted 4 years ago #

    Actually, could you please tell me what search terms you used so I can reproduce the problem? I'm sure it is something small, but I don't want to waste a ton of time trying to get it to show up.

  25. gudlyf
    Member
    Posted 4 years ago #

    Hi Nick. I'm trying your latest version on a new server now and, though I'm certain I'm using the correct API and Secret keys, the 'Test' button reports they are generating an error or are incorrect.

    Any clue how I can figure out what's being reported back as that error? Thanks!

  26. dhinz
    Member
    Posted 4 years ago #

    Using WP2.8.6
    I have same KEY problem. numerous cut an d pastes etc. all to no avail. I even generated a new Key pair @ amazon, no joy.

    Message is: "Your credentials seem to be incorrect. Please check them and try again."

  27. mimieux
    Member
    Posted 4 years ago #

    "Your credentials seem to be incorrect. Please check them and try again."

    regardless of what secret key and api code combop i ahve used. i copied and pasted/ i typed it in, etc. no joy.
    any ideas?

  28. dhinz
    Member
    Posted 4 years ago #

    I figured out my mistake. I had reversed the keys putting the Secret Key in for the API Key and vice versa. OOPS!

    Recommendations for Nick:
    1. Change the window sizes for the keys to make them reflective of the expected length of the keys. That way looking at the filled in keys they'll look goofy if not in correct boxes.

    2. Change the order of the boxes, put the API key first since that is the one that amazon displays w/o clicking.

  29. dhinz
    Member
    Posted 4 years ago #

    Suggestion: allow entering of the ASIN code if known.
    The plug-in delivers only a comparative few choices when amazon may offer thousands, trying to determine the keywords to enter into the plugin to get the exact product to show is frustrating. Otherwise great plug-in.

  30. nickohrn
    Member
    Posted 4 years ago #

    @dhinz - Thanks for the recommendations. I'll take them into account.

Topic Closed

This topic has been closed to new replies.

About this Topic