WordPress.org

Ready to get started?Download WordPress

Forums

Amazon Link
[resolved] Update Broke my WordPress -> 500er Error (6 posts)

  1. myrko
    Member
    Posted 1 year ago #

    I just updated the Amazon-Link plugin to 3.0.3. and after the update my wordpress installation was broken and showed a 500er Server Error. I had to extract the amazon-link version before from my backup to make it running again.

    Maybe it's a conflict with another plugin, I don't know and I can't say which I suspect. Just t let you know!

    http://wordpress.org/extend/plugins/amazon-link/

  2. paulstuttard
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Thanks for the info,

    Was this error on every page, or just the admin pages?

    If anyone else is seeing a problem please let me know - I'll roll back the plugin to version 3.0.2.

    Thanks,

    Paul

  3. myrko
    Member
    Posted 1 year ago #

    Paul, it was on all pages.

  4. paulstuttard
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    I have found one bug in the upgradeSettings section of the plugin - where it tries to re-install the Amazon Link Cache.

    Do you have the plugin cache enabled?

    I have fixed this in 3.0.4 - but I'd be surprised if this gave you a 500 error. Usually something to do with file permissions and the like.

    If you have the time would be handy to get your server log for the 500 error - might indicate which file is the culprit.

    Paul

  5. myrko
    Member
    Posted 1 year ago #

    Paul, I don't have the server logs unfortunately. But I can report that after installing the latest version 3.0.4 the issue is gone for me!

    Thank you for your efforts!

  6. paulstuttard
    Member
    Plugin Author

    Posted 1 year ago #

    Excellent, thanks for the feedback!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic