WordPress.org

Ready to get started?Download WordPress

Forums

ALO EasyMail Newsletter
[resolved] Subscribe Widget "Sending"... (7 posts)

  1. Stergos
    Member
    Posted 2 years ago #

    Hello, I use your plugin the last months and I am very excited.
    Today I decide to add the subscribe widget for first time but I am getting "sending..." and nothing more.

    My site use the default English language, I test an email which is not used by any registered user, after got the latest update I deactivate and reactivate the plugin as you suggest, is this a bug or something?

    Thanks in advance!

    http://wordpress.org/extend/plugins/alo-easymail/

    [No bumping, thank you.]

  2. eventualo
    Member
    Plugin Author

    Posted 2 years ago #

    I hope this faq can help you: http://www.eventualo.net/blog/wp-alo-easymail-newsletter-faq/#faq-12
    Then, maybe there is some conflict with other plugins: try to disable them all and see if EasMail still does not work.

  3. Stergos
    Member
    Posted 2 years ago #

    Thanks for response! The issue was caused by "W3 Total Cache" plugin after I disable 2 features the widget seems to working great!

    I have made some changes to css to feet the plugin better to my site but it's only working on Chrome. Firefox and I.E. is not look at the "min-width" and the result is pretty bad. Here is the code I am using:

    .alo_easymail_widget_form .input-text {
    padding: 0px;
    min-width: 50px;
    max-width: 182px;
    }
    .alo_easymail_widget_form {
    color: #white;
    }

    Any suggestions would be helpful, thank you!

  4. eventualo
    Member
    Plugin Author

    Posted 2 years ago #

    Can you tell us which "W3 Total Cache" settings you disabled? It could be useful for someone else.
    About css width, my not-very-original idea is that you use a fixed width property, suitable for all browsers.

  5. Stergos
    Member
    Posted 2 years ago #

    I am still testing "W3 Total Cache" plugin, I was using (Page Cache "Disk: Basic" ,Browser Cache ,Database Cache and Object Cache. When I disable Database Cache and Object Cache EasyMail widget worked! These two features was not caused only problems to EasyMail but to registered users too, contributors could not access to their profile the page was redirect back.

    I am using a child theme of twenty eleven, in full screen the theme is 1100px but the normal width is 1000px that's why I need a max $ min width. After a quick search I find it out that latest Firefox and I.E. is not follow the tag min-width so the only solution is to use
    <div style="padding: 0px; min-width: 50px; max-width: 182px; ">

    But I am not sure where the object ".alo_easymail_widget_form .input-text" is...

    Update: Not work either!
    On alo-easymail-widget.php
    Find:
    <td><input type='text' name='alo_em_opt_name' value='".
    replace:
    <td><input type='text' style='padding: 0px; min-width: 50px; max-width: 182px;' name='alo_em_opt_name' value='".

    I make the changes under "name" and "e-mail" but is the same result with CSS.

  6. eventualo
    Member
    Plugin Author

    Posted 2 years ago #

    But is the plugin css file properly loaded?
    If not, be sure to have flag the option in Newsletters → Settings → tab General and double check if css files exists in theme folder or plugin folder.
    Otherwise, it could be an issue with child theme. The fix (I hope) is here: http://wordpress.org/support/topic/plugin-alo-easymail-newsletter-override-css-using-child-theme?replies=4
    I'll include it in next release.

  7. Stergos
    Member
    Posted 2 years ago #

    Yes I have checked this option. Also I have seen this post yesterday and I made that change of code. Same results, as far I check is not plugin issue but properties and browsers support.

    Anyway I decide to make my side little bit larger for other purposes so the widget is feet right now.

    Thank you very much for this great plugin!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.