WordPress.org

Ready to get started?Download WordPress

Forums

ALO EasyMail Newsletter
Cannot send newsletter and ajax stopped responding (19 posts)

  1. arvish
    Member
    Posted 2 years ago #

    After upgrading to wordpress 3.4, Alo newsletter plugin stopped sending newsletter. Additionally Ajax stopped responding. Tested on new WP 3.3.2 install on same server and works perfectly fine.

    http://wordpress.org/extend/plugins/alo-easymail/

  2. eventualo
    Member
    Plugin Author

    Posted 2 years ago #

    I've noticed the same issue on some 3.4: after the upgrade from 3.3.2 there are some problems with list generation, send test email... Maybe it could be some changes in WP 3.4... I'll investigate about it, any help is appreciated.

  3. arvish
    Member
    Posted 2 years ago #

    Could it have to do with an upggrade in the JQuery UI library to 1.8.20

    I also downgraded Alo Newsletter and tested the plugin with version 2.4.8 and 2.4.7 on the upgraded WP 3.4 install to no avail.

    Does it work with a fresh WP 3.4 install? I haven't checked that.

  4. eventualo
    Member
    Plugin Author

    Posted 2 years ago #

    About failed sendings, there is a known issue in phpmailer bundled with WP 3.4: http://core.trac.wordpress.org/ticket/20970
    Here the patch: http://core.trac.wordpress.org/attachment/ticket/20970/20970.patch

  5. arvish
    Member
    Posted 2 years ago #

    Unfortunately that doesn't work. I firmly believe there is a javascript conflict. Modal window won't appear. Javascript won't respond.

  6. eventualo
    Member
    Plugin Author

    Posted 2 years ago #

    Ok, thanks for the report, I'll investigate about javascript.

  7. eventualo
    Member
    Plugin Author

    Posted 2 years ago #

    Can you report us the javascript errors, if any, that you can see in javascript browser console?

  8. arvish
    Member
    Posted 2 years ago #

    Hello. Thank you for your support. Her is the error that generated when I click on "Create list of recipients"

    tb_show is not defined
    /wp-content/plugins/alo-easymail/inc/alo-easymail-backend.js?ver=3.4
    Line 283

    tb_show ( easymailJs.subscribersPopupTitle, url +"&newsletter=" + newsletter + "&lang=" + lang + "&action=open_popup&TB_iframe=true&height=400&width=700&modal=true", false );

  9. eventualo
    Member
    Plugin Author

    Posted 2 years ago #

    You can go in newsletter settings in tab Newsletter and try the other options in "Method of creation of the recipient list": in particular, try the 2nd that can load only plugin js. Maybe it can help you.

  10. arvish
    Member
    Posted 2 years ago #

    I have tried all these options. None of them work.

  11. Naz
    Member
    Posted 2 years ago #

    I'm having the same problem with the AJAX not working. When I checked my analytics I noticed people did sign up for my newsletter, but they didn't show up as subscribers. So I checked the form and noticed it gets stuck on the 'sending' part when signing up for the newsletter.

  12. arvish
    Member
    Posted 2 years ago #

    Naz, have you tried sending a test newsletter out? I believe there is an issue with the javascript for the whole plugin. Ajax requests are not being sent whether for creating a subscriber or creating a mailing list.

  13. eventualo
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Naz, maybe your problem in subscription form is different from ajax issue in admin panel. You can read this: http://www.eventualo.net/blog/wp-alo-easymail-newsletter-faq/#faq-12
    In admin panel do you have ajax problems (e.g. send test email or generation of recipient list)?

  14. Naz
    Member
    Posted 2 years ago #

    Thanks for the link. I sent a test e-mail and that seems to work. However, when I click 'Edit' to edit a mailing list about 25% of the time it doesn't work so I have to retry and retry (and reload the page) until it works.

    I tried all of the .js options and it didn't fix anything. I do have wp_head() in my theme file, I'm using an English version of WordPress and I'm not using multisite.

    I hope that helps. :)

  15. saijin_nxtoyou
    Member
    Posted 2 years ago #

    I'm also having this issue, ALO EasyMail Newsletter Widgets says:
    +++++++++++++++++++
    Error during sending: please try again.
    +++++++++++++++++++
    My last subscription was dated 3 days ago (June 24, 2012) I didn't update the plugin so I don't know what happen.

    Note that I'm using ALO EasyMail Newsletter Version 2.4.3 and here is our website in case you want to test it: http://www.hearttoheartthoughts.com/ (The part that says Newsletter Sign Up is the problem)

    Please help me, thanks in advance.

  16. arvish
    Member
    Posted 2 years ago #

    Clearing the browser cache and WordPress cache after upgrading the WordPress and the plugin solved the issue for me.

  17. 850sport
    Member
    Posted 1 year ago #

    I'm having the same error tb_show is not defined.
    I updated the plugin to latest version and wordpress to 3.4.2.
    I've checked all options to generate the list of recipient, and doesn't work.

    Any clues?

    Many thanks!

  18. eventualo
    Member
    Plugin Author

    Posted 1 year ago #

    Sometimes there could be a conflict with another plugin. You should disable all plugins and see if it works. Otherwise you can disable one plugin per time and try to generate the list.
    I hope it helps.

  19. GuyOlinga
    Member
    Posted 1 year ago #

    Hi,

    I'm using WP 3.5 and the last version of the plugin. 3 weeks ago I have succeeded to send my newsletters. But since yesterday, it is hanging up with the below message :

    On sending queue...
    En cours: 0%

    Please assist.
    Thanks

    Guy
    http://www.pyramidedusalut.net

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.