WordPress.org

Ready to get started?Download WordPress

Forums

ALO EasyMail Newsletter
[resolved] Batch sending question (6 posts)

  1. Stergos
    Member
    Posted 2 years ago #

    Hi, I am completely confused using Batch sending please I really need your opinion! My subscribers right now is 284. My shared server is allow my to send 250 emails per hour, so I have set "Maximum number of emails that can be sent in a 24-hr period:" to "4000" and "Maximum number of emails that can be sent per batch (every 5 minutes):" to "30" but all my newsletters was send in 20 minutes, that means that plugin was send 71 emails every 5 minutes and 34 newsletters was not send. What i am missing here?

    Thanks in advance!

    http://wordpress.org/extend/plugins/alo-easymail/

  2. eventualo
    Member
    Plugin Author

    Posted 2 years ago #

    It's very strange... I suggest that you set up debug newsletter to send all messages to newsletter author (in plugin settings), then disable all plugins except Easymail and then try to send a newsletter.
    It could be useful to understand if the issue is caused by an Easymail bug or by some conflicts with other plugins.
    Which WP and Easymail versions?

  3. Stergos
    Member
    Posted 2 years ago #

    I'm using WordPress 3.4 and the latest version of Easymail 2.4.9. I will try that and I let you know thank you very much for response!

  4. Stergos
    Member
    Posted 2 years ago #

    Okay I use it in debug mode and to send all messages to newsletter author. I change the settings "Maximum number of emails that can be sent in a 24-hr period:" to "5000" and "Maximum number of emails that can be sent per batch (every 5 minutes):" to "18". I notice that every 2 minutes I was receiving 18 newsletters. So in a few words the problem is that the plugin is sending every 2 minutes unless 5. The truth is that I do not disable my other activated plugins because is more than 30 and is very important!

  5. eventualo
    Member
    Plugin Author

    Posted 2 years ago #

    Ok, you can double check the value of the constant ALO_EM_INTERVAL_MIN (default is 5, minutes). If you change it you have to reactivate the plugin. More info: http://www.eventualo.net/blog/easymail-newsletter-for-developers/#wp-config
    Then, you can use a plugin like Cron View to see Easymail scheduled jobs. After installing, in admin panel go to Tools > What's in Cron?: you should find a row saying "EasyMail every X minutes... alo_em_batch" ( where X = ALO_EM_INTERVAL_MIN).

  6. Stergos
    Member
    Posted 2 years ago #

    Hi, I think I make it work. I put this code into wp-config file:
    define( "ALO_EM_INTERVAL_MIN", 10 );
    define( "ALO_EM_BATCHRATE", 18 );

    The interval minute is not sending every 10 minutes but every 5 minutes but this is not a problem, I decrease the BATCHRATE to 18 so everything seems to work fine now. Sending 18 newsletters every 5 minutes is about 216 newsletters per hour which is great.

    eventualo, Thank you very much you help was critical highly appreciated!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.