WordPress.org

Ready to get started?Download WordPress

Forums

All In One WP Security & Firewall
Client can login but not edit (3 posts)

  1. tg1
    Member
    Posted 3 months ago #

    Hey,

    For whatever reason - I lost this thread the first time I tried to write it.

    Have been migrating clients from Better WP Security to All-In-One Security and Firewall. Most have gone well.

    One has not. And I don;t know where the problem stems from.

    The can login.

    However they cannot edit pages and posts.

    When they try to "save' or "publish" - they get a "Well this is embarrassing" page message that I believe is default to twenty eleven theme not being able to save their work. It's like WP does not know what or where to go.

    I'm confused. Does this ring any bells - or does anyone have any thoughts as to how to proceed?

    Thanks!

    https://wordpress.org/plugins/all-in-one-wp-security-and-firewall/

  2. wpsolutions
    Member
    Plugin Author

    Posted 3 months ago #

    What is the full error message displayed when you try to save the page?

    Some theme's display the "Well this is embarrassing" message in their 404 pages.

    Can the user save other settings within the WP dashboard?

  3. tg1
    Member
    Posted 3 months ago #

    They wrote back this morning and said now they can't move from the login page. Which means they have lost their ability to even reach posts or pages.

    A little background:

    1 - Their site lives in a subdirectory of root. So root/public_html/their directory/wordpress

    2 - I deleted copies of htaccess on both their directory and wordpress directory.

    3 - I then went to settings/permalinks and set to default. I then saved that.

    4 - I went back in and set permalinks to the post setting. And saved.

    In the past this has been successful in recreating a new htaccess file.

    5 - So now - with the new htaccess in wordpress - I then copied that htaccess to their directory.

    The crazy thing is that everything works fine on my computer in 3 different browsers. Logging in and out, editing pages and posts... I have no problems.

    So I'm sort of at a standstill as to what to do.

    This current configuration works for other clients. I have a stack of security I use on these sites:

    1 - Wordfence
    2 - Sucuri
    3 - All-In-One

    The old configuration used to be:

    1 - Wordfence
    2 - Sucuri
    3 - Better WP Sucurity

    The old configuration worked fine for them until Better WP broke after changing ownership.

    I hope this helps. If you need more detailed info - let me know. Thanks!

Reply

You must log in to post.

About this Plugin

About this Topic