WordPress.org

Ready to get started?Download WordPress

Forums

All in One SEO Pack
Titles not rewriting (10 posts)

  1. astreetweb
    Member
    Posted 2 years ago #

    Admin area seems to be working of but titles are not rewriting. Meta-description is ok

    http://wordpress.org/extend/plugins/all-in-one-seo-pack/

  2. Glisse
    Member
    Posted 2 years ago #

    actually in my case the title are rewritten, but for some reason it adds the blog_title in front of post_title..

    so, my blog name is "blabla", my post title name is "wawa", and the output for $post_title$ is "blabla | wawa" when it should have been just "wawa".. the other taqs are working fine

  3. astreetweb
    Member
    Posted 2 years ago #

    In my case, it turned out to be a template issue. I had to update my header.php page. Replaced <title>xxx</title> in my theme header.php with code copied from twenty-eleven. In my case:

    <title><?php wp_title('&laquo;', true, 'right'); ?> <?php bloginfo('name'); ?></title>

    with

    <title><?php
    	/*
    	 * Print the <title> tag based on what is being viewed.
    	 */
    	global $page, $paged;
    
    	wp_title( '|', true, 'right' );
    
    	// Add the blog name.
    	bloginfo( 'name' );
    
    	// Add the blog description for the home/front page.
    	$site_description = get_bloginfo( 'description', 'display' );
    	if ( $site_description && ( is_home() || is_front_page() ) )
    		echo " | $site_description";
    
    	// Add a page number if necessary:
    	if ( $paged >= 2 || $page >= 2 )
    		echo ' | ' . sprintf( __( 'Page %s', 'twentyeleven' ), max( $paged, $page ) );
    
    	?></title>

    HTH

  4. Turismo in
    Member
    Posted 2 years ago #

    Doesn't work your code, i've ever my blank titles.

    http://turismo-in.it/group/seller/titolo-deal-numero-1/

    Anyone can help me? Title blank, blog name works.

  5. astreetweb
    Member
    Posted 2 years ago #

    It looks like your title text is there. Is that not the right text?

  6. Turismo in
    Member
    Posted 2 years ago #

    I've deleted this plugin. My titles was:

    | Blog name

    Title post doesn't show.

  7. Michael Torbert
    WordPress Virtuoso
    Plugin Author

    Posted 2 years ago #

    Hi Turismo in,

    Please reinstall All in One SEO Pack and I'll look to see what the problem is.

  8. fabspider
    Member
    Posted 1 year ago #

    You need to make sure wp_head tag is the last element in the header because the wp_head tag pulls in the info from the plugin. If the title tag occurs after wp_head it will overwrite all the good work done by all in one seo.

  9. bouncewow
    Member
    Posted 1 year ago #

    Im Having a similar problem. All in one used to work fine for all my posts but now it only shows post name| Blog title. Please help me!!!!
    My correctly indexed pages are changing too. Any help would be great. Heres my website bouncewowny.com

  10. biscuits
    Member
    Posted 1 year ago #

    I am having the same issue with the title not rewriting. I've posted in a few areas but not gotten any input. It's just the Titles. I'm using Shantia Theme.

    I'd appreciate any help you can give!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.