WordPress.org

Ready to get started?Download WordPress

Forums

All in One SEO Pack
[resolved] Title tag wont change (19 posts)

  1. razzera
    Member
    Posted 1 year ago #

    Hello

    Im using All in One SEO Pack 1.6.14.6 for my wordpress and i have a little problem. In the plugin i have se the "Post Title Format:" to be "%post_title% Review | %blog_title%" as i run a review site. Sometime when i write other stuff then reviews i go into the post to set a special "title" with All in One SEO but the title i set will not show and i wonder why?

    if i in a post write the post title as "bla bla" it becomes "bla bla review | page.com" if just post it as that, if i at the bottom of the post use All in One SEO Pack to se a speciall title like "merry christmas everyone | %blog_title%" that will not show once the post is made and i wonder if anyone know what could cause this problem, is it a fault in the plugin? :/

    http://wordpress.org/extend/plugins/all-in-one-seo-pack/

  2. razzera
    Member
    Posted 1 year ago #

    I just noticed that if the "Post Title Format in the plugin is:" to be "%post_title% Review | %blog_title%" and the title of the post is "bla bla" and at the bottom of the post in "all in one SEO" i write what i want the "title" to be for exaple "bla2 bla2", i then update my post and check the source coe and the title is now "bla2 bla2 Review | %blog_title%".

    Is this a fault in the plugin ? i thougt that if i made a new title at the bottom of the post in All in One SEO it would replace the main one with what i wrote there ?

  3. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    razzera,

    This is the expected behavior of the plugin; the %post_title% gets filled in with what you put in as the title on the post. If you want your posts to only display the post title then your "Post Title Format:" should be "%post_title%".

  4. matt.elmore
    Member
    Posted 1 year ago #

    Hello Peter,

    No matter what I write in the Post/Page "SEO Title", it doesn't override what my theme's header.php wants to write there. Do you have any experience with incompatible theme php? Any tips on what to look at?

    Thanks,
    Matt

  5. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    matt.elmore,

    We'll have more options for controlling this in the next release of the plugin.

  6. pete119
    Member
    Posted 1 year ago #

    Hi Peter,

    I have the same issue as matt.elmore.

    No matter what I do with a post or page the Title I place in All in One SEO wont show, my theme always over rides this.

    Any idea when the next release is due please?

    Many thanks, Pete

  7. pete119
    Member
    Posted 1 year ago #

    Hi Peter,

    I have the same issue as matt.elmore.

    No matter what I do with a post or page the Title I place in All in One SEO wont show, my theme always over rides this.

    Any idea when the next release is due please?

    Many thanks, Pete

  8. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    While we don't have a firm date yet, we are currently in the process of beta testing our next major release.

  9. pete119
    Member
    Posted 1 year ago #

    Hi Peter,

    Thank you for getting back to me.

    Great, sooner the better as tested another 'well known' WP SEO plugin and just not getting on with it.

    Yours much better just this issue that I cant use it interdependently on Posts and Pages until this issue resolved.

    Many thanks again, Pete

  10. Ilan Shalev
    Member
    Posted 1 year ago #

    Hi Peter,

    I have the same issue as the others

    No matter what I do with a post or page the Title I place in All in One SEO wont show, my theme always over rides this.

    The new release 2.0 didn't fix the problem, in fact the problem ocured after upgrade to the new release.

    Thanks, Ilan

  11. pete119
    Member
    Posted 1 year ago #

    Hi ilan,

    We tried the Pro version and also the latest free release of 'All in One' and this is still an issue rendering this plugin rather useless.

    We have now cancelled our subscription to AIO and now use Yoast on all our sites.

    This free plugin does not have this issue it has to be said :)

  12. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    matt, ilan;

    The options for controlling this in 2.0 are Use Original Title in the General Settings (defaults to Disabled), and Force Rewrites under Performance (defaults to Enabled). If you're having an issue with your theme or another plugin conflicting with how All in One SEO Pack sets the title, try changing those options.

  13. Ilan Shalev
    Member
    Posted 1 year ago #

    Peter,

    The options you mentioned were there before, i didn't changed them, they supposed to work, i deleted all my other plugins and still the same problem.

    I guess your team didn't check all the option.

  14. wpsmort
    Member
    Posted 1 year ago #

    Hi ilan256,

    Can you provide a URL so we can take a look at your site. We are aware of some themes that have taken code directly from All in One SEO Pack and used it in their theme making it virtually impossible to override. I'd like to check your site and see what theme you are using as the new settings should work.

  15. Ilan Shalev
    Member
    Posted 1 year ago #

    Hey that's the site:
    http://www.xn--9dbaak2de7a.net/

    I bought the theme from Elegant at the last year.

    Thanks

  16. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    ilan256,

    Make sure you have Force Rewrites on under Performance; it looks like it is already, and there's another plugin on your site that's using output buffering, you may have to disable that plugin. Alternatively, you can turn Force Rewrites off under Performance, and change the title tag in your header.php to read as follows:

    <title><?php wp_title(); ?></title>

  17. Ilan Shalev
    Member
    Posted 1 year ago #

    Thanks Peter,

    The Alternative worked just fine.

  18. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    ilan256,

    Great, glad to hear it.

  19. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    Roger,

    See my previous reply, I'd suggest either disabling Use Original Title and enabling Force Rewrites, OR disabling Force Rewrites and changing your <title> tag in your header.php to read like so:

    <title><?php wp_title(); ?></title>

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.