WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: All in One SEO Pack] All in One SEO Toolbar is dead in WordPress 2.7 Edit Post Page (13 posts)

  1. Robert
    Member
    Posted 5 years ago #

    Running WP 2.7 and did the automatic upgrade to All-In-One SEO ver 1.4.6.16 today. The upgrade installed without errors.

    When I edit a post, the All-In-One SEO title bar appears at the bottom of the web page with nothing below it. No fields are displayed to edit for the post title, summary or tags.

    Any ideas? The previous version of SEO was running fine under WP 2.7.

    Thanks

  2. honestaeb
    Member
    Posted 5 years ago #

    I am having the same issue on several (although not all of my WP sites). I have not yet been able to find a solution from anyone...

  3. honestaeb
    Member
    Posted 5 years ago #

    A tiny hint: It seems that my older sites (Ones that have had several WP and plugin upgrades) are the ones that have errors, while newer sites that have been through few upgrades seem to work fine.

  4. testcricket
    Member
    Posted 5 years ago #

    erm.... this might sound stupid but have you actually clicked on the heading/box for "all in One SEO Pack" than appears at the bottom of your edit posts page?

    I know at first I thought it wasn't clickable because it's black instead of blue like the others. But when I clicked on it the section expanded with configurable options there.

    Just thought it was worth throwing this in just in case someone else got tricked by the colour discrepancy.

  5. Robert
    Member
    Posted 5 years ago #

    > I know at first I thought it wasn't clickable because
    > it's black instead of blue like the others. But when I
    > clicked on it the section expanded with configurable
    > options there.

    This occurred to me as well. Clicking does nothing. It's just static text in both IE7 and FireFox 3.0.5. If the section is clickable, the cursor changes to a four-arrow icon - here it doesn't not.

    I downgraded to All In One SEO ver 1.4.6.15 with no effect as this version was working before the upgrade to 1.4.6.16. I've not installed any other plugins, so I don't think it's a plugin interaction issue.

  6. testcricket
    Member
    Posted 5 years ago #

    FWIW

    I reckon you should get a fresh copy of the plugin and then manually reinstall the updated version again - I recall that working for me once with a plugin.

    All in One SEO plugins are working fine in my sites - all running 2.7

  7. Robert
    Member
    Posted 5 years ago #

    I tried that - deleted the plug-in and all files. Unzipped SEO and FTP'd the entire 'all-in-one-seo-pack' folder to .../wp-content/plugins -- the resulting path is /wp-content/plugins/all-in-one-seo-pack.

    I tried disabling all plugins except SEO. Still no joy.

    Thinking it might be a web client problem, I tested it on a WinXP and Vista system, doesn't work on either.

  8. Robert
    Member
    Posted 5 years ago #

    More info - I'm running PHP v5 and there's nothing in the PHP error logs on BlueHost.com.

  9. Robert
    Member
    Posted 5 years ago #

    I used Firebug (http://getfirebug.com/) in FireFox 3.0 to "Inspect" the unresponsive All In One SEO postbox control on the WordPress Edit Post page. This helped me locate the postbox code in the SEO php code.

    The workaround is to:
    1. Deactivate the All In One SEO Pack plugin.
    2. Edit the SEO plugin code from the WordPress plugin
    management page.
    3. Remove the 'closed' option on the postbox class.

    Change the original code from class="postbox closed":

    <?php if (substr($this->wp_version, 0, 3) >= '2.5') { ?>
    <div id="postaiosp" class="postbox closed">

    to just class="postbox" as shown below:

    <?php if (substr($this->wp_version, 0, 3) >= '2.5') { ?>
    <div id="postaiosp" class="postbox">

    This defaults the SEO postbox display in expanded mode showing the various input controls. I think the default display mode should be expanded instead of hidden anyway.

    4. Reactivate the SEO plugin.

    I verified the fix works by inputting the SEO options for a new post and viewing the HTML source from the web browser, which contains the following HTML entries:

    <!-- all in one seo pack 1.4.6.15 [211,308] -->
    <meta name="description" content="Water dripping from the ceiling was traced to leak from the upstairs shower/bathtub. Steps for finding and fixing the leak are explained with photos." />
    <meta name="keywords" content="access panel, bathtub drain, ceiling leak, drop ear elbow, drywall, finding a shower leak, how to, inspection and repair, leaky bathtub, maintenance panel, pipe joint compound, plumbing, rotozip, shower head, shower valve, teflon tape, water stain, wet wall,bathtub drain,ceiling,drop ear elbow,drywall,finding a shower leak,how to,inspection and repair,leaky bathtub,maintenance panel,pipe joint compound,plumbing,rotozip,shower head,shower valve,teflon tape,water stain,wet wall" />
    <!-- /all in one seo pack -->

    Why the above HTML comment says version 1.4.6.15 I'm not sure as All In One SEO Pack shows ver 1.4.6.16 on the WordPress "Manage Plugins" page.

    I verified the SEO form data I entered is retained for the newly updated post and as well as my older posts.

  10. sakyant
    Member
    Posted 5 years ago #

    MIne occurred when i installed the slideshow module to the built in gallery function.. maybe this sheds some light oin it.. im not too good at php writing but i might open the files and read them to see if i can find any command that causes the deactivation of the all in one seo...

    mods and plugins are great but one thing i can advize is that if you install a load of plugins.. NBEVER update your wordpress version again as oyu run some serious risk of causing a mountain of unfindable issues... i have updated two websites and lost 2 years of forum posts etc because it destroyed the database.

  11. sakyant
    Member
    Posted 5 years ago #

    even the custom fields dnt work either.. they appear doubled when i enter themn and save the page they disappear again

  12. sakyant
    Member
    Posted 5 years ago #

    did what kinderr@windstream.net said and the all in one seo has now completely diappeared from view, and will not be reactivated.. i click reactivate and it doesnt work

  13. sakyant
    Member
    Posted 5 years ago #

    Ok it worked! the problem in previous post was cause because the chmod permissions were changed when i deactivated it.. so i ch modded them back to 777 using my ftp program and all is well! thank you for your solution.. wasnt happy without the seo plugin as i have done some research with my seo tools and texhniques and the thing really does well with google and co - its a great plugin. Three cheers for kinderr

Topic Closed

This topic has been closed to new replies.

About this Topic