WordPress.org

Ready to get started?Download WordPress

Forums

All in One SEO Pack
About a warning (9 posts)

  1. soleil_levant
    Member
    Posted 3 years ago #

    Hi,

    With the last releases (WP 3.0.1 and AIOSEO 1.6.12.2), I get a
    warning when the debug mode is on.

    Notice: Undefined index: aiosp_enabled in /var/www/vhosts/xxx/wp-content/plugins/all-in-one-seo-pack/all_in_one_seo_pack.php on line 766

    The code is :

    if( ($_POST['aiosp_enabled'] == null && $aioseop_options['aiosp_enabled']!='1') || $_POST['aiosp_enabled']=='0'){
    	add_action( 'admin_notices', 'aioseop_activation_notice');
    	}

    and I suppose the problem is coming from $_POST.

    Do you have any idea ?

    http://wordpress.org/extend/plugins/all-in-one-seo-pack/

  2. armid12
    Member
    Posted 3 years ago #

    I have a similar problem.
    At just installed wordpress, I installed this plugin (1,6,13).
    Turn on the debug and got the same error. How do I fix this?

    Does it make sense at all in this plugin?

  3. Sjroep
    Member
    Posted 3 years ago #

    I just updated my All in one SEO package to 1.6.13 and I'm running wordpress 3.0.1. Now I'm not able to access the plugin.php via the dashboard. Anyone?

  4. Tavy315
    Member
    Posted 3 years ago #

    @soleil_levant, @armid12 change line 766 to:

    if( (!isset($_POST['aiosp_enabled']) && isset($aioseop_options['aiosp_enabled']) && $aioseop_options['aiosp_enabled']!='1') || (isset($_POST['aiosp_enabled']) && $_POST['aiosp_enabled']=='0')){

  5. bobbingwide
    Member
    Posted 2 years ago #

    Just to let you know that this problem still exists in 1.6.13.3
    Before finding this topic I'd read
    http://wordpress.org/support/topic/plugin-all-in-one-seo-pack-the-plugin-doesnt-work-for-me-on-wp-30?replies=14

    There was a "solution" by @domst3r which disabled half of the logic.
    I reworked this and got similar code to Tavy315

    if ( (isset($_POST['aiosp_enabled']) && $_POST['aiosp_enabled']=='0' ) ||
     (isset($aioseop_options['aiosp_enabled']) &&  $aioseop_options['aiosp_enabled']!='1') ){

    I didn't bother to check whether or not the index is ever actually set in $_POST

    WIBNI this code was corrected in the official version of the plugin

  6. Tavy315
    Member
    Posted 2 years ago #

    Looks like the bug still exists in 1.6.13.4 :)

    if( ( (!isset($_POST['aiosp_enabled']) || $_POST['aiosp_enabled'] == null) && $aioseop_options['aiosp_enabled']!='1') || (isset($_POST['aiosp_enabled']) && $_POST['aiosp_enabled']=='0')){

  7. xzoom
    Member
    Posted 2 years ago #

    I have the same problem.

    Notice: Undefined index: aiosp_enabled in /httpdocs/wp-content/plugins/all-in-one-seo-pack/all_in_one_seo_pack.php on line 766

    Notice: Undefined index: aiosp_enabled in /httpdocs/wp-content/plugins/all-in-one-seo-pack/all_in_one_seo_pack.php on line 766

  8. jayeshguru
    Member
    Posted 2 years ago #

    I have the same problem.

  9. ThePres
    Member
    Posted 2 years ago #

    What a ridicolus error not checking the existence of the index first. How is this not yet fixed?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic