WordPress.org

Ready to get started?Download WordPress

Forums

All-in-One Event Calendar
[resolved] WP Dashboard is very slow in IE9 and Chrome (not FF!) (21 posts)

  1. SPQC
    Member
    Posted 2 years ago #

    Pretty strange, I usually use Firefox for my browsing needs but I'm now building a new website with a fresh WP install and I recently added the All-in-One Event Calendar plugin.

    Haven't noticed anything wrong until I try to log in as admin using IE9. That was very slow! i tried Chrome, same thing but a bit faster. No problem with Firefox.

    It not until I disabled All-in-One Event Calendar that speed was back to normal. Enabled it again and it was slow again.

    Are you aware of this?

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

  2. cryogenfx
    Member
    Posted 2 years ago #

    weird, i just experienced the same thing, on safari/mac.
    the site is hosted locally on my mac whilst developing, and it has been working fine for a week. suddenly when i woke up this morning, admin pages took 30 secs to load until i disabled the cal plugin.
    upon reenabling it, it slows to a crawl again.
    so for now it's disabled, but i really need this plugin.

    any pointers on what to look for? latest version of both wp and ai1ec

  3. msabirm
    Member
    Posted 2 years ago #

    Hello,
    I too had the same problem, in the backend of my site, I noticed it was very slow. but until yesterday did not give me no problem.
    I tried with firefox and chrome, but nothing, the problem persists.

  4. ferasb
    Member
    Posted 2 years ago #

    I just spent over an hour deactivating and re-activating plugins to figure out why my admin section was taking nearly 30 seconds or so to load the page and after I deactivated this plugin, it started to work well.

    The problem persists in all the browsers -- including Firefox. I used the Firebug extension in FF and I believe it's not working because the simplecdn.maxcdn.com website is down and the page continues to load until it's loaded but is eventually aborted.

    I hope this is fixed very soon because the plugin is used heavily on my website.

    Thanks

  5. SPQC
    Member
    Posted 2 years ago #

    Ok it's also slow in Firefox after a CTRL-F5. :-(

    What's simplecdn.maxcdn.com? Is it really needed? Could go edit the sources to remove it until there's a fix.

  6. robereke
    Member
    Posted 2 years ago #

    Had the same problem. My (temporary) solution: in wp-content/plugins/all-in-one-event-calendar/app/controller/class-ai1ec-events-controller.php on line 120 remove or comment

    wp_enqueue_script( 'jquery.tools-form', 'http://cdn.jquerytools.org/1.2.5/form/jquery.tools.min.js', array( 'jquery' ), '1.2.5' );

    Hope this helps for you too!
    Robert Busschots

  7. cryogenfx
    Member
    Posted 2 years ago #

    Thanks robert, that helped for me. Don't know what it removed of functionality, but at least i have my calendar back.
    Too bad one site down can hold back so many horses in 2012.

    edit: I know what went missing. all the little nice popup helpers on date and such. also, more importantly, it1s now impossible to set recurring events, as there's no picker.
    bummer

  8. Bobans
    Member
    Posted 2 years ago #

    Had similar problem with my theme, took similar action to fix the calendar
    and now it works

    My (temporary) solution:
    create folder /js/ in the wp-content/plugins/all-in-one-event-calendar/add/

    download the jquery-tools-1.2.5.min.js file from here

    place the file in the newly created /js/ folder

    in wp-content/plugins/all-in-one-event-calendar/app/controller/class-ai1ec-events-controller.php on line 121

    wp_enqueue_script( 'jquery.tools-form', 'http://cdn.jquerytools.org/1.2.5/form/jquery.tools.min.js', array( 'jquery' ), '1.2.5' );

    change to these
    wp_enqueue_script( 'jquery.tools-form', '/js/jquery-tools-1.2.5.min.js', array( 'jquery' ), '1.2.5' );

  9. SPQC
    Member
    Posted 2 years ago #

    I think the site is back, no more slowdown and haven't modified a thing...

    But having the file local is a good idead and could prevent future downtime of cdn.jquerytools.org

  10. nelra
    Member
    Posted 2 years ago #

    Hi all,

    JqueryTools uses a CDN to allow for hosting of their JS library, but its had some issues recently. Similar to the tip here, please see:
    http://wordpress.org/support/topic/plugin-all-in-one-event-calendar-change-jquerytools-to-not-serve-from-cdn?replies=2#post-2652516

    We will be changing in a release tomorrow to not use the CDN anymore

  11. SPQC
    Member
    Posted 2 years ago #

    Delayed?

  12. umutsun
    Member
    Posted 1 year ago #

    Hi,
    Im using this plugin on my multiple works and very happy. But now I have to share my problem with you : )

    Latest WP + Then.ly Latest All in One Calendar
    Tested as All plugin disabled, other wordpress themes, no permalink
    now rewrite is false
    php memory 64m
    no jquery conflict

    i ve been reading all support items one by one for troubleshooting for one week.

    http://www.workshopperz.com/?post_type=ai1ec_event&p=82&instance_id=
    Everything works fine on chrome but Firefox and Safari gives No results found.
    any hint or clue would be perfect.
    Thanks to everybody from now.

  13. umutsun
    Member
    Posted 1 year ago #

    i ntoiced something it s not about browser type.
    logged ┼čn user can see the event detail, visitors are not allowed to do that.
    probably i should edit class-ai1ec-calendar-helper.php
    around line 980
    or is event detail page user control somewhere else?
    thanks again.

  14. sauril
    Member
    Posted 1 year ago #

    Are you sure you don't have any permalinks? That url does not look right.

  15. umutsun
    Member
    Posted 1 year ago #

    Hi sauril,
    i guess i have this issue:
    http://wordpress.org/support/topic/plugin-all-in-one-event-calendar-event-details-not-showing

    - when user logged in event detail looks fine
    - when post date is not a future (post status = published) again event detail page works fine

    but visitors (not logged in) can not view post (if it s a future post)
    do you have any idea where can i change that query?
    problem almost solved any help would be great : )

  16. Richard
    Member
    Posted 1 year ago #

    Hi umutsun,

    Sorry for not replying sooner. Can you tell me if this is also occurring in ai1ec premium version 1.8.3?

  17. firatozturk
    Member
    Posted 1 year ago #

    Hi, I have the smae problem. I works gut but too slow. And because of this Plugin, ather pages are working also slow. Dear umutsun the page that you made is working very well, did you find a solution for the speed?

    thanks

  18. Richard
    Member
    Posted 1 year ago #

    Hi firatozturk,

    Can you please confirm that you are using the latest version of the plugin? We have had a few issues with sites running slowly due to a large number of events.

    Thanks

  19. firatozturk
    Member
    Posted 1 year ago #

    Hi Richard, thanks for your Answer. I am using ver. 1.8.2, this must be the latest version. I had 8 Events with daily or weekly repeats and endless. Then i give them an End-Date(about 100 repeats). Now it is little bit better, but still slow.

    Thanks

  20. Richard
    Member
    Posted 1 year ago #

    Hi firatoxturk,

    Please try updating to the 1.8.3 premium version of the plugin. Available now from http://time.ly (for free)

    Thanks

  21. firatozturk
    Member
    Posted 1 year ago #

    I tested AIO-Calendar(Premium) with a brandnew wordpress installation.

    WordPress 3.4.2 German
    Theme: Twenty Ten
    Hoster: 1&1
    9 Events with 100 or 300 times daily repeats
    AIO-Calendar, Version 1.8.3-premium

    Page load time results:

      Posterboard 1,55s
      Month 6,54s
      Week 1,33s
      Day 745ms
      Agenda 843ms

    Only the Month-View takes too much time. 5-6 times more than the others. I think this is not a bug or some thing like this. For the Moth-view Server has to work more than others.

    Thats way i want to change my "default_calendar_view" to Agenda or Week. With the Premium version of AIO-Calendar it is possible to change it from Settings but i use the normal version. I try to modify the 'default_calendar_view' => 'month' (line330) in "class-ai1ec-settings.php" but it doesn`t work.

    How can i change the "Default Calendar view" to Week or Agenda with Normal version of AIO-Calendar(not Premium)?

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic