WordPress.org

Ready to get started?Download WordPress

Forums

All-in-One Event Calendar
[resolved] Wont stop loading (27 posts)

  1. Rb1368
    Member
    Posted 2 years ago #

    I installed the plug in but when I go to the page where the calendar is I just see it keep loading and loading....I see the calendar but the loading graphic just keeps spinning. Any advice would be reall helpful.

    Not sure if it matters but I am using a preview dns for my site as it is in development mode so my URL is a little different but I dont think that should matter in this case. Please HELP!

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

  2. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    I believe it is caused by preview dns configuration.
    The other reason could be that there is a js error or some misconfiguration.

  3. gard.eric
    Member
    Posted 2 years ago #

    I am having the same issue that Rb1368 is having and I'm not a preview dns. I have tried deactivating my other plugins to see if that fixes it but with no luck.

    Any suggestions?

    Many thanks,
    --Eric

  4. wolfgang88
    Member
    Posted 2 years ago #

    I experience the same problem.
    As long as I am logged into my WP site, the calendar works fine. But as soon as I log out, the events disappear from the sidebar widget and the calender is stuck in an endless loading state.
    Non-members therefore can not see any events, which is a severe issue, since those events are there to inform unregistered users of potential events of our community. Once a user logs in, all events reappear.
    I have a fresh install of WP 3.3.1 and the calendar plugin.

    Any help is warmly welcomed!

    Wolfgang

  5. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    @gard.eric
    Can you post a link to your website, I might be able to see the problem?

    @wolfgang88
    Do you have any other plugins installed? Are you using the default theme that comes with WP 3.3.1?

  6. Rb1368
    Member
    Posted 2 years ago #

    The calendar uses a script in wordpress for the ajax functionality.

    http://yourdomain.com/wp-admin/admin-ajax.php

    This plug in stops and just tries to load forever if it cant access that file.

    When I was in preview DNS mode the path was incorrect to this script. SO when I launched my site with out the preview DNS it worked perfectly.

    If the calendar cant find the admin-ajax.php file, its not going to work.

    Firebug was a huge help for me with this issue.

  7. wolfgang88
    Member
    Posted 2 years ago #

    I have figured out what went wrong.
    I am using HTTPS during administration and member login (HTTPS Plugin for WordPress). It was during the switching period between SSL and non-SSL where I had the problem. Once I have closed the browser (clearing its caches) and reconnected as normal visitor the events did show up.
    I did not investiagte the problem any deeper, but it seems that when in HTTPS mode the script gets blocked by the HTTPS Plugin, resulting in a hang, quite similar to the effect Rb1368 experienced.

  8. fdnymedic08
    Member
    Posted 2 years ago #

    Same thing happened with me. The problem was caused by the All-in-one Seo plugin. Try deactivating your plugins then go one by one to see which one is cause the problem...

  9. eric.fought
    Member
    Posted 2 years ago #

    I'm having this issue as well. I've deactivated all of the plugins, that didn't help. There is no https issue, and I'm not advanced enough to explore the other options listed above. I really just need to get this to work so that we start loading events.

    My website: http://www.ourvoicescountmn.org.

  10. lzevon
    Member
    Posted 2 years ago #

    Same issue - I switched the site address URL upon launch and this started to happen. Not exactly sure where to go to resolve this issue (I've looked at each file in the plug-in editor).

    Could this thread please be re-opened, or 'unresolved'? I'd like to know where I need to go to enter the new site address url to get it working again.

    Thank you.

  11. lzevon
    Member
    Posted 2 years ago #

    Resolved: I launched the site and with different WordPress Address (URL) and Site Address (URL) and got the endless spinning circle (Ajax). I set both the URLs to the same value and it's OK now.

    Interestingly, if I loaded the calendar using the WordPress Address (URL) - even if it's different than the Site Address (URL) it works. You would think the opposite would be true since some people can't or don't want to use the same URL for both.

  12. danromanchik
    Member
    Posted 2 years ago #

    Amazing. I had exactly the same problem with this plugin.

    After reading this item, I checked to make sure that the WordPress Address and Site Address matched, and found that one was "www.domain.com" and the other just domain.com. I changed them both to http://www.domain.com, and this plugin is working great now.

    Thanks, guys.

  13. hypnobliss
    Member
    Posted 2 years ago #

    Hi,
    I am having the same problem. I have checked my wordpress and Website URL in my Settings--> General and they are both exactly the same.

    WordPress Address (URL): http://ciad.org.uk
    Site Address (URL): http://ciad.org.uk

    I even cut and pasted to ensure there were no extra spaces etc.
    Am I doing something wrong?

    Many thanks in advance.

  14. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    @hypnobliss
    Are you still having the issue? I checked your website and it is loading fine on my end. Make sure to clean your cache before testing.

  15. hypnobliss
    Member
    Posted 2 years ago #

    @ynai.iliev
    Yes I think you were right. I am using Chrome but once I had cleared my cache it seemed to work fine.

    Cheers for helping sort it out!

  16. overmetal61
    Member
    Posted 2 years ago #

    I am having this exact same issue.
    I just upgraded to 1.3, and calendar widget load fine.
    My Calendar page loads events, but I get a spinning wheel that just sits on top forever. Any Advice?

    http://www.ctkyam.org/wp/index.php/calendar/

  17. blu3s0da
    Member
    Posted 2 years ago #

    hi everyone,

    im having the same issue
    i've done every solution that was written here, but none of them work.
    i've cleared both my firefox and chrome browsers cache,
    both wordpress url and site url are exactly the same, and
    from the time i used this plugin and from the time this issue started, i've used the same plugins, no additions/upgrades/updates.
    and i even updated this plugin from 1.3 to 1.4 to see if that solves the problem, but it didnt.
    any thoughts?

    thanks in advance!

  18. josjo
    Member
    Posted 2 years ago #

    @blu3s0da

    Is your site public? If you can provide a link I can have a look.

  19. blu3s0da
    Member
    Posted 2 years ago #

    my site is actually under construction, can I pm you with the link?

  20. josjo
    Member
    Posted 2 years ago #

  21. josjo
    Member
    Posted 2 years ago #

    There is a JavaScript error in Tinyfader that's part of the Toolbox theme. It seems it has trouble fading in the sponsor logos.

  22. blu3s0da
    Member
    Posted 2 years ago #

    thank you josjo! im checking that out now.

  23. blu3s0da
    Member
    Posted 2 years ago #

    T_T i changed the slideshow, im now using Showtime Slideshow plugin to show the sponsor logos, and transferred the Tinyfader <script> to if(is_home).. and still the calendar keeps loading.

  24. blu3s0da
    Member
    Posted 2 years ago #

    I found the problem!

    <!-- for custom excerpt length -->
    <?php
    function new_excerpt_length($length) {
    return 50;
    }
    add_filter('excerpt_length', 'new_excerpt_length');
    ?>

    i put this into the functions.php

    this block of code caused a lot of problems, not just the calendar plugin.

    as soon as i deleted this from the functions.php file, everything went back to normal.
    thanks josjo for trying to help! :)

  25. NadineBode
    Member
    Posted 2 years ago #

    I have the same issue of endless loops here as soon as i logg out: http://www.blog.terraveggia.de/kalender-vegane-events-und-termine

    The details won't load. I already filled in a lot of details befroe i noctides the problem, any help :)?

  26. OC2PS
    Member
    Posted 1 year ago #

  27. rculok
    Member
    Posted 1 year ago #

    NadineBode you wrote

    I have the same issue of endless loops here as soon as i logg out: http://www.blog.terraveggia.de/kalender-vegane-events-und-termine
    
    The details won't load. I already filled in a lot of details befroe i noctides the problem, any help :)?

    Now you work with the calendar as I watched. How can I solve this problem I have version 3.4.2 wp 1.7.1 I have a calendar and I still have the loading overbids nothing like what you finally solved the problem?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic