WordPress.org

Ready to get started?Download WordPress

Forums

All-in-One Event Calendar
How do I import from google ics? (11 posts)

  1. smithgt
    Member
    Posted 2 years ago #

    I'm not sure if I'm doing this correctly, but I pull in another persons Google calendar into my own Google Calendar using an link to the ICS files.

    Is this the same process to have these external events appear in my AIO Event Calendar?

    If I add the ICS path then the eggtimer wheel just keeps rotating forever.

    http://sandbox.smith-it.co.uk/wp-content/uploads/2011/11/add-ics.png

    Have I done somethings wrong?

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

  2. nelra
    Member
    Posted 2 years ago #

    The ICS import can take quite awhile depending on the # of events being imported, however there is an issue where an invalid ICS will cause a warning to be generated which is not properly displayed, and instead the icon continues to spin.

    If you are familiar with Firebug or another HTTP Request analyzing tool, you can review the Response from the call to admin-ajax.php when you try and Update from your ICS feed. It may be though that the ICS URL itself is invalid (or without public permissions to it), which causes the problem

  3. smithgt
    Member
    Posted 2 years ago #

    Hi Nelra,

    I'm not familar with Firebug, but I'm happy to give it a go. I've installed the Firefox Firebug Plugin, visted my sites dashboard, and then added a public ics (as below)

    https://www.google.com/calendar/ical/l86ihefeuto0tfk4ap7fbc27k0%40group.calendar.google.com/public/basic.ics

    I've then clicked on the Update button in the Event Calendar settings - but I'm not sure what I'm supposed to see happen or do next?

    Any pointers would be much appreciated.

  4. nelra
    Member
    Posted 2 years ago #

    Hello,

    I have tested your ICS field and it properly imported 167 events. It may be that you are experiencing a timeout as the import processes.

    Using firebug can be a bit complicated, however what you can do is click the bug icon to open the Firebug panel and then click on the "Net" tab and make sure it is enabled.
    Then, click 'Update' next to the ICS field to try and import the records.

    In the firebug Net tab you will see an entry at the bottom for admin-ajax.php. Click on it to view details and choose the "Response" tab, it should look like:
    {"error":false,"message":"Imported 167 events","flush_label":"Flush 167 events","count":167}

    However, if there is an error or other warning, the result may be quite different -- feel free to paste the results in a Pastebin site or similar.

  5. smithgt
    Member
    Posted 2 years ago #

    Thanks for your help so far.... :-)

    I've created a paste bin here:

    http://pastebin.com/jxdMv1ma

    The debug code definately states that it's failing.

    <b>Warning</b>: Cannot modify header information - headers already sent by (output started at /homepages/10/d83518211/htdocs/Client_Area/TBSCC/wp-content/plugins/all-in-one-event-calendar/lib/iCalcreator.class.php:1558) in <b>/homepages/10/d83518211/htdocs/Client_Area/TBSCC/wp-content/plugins/all-in-one-event-calendar/app/helper/class-ai1ec-view-helper.php</b> on line <b>174</b>
    {"error":false,"message":"Imported 0 events","flush_label":"Flush 0 events","count":0}

  6. nelra
    Member
    Posted 2 years ago #

    Thank you for the details

    The key message is this:
    URL file-access is disabled in the server configuration

    You will need to talk to your server hosts, as the ability to import from an external URL is being blocked by your server configuration

  7. smithgt
    Member
    Posted 2 years ago #

    Thank you. I now know that my shared (1and1) server doesn't allow URL file-access.

    To get round this I've created a php.ini with the line :

    allow_url_fopen = ON

    I've dropped this in several locations on the server, as some searching has suggested I need a PHP.ini in each folder that wants to do the FILE URL access.

    Do you know if this is correct, or while file (folder location) actually needs this URL file access permission?

    Many thanks

  8. smithgt
    Member
    Posted 2 years ago #

    Just as an update to this; I think the only place you need the php.ini file is in the /YourSiteName/wp-content/plugins folder.

    I've not managed to plug in the Google ICS for UK Public holidays to my calendar.

    http://www.tbscc.co.uk/?page_id=87

    PS: Just lovin' this plugin :-)

  9. nelra
    Member
    Posted 2 years ago #

    Thanks for the followup - I'm sure the details will be useful to others

    I assume you meant "I've now managed" rather than "I've not managed" ? :-) Just double-checking that there isn't still an issue

  10. smithgt
    Member
    Posted 2 years ago #

    Yes - this is NOW working :-)

  11. grantday
    Member
    Posted 2 years ago #

    Is there another way around this, I'm having the same issue and am worried about this fix's security.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic