WordPress.org

Ready to get started?Download WordPress

Forums

All-in-One Event Calendar
[resolved] Google Map not displaying (28 posts)

  1. alleyoopster
    Member
    Posted 2 years ago #

    Hi,

    I have been trying to get all in one event calendar to display a map within the event, but it just displays a box. The preview of the map works when creating the event as does the full map view.

    I have tried disabling all other plugins and still get this problem.

    Browsers tried - firefox and chromium

    Event Page

    Example of an event

    Thanks for great plugin

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

  2. mobilus
    Member
    Posted 2 years ago #

    To disable the google maps function go to the plugins folder and to the folder for the all-in-one plugin, then apps, then view and edit the event-map.php file.

    You can simply delete the content or comment it out. OR even better add the code you see below that allows you to add your own google map "embed" code (from maps.google.com) as a custom field called google_map. Be sure to enter the Venue name and Address to make the system display the "custom map"

    [Code moderated as per the Forum Rules. The maximum number of lines of code that you can post in these forums is ten lines. Please use the pastebin]

  3. alleyoopster
    Member
    Posted 2 years ago #

    Thanks for the workaround, but I would really like to get this working and show the map. Can you confirm that this is a problem for you also?

  4. sauril
    Member
    Posted 2 years ago #

    Hi,

    This is a strange bug - if you could send your login information to help@theseednetwork.com we can take a look at it for you.

    Cheers,
    Mark

  5. FraserMedhurst
    Member
    Posted 2 years ago #

    Hey guys,

    I'm having the same issue (at least the same symptoms). My problem is definitely due to one of the changes I've made to the theme I'm working on. I set my theme back to twenty ten and it works perfectly. Alley, if you haven't tried that, test it out to see if it's something in your theme (as opposed to an actual error in the plugin).

    Fraser

    Just as a follow-up I've identified the version of nicEdit that I'm running for my forums is conflicting with the plugin.

  6. alleyoopster
    Member
    Posted 2 years ago #

    thanks FraserMedhurst, I tried twentyeleven theme and the plugin behaves as expected. However, this is not an option for the website as it is a customised Atahualpa theme setup. I was wondering if this were a theme issue or a plugin issue?

  7. frank4
    Member
    Posted 2 years ago #

    i have the same problem, google map display on twentyeleven but not on my personal theme... anyone solved this ?

  8. sauril
    Member
    Posted 2 years ago #

    Hi frank4 - what's your url -we have received a few reports of this, but it's not widespread - the more data points we have the better.

    @alleyoopster - it's obviously a conflict with the theme and the plugin. We do our best to have no conflicts, but we can't test everything.

    can you also supply your url?

  9. alleyoopster
    Member
    Posted 2 years ago #

    @sauril URL here

  10. frank4
    Member
    Posted 2 years ago #

    @sauril
    i found the conflict : i had a function called in a personal js :

    jQuery(document).ready(function(){
    [....]
    	function externalLinks() {
    		if (!document.getElementsByTagName) return;
    		var anchors = document.getElementsByTagName("a");
    		for (var i=0; i<anchors.length; i++) {
    			var anchor = anchors[i];
    			if (anchor.getAttribute("href") && anchor.getAttribute("rel") == "external") {
    				anchor.target = "_blank";
    			}
    
    		}
    	}
    	window.onload = externalLinks;
    [....]
    }

    The "window.onload" makes the conflict.
    So i left this function aside, but would appreciate another way to generate a target="_blank"

  11. sauril
    Member
    Posted 2 years ago #

    thanks for the self help and the url - a ticket has been created to investigate this.

  12. surachar
    Member
    Posted 2 years ago #

    Hi; I would appreciate help with this also, please. The URL is soi-seattle.org

    The Google maps feature worked fine on our developer's site, but when we transferred the site files to DreamHost and went live, the events pages show a blank box on the right and a 'view full-size map' prompt.

    Will someone please help with this?

    Thank you!

  13. ozdave
    Member
    Posted 2 years ago #

    Hi there. I am having the same issue. the map wont display in the event.

    Here is the link to the page

    Thanks!

  14. surachar
    Member
    Posted 2 years ago #

    Hi. This issue is now resolved as a result of this clue from the theme author in response to our other problem ("Drop-down menus not showing in IE9".) It wasn’t the plug-ins causing the problem. We accessed the 'console' entry via ftp, about 5 levels deep and deleted it, then the maps worked fine. If you can't locate it, please write back and I will ask my partner to tell the pathway we took. Best Wishes.
    ---------
    'some JavaScript functionality is adding logs to the JavaScript console and I think when the console is disabled, this stops executing some scripts. When you enable the console (F12 enables the developer tools), everything works normally. As I always have the console enabled by default, I didn’t experience any problems.
    So, this is most likely caused by a plugin installed, so you can try with temporarily disabling all the plugins installed. Or if you have added some additional JavaScript code, just make sure to delete the logging lines:

    console.log(...); '

  15. sauril
    Member
    Posted 2 years ago #

    thanks surachar - this should be fixed in 1.8 as we are completely refactoring our javascript

  16. surachar
    Member
    Posted 2 years ago #

    Glad; thanks for writing back. For anyone else, here are the pathway and instructions:

    The file that needs to be edited is the "script.js" file in this directory:
    /wp-content/themes/soi/script/

    "soi" is a variable in the path, so other wordpress installations will have a different value in the path there. Think of it really as /wp-content/themes/FOO/script/. The soi directory is probably a modification of dandelion, as the "dandelion" directory does not reference console.log in it's script.js file. Consequently I'm not sure how useful this fix will be to other users of the dandelion theme.

    if in doubt, you can turn on script debugging in internet explorer, and you'll see an "object is undefined" type of error pointing to console.log on a particular line of the script.js file. You can see the path there while in debug mode.

    the line that needs to be commented out is
    // console.log(jQuery(this));

    Apparently "console" is only a valid object reference while Internet Explorer's developer tools are active. This is why the menus work when you've activated developer tools by pressing F12.

  17. ozdave
    Member
    Posted 2 years ago #

    im not using IE9 this is occurring on a MAC using Chrome and I have seen it working on other website on the same browser.

    Does this fix work for browsers other than Chrome? I cant find the referred to file in my theme

    Do you know when 1.8 will be available?

    Thanks!

  18. sauril
    Member
    Posted 2 years ago #

    1.8 should be out shortly - we want to make sure it's done though, so we don't want to give a date.

  19. jrbroglio
    Member
    Posted 2 years ago #

    mobilus - can you share that code again that allows to "embed" my own google map code into each event? WordPress cut off your post. And I've been searching for it for hours. Thanks!

  20. Richard
    Member
    Posted 1 year ago #

    Hi jrbroglio:

    Not sure if this helps, but one option would be to add your own map by creating a new field. See here: http://help.time.ly/customer/portal/questions/460876-extra-fields

  21. ozdave
    Member
    Posted 1 year ago #

    Hi, I have updated to the altest version but this still doesnt appear to be working for me

    Any ideas on how to resolve this? The page example is http://www.matkapolkaaustralia.com/blog/ai1ec_event/australijski-dzien-ojca/?instance_id=49

    Thanks

  22. nikoski
    Member
    Posted 1 year ago #

    I use the newest ver 1.8.2 with core updates and have the same issue: google maps not showing.

    What's the solution?

  23. Richard
    Member
    Posted 1 year ago #

    Hi nikoski and co,

    The latest update is 1.8.3 Please try updating to this. This is a known bug. Our dev team are currently working to resolve this issue. Thank you for your patience in the interim.

  24. nikoski
    Member
    Posted 1 year ago #

    Thanks, Richard, it seems to work now :-)

  25. mauryg
    Member
    Posted 1 year ago #

    Just found this thread on the problem and realized this is (was) a well known problem, so I moved my post here. Plug-in site says v1.8.3 (Premium) solves the problem, but the latest WordPress version is 1.8.2. Does it have the Google maps fix???
    -------------------------------------------------------
    Using WP 3.2.1 with child theme of Suffusion v4.3.2
    Example event page

  26. Richard
    Member
    Posted 1 year ago #

    Hi mauryg,

    The latest version 1.8.3 has the maps fix. Available for free from here:
    http://time.ly/

  27. mauryg
    Member
    Posted 1 year ago #

    Thanks, Richard
    I had assumed that the 'Premium' version was a paid version. Very happy to hear it is available free. And it solved my problem.

  28. Richard
    Member
    Posted 1 year ago #

    You're welcome mauryg!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic