WordPress.org

Ready to get started?Download WordPress

Forums

All-in-One Event Calendar
[resolved] Google Calendar Feeds Not Showing? (24 posts)

  1. BigBirdy
    Member
    Posted 2 years ago #

    I have tried to add a public Google calendar feed as xml, ics or html, but none will show in the calendar? I can add the feed to other WP calendar widgets and they work. Am I missing something in the configuration? Nothing could be found in the online docs.

    This is the feed I am trying to add.

    https://www.google.com/calendar/ical/uml9c0381vb2hm95btu82pkmk8%40group.calendar.google.com/public/basic.ics

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

  2. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    When you add the feed to your settings page, you have to click on the update button.
    I tried it myself and it imports 10 events.

  3. urban75
    Member
    Posted 2 years ago #

    I'm trying to import a Google calendar but having the same problem. I press 'update' in Settings after adding the iCal address and the circular indicator constantly shows itself as busy. I've tried several times.

    I'm using Firefox. I'll try it in Chrome shortly to see if it's a browser issue.

  4. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    Could it be a firewall issue?

  5. urban75
    Member
    Posted 2 years ago #

    I turned off the firewall and the same problem continued.

    I run five WordPress sites with loads of plug ins and none have encountered this issue before, so it has to be something related to this plug in.

  6. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    We can do the following:
    1. You can give me the ics feed and I can try it on my install.
    2. You can create a new WP install, enable ai1ec plugin and test importing of the feed.

  7. urban75
    Member
    Posted 2 years ago #

    Try this. It's been set to public and only has one event in so far:
    https://www.google.com/calendar/ical/d8v2ngcq4dc64oohsobfmejefo%40group.calendar.google.com/public/basic.ics

    Thanks for your prompt response, by the way: appreciated!

    Mike

  8. BigBirdy
    Member
    Posted 2 years ago #

    Unfortunately still no luck and I have tried all calendar feeds and of course hit "refresh" multiple times. I dont get any errors or any notice at all about successfully finding any events.

    Calendar remains empty

    http://www.squamishspeaks.ca/calendar-new/

  9. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    It must be something in your setup, either a plugin is interfering or something is blocking the request to retrieve the feed.
    I tried urban75 feed and it successfully imports 1 event.

    Can you setup a test user for me so I can locate the problem on your setup. I have to warn you that if it is not a bug in the plugin, you will have to use our premium support. This will allow me to fix the problem.

  10. urban75
    Member
    Posted 2 years ago #

    Yani - can you post up your email address so I can sort you out a log in for the site?

    It does seem very odd - all the other plug-ins work fine across all my other WordPress installations - and this is a brand new installation with only the default plug ins installed.

  11. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    Sure,
    yani at the-seed.ca

  12. urban75
    Member
    Posted 2 years ago #

    Log in details sent. My tech guy says that we've reinstalled WordPress, recreated the config file and restarted Apache but it seems to throw up in the same places every time.

  13. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    I haven't received the login details yet.

  14. urban75
    Member
    Posted 2 years ago #

    Here's some of the errors we're getting:

    [Thu Oct 13 10:27:30 2011] [error] [client 188.222.96.49] PHP Warning: file_get_contents(https://www.google.com/calendar/ica...fo@group.calendar.google.com/public/basic.ics) [function.file-get-contents]: failed to open stream: No such file or directory in /usr/home/www/vhosts/www.brixtonbuzz.com/wp-content/plugins/all-in-one-event-calendar/lib/iCalcreator.class.php on line 1558, referer: http://www.brixtonbuzz.com/wp-admin...event&page=all-in-one-event-calendar-settings

    *password sent again

  15. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    Ah great. I received the login credentials but after seeing this error I no longer need it.
    You can delete the test WP account.

    The error is due to incorrect server configuration.
    Basically, file_get_contents cannot retrieve the ics feed.
    My initial thought is still valid: possible firewall issue.

    You can either ask your tech guy to fix this issue or you can fill a support request here: http://theseednetwork.com/get-supported/software-support/

  16. urban75
    Member
    Posted 2 years ago #

    Here's what our tech guy thinks:

    Okay, I think I've tracked down the problem with the plugin.

    It assumes that PHP has been built with an fopen() wrapper to handle SSL and https, which in our case is not true and so every outbound request using file-get-contents to https destinations will fail. If the plugin were to try using cURL instead, it would work.

    So to make that part work we'll need to recompile PHP for the whole server. This will mean taking all the sites down while the new version is installed.

    My response: - is this something that his plug in should be able to handle?

    Well, it's making assumptions about the environment which aren't going to be true of every installation, but then so would assuming cURL was installed.

    You could let him know that you think you've tracked down the problem:
    That it assumes that PHP has fopen wrappers compiled in for HTTPS, which isn't the case on our install.

    It'll help him a) troubleshoot others who have similar issues, b) specify the requirements for the plugin better and c) improve his error-handling.

    $w = stream_get_wrappers();
    echo 'openssl: ', extension_loaded ('openssl') ? 'yes':'no', "\n";
    echo 'https wrapper: ', in_array('https', $w) ? 'yes':'no', "\n";

    will tell him whether the installation has the required wrappers.

  17. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    It assumes that PHP has been built with an fopen() wrapper to handle SSL and https, which in our case is not true and so every outbound request using file-get-contents to https destinations will fail. If the plugin were to try using cURL instead, it would work.

    By default, fopen() wrapper is built-in in PHP while cURL is not.
    Both, installing cURL and installing openssl, require recompilation of PHP.
    However, adding support for cURL will be a good thing to have.

    Thanks for the great feedback.

    Sources:
    http://www.php.net/manual/wrappers.php
    http://uk.php.net/manual/en/openssl.installation.php
    http://www.php.net/manual/en/curl.installation.php

  18. urban75
    Member
    Posted 2 years ago #

    Is cURL support likely to come any time soon, otherwise I'm sadly going to have to try and find something else, which would be a shame.

  19. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    We are currently working on our Milestone 1.1: http://trac.the-seed.ca/roadmap
    Unfortunately, we are not accepting anymore requests for this milestone so the earliest we can add this will be Milestone 1.2.

    However, you can always use our premium support to get this done asap.

  20. urban75
    Member
    Posted 2 years ago #

    OK, cheers. It's a non-profit community site run on goodwill, so I'm afraid we can't afford premium support!

  21. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    That's okay, You will just need to wait for about 7 weeks or choose a different solution.

  22. BigBirdy
    Member
    Posted 2 years ago #

    Well I did locate an error now. But I cant figure out the issue. I came across some other posts with a similiar issue under PHP5 (which I run), but not sure of the solution. I dont have openssl compiled into my PHP install and cant do it right now. Is there a way to fix this any other way?

    [Fri Oct 14 16:48:02 2011] [error] [client 24.82.0.xxx] PHP Warning: file_get_contents() [function.file-get-contents]: Unable to find the wrapper "https" - did you forget to enable it when you configured PHP? in /home/sqspeaks/public_html/wp-content/plugins/all-in-one-event-calendar/lib/iCalcreator.class.php on line 1558

  23. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    @BigBirdy
    This seems to be the same error that urban75 is experiencing.
    You will need to provide https wrapper for your php install. Asking your hosting company to do it for you is probably the right solution.

  24. BigBirdy
    Member
    Posted 2 years ago #

    Thanks kindly. I did manage to fix the wrapper issue, and get the plugin to parse/pull the calendar data once. But then it seemed to barf and now returns this error so had to disabled the plugin again.

    [Sat Oct 15 08:53:56 2011] [error] [client 24.82.0.208] PHP Fatal error: Ai1ec_Settings::get_instance() [ai1ec-settings.get-instance]: The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition "Ai1ec_Settings" of the object you are trying to operate on was loaded _before_ unserialize() gets called or provide a __autoload() function to load the class definition in /home/sqspeaks/public_html/wp-content/plugins/all-in-one-event-calendar/app/model/class-ai1ec-settings.php on line 220, referer: http://www.squamishspeaks.ca/test/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic