WordPress.org

Ready to get started?Download WordPress

Forums

All-in-One Event Calendar
[resolved] excusion of "ai1ec_event" in the event detail url (13 posts)

  1. vince.fr
    Member
    Posted 2 years ago #

    Hi,

    Is there any chance to change the "ai1ec_event" by any kind of expression in the following url : "http://www.mywebsite.com/ai1ec_event/event1" ?

    Thanks in advance,

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

  2. Yani Iliev
    Member
    Posted 2 years ago #

    Yes, we will probably add it in the settings in one of the next releases but for now the only way to do it is by editing the following file:
    wp-content/plugins/all-in-one-event-calendar/app/helper/class-ai1ec-app-helper.php
    line 178
    Change from: 'rewrite' => true,
    Change to: 'rewrite' => array( 'slug' => 'ai1ec_event' ),

    You can change ai1ec_event to anything you want.

  3. raasdesign
    Member
    Posted 2 years ago #

    Ahh so glad I found the answer to this. Keep up the work guys, this plugin is dank!!!!

  4. zaGerald
    Member
    Posted 2 years ago #

    Hi there, I hope that someone can help me. I have tried the suggestion to change the default directory structure of the "all-in-one-event-calendar" as described above. It works and the directory is changed. However my page now does not exists: http://3d-car-shows.com/car-show-events/tokyo-motor-show/?instance_id=510 any idea why that is?

    Thanks

  5. zaGerald
    Member
    Posted 2 years ago #

    Ok - I have found out what is causing the page not exists error - after changing the settings as above - you need to visit your permalink settings and save it, this will activate the change as above and the page (directory change) will now work!

    Thanks

  6. nelra
    Member
    Posted 2 years ago #

    Thanks for posting the fix to what you were experiencing, it will help others

  7. B_Dark
    Member
    Posted 2 years ago #

    who can i do the same for the botton "back to calendar": mysite.com/calendar?ai1ec_month_offset=1&ai1ec_active_event=58545
    to
    mysite.com/calendar

    and
    "categories" botton : mysite.com/calendar?ai1ec_cat_ids=5088
    to
    mysite.com/calendar?events_cat_ids=5088 ?

  8. Yani Iliev
    Member
    Posted 2 years ago #

    @B_Dark
    You will have to edit app/view/class-ai1ec-agenda-widget.php file
    Lines 163-212

  9. B_Dark
    Member
    Posted 2 years ago #

    thnx a lot yani

  10. Dexname
    Member
    Posted 2 years ago #

    Hi! How to remove "ai1ec_event" from the names of pages and bread crumbs. here aScreenshot

  11. damainman
    Member
    Posted 1 year ago #

    Awesome post!!! Thanks for all the information everyone!!

  12. leftbank
    Member
    Posted 1 year ago #

    Thank you for the information. I also was wondering how to change that section of the URL.

  13. nebota
    Member
    Posted 1 year ago #

    @Dexname

    You can create custom page for ai1ec_event. The method has already been described.
    Here it goes again:
    1. Create single-ai1ec_event.php file
    2. Copy the code from single.php file inside your WP themes folder and place it inside single-ai1ec_event.php, you've just created in the first step.
    3. Put single-ai1ec_event.php inside your themes folder. (not inside ai1ec theme but WP themes).
    4. Inside newly created file you will find a line of code calling for header - get_header();
    5. Create a custom header file which will be called only from single-ai1ec_event.php
    5.1 To create it just copy the one inside your theme's folder and rename it like: header-YOURNAME.php
    5.2 Change the "yourname" part however you want.
    5.3 Call newly created header file from single-ai1ec_event.php file by replacing: get_header();
    with: get_header("YOURNAME");

    That is it!
    Now you can edit just the custom header as you prefer.
    If you have trouble getting around the breadcrumbs, just remove them or make the rule.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic