WordPress.org

Ready to get started?Download WordPress

Forums

All-in-One Event Calendar
[resolved] Event time correct, reload, time= -1hr - WEIRD (6 posts)

  1. bitpod
    Member
    Posted 2 years ago #

    Really odd issue.

    If I add an event to the calender, load calender page (or sidebar) it shows new event and time is correct. Then if you reload the page it is shown minus one hour. The only way to reset this is to de-activate/activate the plugin. Then you still only get to see it right once before an hour is lost again.

    I have this plugin running on another site on the same server so it must be a config thing.

    Any ideas please?

    Alex

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

  2. bitpod
    Member
    Posted 2 years ago #

    UPDATE - just checked in the database and can see that the time is entered incorrectly. It seems to be loosing an hour before it is written to the database. Yet the admin still shows the time as was originally entered.

    Alex

  3. bitpod
    Member
    Posted 2 years ago #

    UN-UPDATE - Just realised it is storing the date in GMT so -1 what is entered. This means that the site is not displaying the dates from the database in BST (+1 hour).

    Still confused...

  4. bitpod
    Member
    Posted 2 years ago #

    Running a simple PHP time script from each site (the one that shows the correct time for events and the one that does not) shows that PHP is displaying GMT (BST-1 hour). I assume from this that PHP time settings are not the problem.

    In WordPress general settings both sites are set to London (displays shows UTC time is 2012-04-23 18:10:21 Local time is 2012-04-23 19:10:21, My clock says 19:10 here!)

  5. bitpod
    Member
    Posted 2 years ago #

    I've enjoyed this little support conversation with myself and can now report I have found the culprit!

    "DB Cache Reloaded Fix" plugin when disabled solves everything...

    Alex

  6. butcher-pl
    Member
    Posted 1 year ago #

    thx for this conversation with yourself - very helpful ! I had the same issue...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic