WordPress.org

Ready to get started?Download WordPress

Forums

All-in-One Event Calendar
[resolved] Display problems with calendar view (12 posts)

  1. inetinitiatives.com
    Member
    Posted 2 years ago #

    Not sure what's wrong but am getting this as the calendar display on my site:

    http://03103e2.netsolhost.com/WP/wptest7/calendar/

    I realize from looking at other samples that the display should be much more robust. Any ideas?

    Thanks!

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

  2. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    You will need to change the ownership/permissions to wp-content/themes-ai1ec/ directory and its children to make it readable by your webserver. Currently, if you look at your console this is what it says: http://d.pr/i/r0yI

  3. nathair
    Member
    Posted 2 years ago #

    I had this problem with several sites with apache servers and with different hosts. This is caused by the installation of the plug-in when it makes directories it sets the apache server as the owner.
    I had to manually change permissions of all the directories of /wp-content/themes-ai1ec/
    AND copy files from one directory with its subdirs by hand as well
    Has that been resolved yet?

    my hair has gone grey with these problems

    Yolanda

  4. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    @Yolanda
    Yes, we are using wp_filesystem now to copy all files.
    Sorry for the grey hair.

  5. nathair
    Member
    Posted 2 years ago #

    good, I'll test it in a new situation then,
    and cook some hazelnuts to rinse the colour back in
    Yolanda

  6. inetinitiatives.com
    Member
    Posted 2 years ago #

    Thanks for your input Yolanda. I'm a little new at this, should I be able to change the directory permissions through my host's control panel? I found some info in the WordPress codex about changing permissions but am not sure how to proceed. Any help is greatly appreciated.

  7. nathair
    Member
    Posted 2 years ago #

    hi
    in your hosts control panel there should be something called file-manager, or something similar. In this file-manager you can locate and see the rights and ownership of all your files and maps / directories
    Find the map "themes-ai1ec" which is in /wp-content -so NOT the one in the plugin folder - and see who is the owner [UID] and if it is Apache then select it and find the "Reset Owner" button to change it. You may have to find subdirectories and change these ownership-rights there as well.

    If you cannot find the filemanager ask the helpdesk of your hosting company.
    good luck
    Yolanda

  8. nathair
    Member
    Posted 2 years ago #

    PS in the filemanager you can also change the permissions of files
    644 should be ok for files, usually no need to change
    And 755 for most directories [or maps]
    Anyway the filemanager can do it.
    Yolanda

  9. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    @ inetinitiatives.com
    We can also help you if you fill a ticket on: help.time.ly

  10. inetinitiatives.com
    Member
    Posted 2 years ago #

    Thanks so much to both of you. So far I've changed the directory permission to 755 as Yolanda suggested; the individual files are all currently set to 640 (not 644)... just to confirm, should all the files be changed to 644 as well? I haven't seen a change in the display with the directory permissions change. If I can't swing it Yani I'll definitely go submit a ticket. Thanks again.

  11. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    I'd recommend 775, the difference between 755 and 775 is:
    755 - allows only the file owner to write to the file
    775 - allows the file owner and the group to write to the file
    If your file owner is apache/nginx - you can set it to 755, if not, I recommend you setting it to 775.

  12. inetinitiatives.com
    Member
    Posted 2 years ago #

    Hmmm... ok. I can't seem to figure out the 'owner' issue; in the column every file and directory in my WP directory has the owner as '2134333.2342362', and there doesn't appear to be any way to alter it. Will try the 775 setting.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic