WordPress.org

Ready to get started?Download WordPress

Forums

All-in-One Event Calendar
[resolved] Can't load Agenda (37 posts)

  1. Guillermo Sabbatella
    Member
    Posted 2 years ago #

    I'm having problems loading the Agenda.
    When I click in the Agenda or Month button, it appears a circle in the middle of the Calendar as if it was loading. But it keeps doing that and nothing happens.
    Any solution?
    Thanks!

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

  2. Paal Joachim Romdahl
    Member
    Posted 2 years ago #

    We are having the same problem:
    http://baldron.org/kalender/

    It goes into a loop and does not come out of it.

    Did you or anyone else with the problem figure out a solution?

    Have a great day!

  3. Guillermo Sabbatella
    Member
    Posted 2 years ago #

    Here is a link to my calendar:
    http://www.chute.com.ar/calendar/

    Please help!

  4. whatsupmf
    Member
    Posted 2 years ago #

    Same problem here in any browser .. TwentyTen theme.. can't get Calendar or Agenda view to work, spinner won't go away.

    Would love to use this plugin if this could be fixed!

  5. josjo
    Member
    Posted 2 years ago #

    The Ajax request fails for some reason. I don't think there is one solution to all your problems.

    @paaljoachim
    When I follow the link you posted it first makes an Ajax request like so:

    http://baldron.org/wp-admin/admin-ajax.php?action=ai1ec_month

    But the server responds with an 302 (moved temporarily) and gives this location instead:

    http://byggebiologi.org/baldron/wp-admin/admin-ajax.php?action=ai1ec_month

    This request doesn't get a response. It looks like the site has been moved. Have you updated the site address in WordPress (Settings/General)?

  6. Paal Joachim Romdahl
    Member
    Posted 2 years ago #

    Josjo

    It is a multi site. The main network site is byggebiologi a sub site is baldron.org.

    I do not know what to do with it. I have registered the error as a bug at http://trac.the-seed.ca/ (do not know if it is or not though only that I am not getting it to work with the multi site).

    I changed over to Events Manager and testing that out for now. It works with the multi site but it has a higher learning curve then All In One. There are so many customizations that can be done with it, and it really does not easily guide one into them.

    Requests for a future version of All In One Calendar (and also Events Manager).
    The point is that I need an easy to use feature rich calendar.

    - A good user interface with tabs (perhaps vertical accordian style) Show only the most used and let the user decide which tabs to open. Just let it be obvious what each section is. Area for: General options, Events, Locations (adding locations) , bookings, design, etc
    - an area (click a tab ) to style the calendar.
    - create bookings (Events Manager seems to be doing this in an alright way)

    Thanks.

  7. josjo
    Member
    Posted 2 years ago #

    @paaljoachim

    I don't have any experience with multisite but from what I've gathered so far you are using some kind of domain mapping plugin to allow for the sub site to have a different domain name.

    If you are using the WordPress MU Domain Mapping plugin you could try enabling the option "Redirect administration pages to network's original".

  8. Paal Joachim Romdahl
    Member
    Posted 2 years ago #

    I checked the Settings -> Domain Mapping Configuration
    The Redirect administration pages to site's original domain -- is already checked.

    Thanks for trying...:)

    I'll post here when I get a response on the bug report I sent.

  9. josjo
    Member
    Posted 2 years ago #

    The option should be disabled not enabled. Sorry for the confusion.

  10. Paal Joachim Romdahl
    Member
    Posted 2 years ago #

    Wow that helped!

    The calendar is coming up as it should.
    http://baldron.org/kalender/

    Thanks! I will let the developers know about this as well!

    Edit...
    How will this effect the site's?

  11. josjo
    Member
    Posted 2 years ago #

    As far as I can tell the only thing you are giving up is Remote Login.

  12. moberdier
    Member
    Posted 2 years ago #

    this solved my problem too, thanks!

  13. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    Thanks josjo!

  14. smithgt
    Member
    Posted 2 years ago #

    I'm getting this problem in my new site. http://www.tbscc.co.uk

    I've AIO v1.1.2 installed

    On the Events Calendar page, I can't display an agenda. This site/domain is less than a week old, and when I only had a few events I'm sure the page redered ok.

    Any ideas?

  15. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    @smithgt
    There is a javascript error when you access the agenda page. If you have done any changes to the theme or plugins try reverting back.

  16. smithgt
    Member
    Posted 2 years ago #

    Hi, I've not changed the theme or plugins. :-(

    Should I try posting on a fresh page?

  17. smithgt
    Member
    Posted 2 years ago #

    I also have a duplicate site where I test plugins before adding them to my live site.

    This has an identical theme

    http://sandbox.smith-it.co.uk/

    Here the agenda view works - though there are less detailed events. (This site also doesn't seem to have the tick box bug in settings).

  18. smithgt
    Member
    Posted 2 years ago #

    I'm still struggling with this and have re-read this thread.

    Originally my site had the web address of tbscc.great-bentley.co.uk before I registered the domain http://www.tbscc.co.uk

    I can't honestly recall if I had the AIOEC installed at the original address. The folder on my webhost has not changed, I joust point the http://www.tbscc.co.uk to the same location.

    I then just changed the WordPress Address and Site Address under settings. If it possible that AIOEV is looking at the old location?

    Both addresses are still valid.

  19. nelra
    Member
    Posted 2 years ago #

    The error you have is related to the attendance-list plugin

    The JS error (cutoff in firebug) :
    Syntax error
    jQuery.post('http://www.tbscc.co....hp', { al_vote: param, al_postid: },

    This code is related to the attendance-list plugin:
    jQuery.post('http://www.tbscc.co.uk/wp-content/plugins/attendance-list/response.php', { al_vote: param, al_postid: }, ............

  20. smithgt
    Member
    Posted 2 years ago #

    Thank you - I've disabled that plugin and the Agenda view works!!

    Now to see if I can get the plugin fixed - or hack it myself!

    Any pointers on why it's gone wrong?

    thanks again

  21. nelra
    Member
    Posted 2 years ago #

    Good to hear it helped - I'm afraid I'm not familiar with the plugin and what may be causing the issue, but it seems to be missing "al_postid"

  22. townmorg
    Member
    Posted 2 years ago #

    Hi, I have the same problem: redirecting from widget or calender to agendas doesn't work.

    Here is my website:

    http://www.dctanoshimu.com

    If you can help me, I would much appreciate it!

  23. nelra
    Member
    Posted 2 years ago #

    Hi,

    Afraid I had no problem loading your calendar and the agenda view?
    Please let us know more about what you are experiencing, if this is still an issue for you

  24. townmorg
    Member
    Posted 2 years ago #

    I am having redirecting problem...
    I cleared all the cookies and tried, but it doesn't jump to the agenda page when I click each event on widget or calendar...

  25. Rb1368
    Member
    Posted 2 years ago #

    My calendar is not loading. Could it be because I am using go daddy's "Preview DNS" option? I think what is happening is this:

    the calendar looks for:

    http://mydomain.com/wp-admin/admin-ajax.php

    but since i am using the preview dns thing it gets:

    http://mydomain.com.previewdns.com/wp-admin/admin-ajax.php

    and thats causing it to never load.

    Am I on to something here with my problem?

  26. nelra
    Member
    Posted 2 years ago #

    Yes, if the domain is different than what is expected, this can cause problems with the AJAX
    Afraid I'm not familiar with the Preview DNS option and what workarounds could be tried

  27. Rb1368
    Member
    Posted 2 years ago #

    I think the workaround is going to be to just launch the site and the calendar will work. At least that's what I am hoping. After doing some investigation with firebug and another site using the calendar I am almost positive this is my problem.

  28. Bengacreative
    Member
    Posted 2 years ago #

    So, I had the same problem as well. It worked fine the first time that I installed it. However, when I upgraded wp core to v. 3.3.2., the bootstrap-dropdown.js, which is located in the folder: (your-website-url/plugin/all-in-one-event-calendar/themes-ai1ec/vortex/js/bootstrap-dropdown.js ), was not loaded.

    Add the code below to your site header.php and refresh, and that should do the trick.
    <script src="http://www.your-site-url.com/wp-content/plugins/all-in-one-event-calendar/themes-ai1ec/vortex/js/bootstrap-dropdown.js"></script>

    _G

  29. sauril
    Member
    Posted 2 years ago #

    Thanks for the help Bengacreative - we're releasing a js update soon that should help this problem as well.

  30. NikolayP
    Member
    Posted 1 year ago #

    I have the same problem (animated circle and word "loading") when I try to access the event page. And I don't use any of the mentioned plugins. Maybe it is somehow related to "The Daily Press" theme? Site pharmaagency.ru, please try to click random event in the widget.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic